Bug 307959 - Amarok 2.5 crashes on startup.
Summary: Amarok 2.5 crashes on startup.
Status: RESOLVED DUPLICATE of bug 258741
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.5.0
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: 2.7
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-06 07:25 UTC by peter@dharma.dyndns.info
Modified: 2012-10-08 15:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description peter@dharma.dyndns.info 2012-10-06 07:25:25 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.5 (4.8.5) "release 521"
Qt Version: 4.8.3
Operating System: Linux 3.4.2-jng6-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
Yesterday upgraded to 2.6, did nor work so downgraded to 2.5, which worked yesterday.
Today it crashes every time on start-up.

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f01db7e37a0 (LWP 6263))]

Thread 9 (Thread 0x7f01d4eda700 (LWP 6269)):
#0  0x00007f01ec919014 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f01e845d2df in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f01e845db02 in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f01e845dfa9 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f01efe34666 in QEventDispatcherGlib::processEvents (this=0x7f01d0000920, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f01efe04162 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f01efe043b7 in QEventLoop::exec (this=0x7f01d4ed9cd0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f01efd02687 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f01efde3c0f in QInotifyFileSystemWatcherEngine::run (this=0x1b93c50) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f01efd056ec in QThreadPrivate::start (arg=0x1b93c50) at thread/qthread_unix.cpp:338
#10 0x00007f01dfca8b74 in ?? () from /usr/lib64/libGL.so.1
#11 0x00007f01ec916f05 in start_thread () from /lib64/libpthread.so.0
#12 0x00007f01ee7d410d in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f01cf8c2700 (LWP 6270)):
#0  0x00007f01ec91ae6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f01efd05c5b in wait (time=18446744073709551615, this=0x2a26720) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x29fa820, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f01ebcf196b in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x29fcc50, th=0x29fa110) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f01ebcf425b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a27aa0, th=0x29fa110) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f01ebcf30cf in ThreadWeaver::ThreadRunHelper::run (this=0x7f01cf8c1d20, parent=0x29fcc50, th=0x29fa110) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/Thread.cpp:87
#6  0x00007f01ebcf315b in ThreadWeaver::Thread::run (this=0x29fa110) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/Thread.cpp:142
#7  0x00007f01efd056ec in QThreadPrivate::start (arg=0x29fa110) at thread/qthread_unix.cpp:338
#8  0x00007f01dfca8b74 in ?? () from /usr/lib64/libGL.so.1
#9  0x00007f01ec916f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f01ee7d410d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f01cf0c1700 (LWP 6271)):
#0  0x00007f01ec91ae6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f01efd05c5b in wait (time=18446744073709551615, this=0x2a26720) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x29fa820, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f01ebcf196b in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x29fcc50, th=0x2a27240) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f01ebcf425b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a27aa0, th=0x2a27240) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f01ebcf30cf in ThreadWeaver::ThreadRunHelper::run (this=0x7f01cf0c0d20, parent=0x29fcc50, th=0x2a27240) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/Thread.cpp:87
#6  0x00007f01ebcf315b in ThreadWeaver::Thread::run (this=0x2a27240) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/Thread.cpp:142
#7  0x00007f01efd056ec in QThreadPrivate::start (arg=0x2a27240) at thread/qthread_unix.cpp:338
#8  0x00007f01dfca8b74 in ?? () from /usr/lib64/libGL.so.1
#9  0x00007f01ec916f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f01ee7d410d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f01ce8c0700 (LWP 6272)):
#0  0x00007f01ec91ae6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f01efd05c5b in wait (time=18446744073709551615, this=0x2a26720) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x29fa820, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f01ebcf196b in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x29fcc50, th=0x2a27390) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f01ebcf425b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a27aa0, th=0x2a27390) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f01ebcf30cf in ThreadWeaver::ThreadRunHelper::run (this=0x7f01ce8bfd20, parent=0x29fcc50, th=0x2a27390) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/Thread.cpp:87
#6  0x00007f01ebcf315b in ThreadWeaver::Thread::run (this=0x2a27390) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/Thread.cpp:142
#7  0x00007f01efd056ec in QThreadPrivate::start (arg=0x2a27390) at thread/qthread_unix.cpp:338
#8  0x00007f01dfca8b74 in ?? () from /usr/lib64/libGL.so.1
#9  0x00007f01ec916f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f01ee7d410d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f01cde98700 (LWP 6273)):
#0  0x00007f01ec91ae6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f01efd05c5b in wait (time=18446744073709551615, this=0x2a26720) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x29fa820, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f01ebcf196b in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x29fcc50, th=0x2aa78b0) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f01ebcf425b in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a27aa0, th=0x2aa78b0) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f01ebcf4274 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a27aa0, th=0x2aa78b0) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f01ebcf4274 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a27aa0, th=0x2aa78b0) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f01ebcf4274 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a27aa0, th=0x2aa78b0) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/WorkingHardState.cpp:74
#8  0x00007f01ebcf4274 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a27aa0, th=0x2aa78b0) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/WorkingHardState.cpp:74
#9  0x00007f01ebcf4274 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a27aa0, th=0x2aa78b0) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/WorkingHardState.cpp:74
#10 0x00007f01ebcf4274 in ThreadWeaver::WorkingHardState::applyForWork (this=0x2a27aa0, th=0x2aa78b0) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/WorkingHardState.cpp:74
#11 0x00007f01ebcf30cf in ThreadWeaver::ThreadRunHelper::run (this=0x7f01cde97d20, parent=0x29fcc50, th=0x2aa78b0) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/Thread.cpp:87
#12 0x00007f01ebcf315b in ThreadWeaver::Thread::run (this=0x2aa78b0) at /usr/src/debug/kdelibs-4.8.5/threadweaver/Weaver/Thread.cpp:142
#13 0x00007f01efd056ec in QThreadPrivate::start (arg=0x2aa78b0) at thread/qthread_unix.cpp:338
#14 0x00007f01dfca8b74 in ?? () from /usr/lib64/libGL.so.1
#15 0x00007f01ec916f05 in start_thread () from /lib64/libpthread.so.0
#16 0x00007f01ee7d410d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f01cd054700 (LWP 6274)):
#0  0x00007f01ec91ae6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f01e5259f52 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f01e5259f89 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f01dfca8b74 in ?? () from /usr/lib64/libGL.so.1
#4  0x00007f01ec916f05 in start_thread () from /lib64/libpthread.so.0
#5  0x00007f01ee7d410d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f01bffff700 (LWP 6275)):
#0  0x00007f01ee7caff3 in poll () from /lib64/libc.so.6
#1  0x00007f01e845dae8 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f01e845dfa9 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f01efe34666 in QEventDispatcherGlib::processEvents (this=0x7f01b40008e0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f01efe04162 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f01efe043b7 in QEventLoop::exec (this=0x7f01bfffed00, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f01efd02687 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f01efd056ec in QThreadPrivate::start (arg=0x2a96100) at thread/qthread_unix.cpp:338
#8  0x00007f01dfca8b74 in ?? () from /usr/lib64/libGL.so.1
#9  0x00007f01ec916f05 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f01ee7d410d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f01beb85700 (LWP 6280)):
#0  0x00007f01ec91ae6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f01ead0c772 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f01eb005e80) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f01ead0c7a9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f01dfca8b74 in ?? () from /usr/lib64/libGL.so.1
#4  0x00007f01ec916f05 in start_thread () from /lib64/libpthread.so.0
#5  0x00007f01ee7d410d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f01db7e37a0 (LWP 6263)):
[KCrash Handler]
#6  QAbstractAnimation::state (this=0x31) at animation/qabstractanimation.cpp:662
#7  0x00007f01f0b67d0a in Context::ContextView::addCollapseAnimation(QAbstractAnimation*) () from /usr/lib64/libamaroklib.so.1
#8  0x00007f01f0b6485e in Context::Applet::collapse(bool) () from /usr/lib64/libamaroklib.so.1
#9  0x00007f01cdeafb13 in ?? () from /usr/lib64/kde4/amarok_context_applet_albums.so
#10 0x00007f01cdeb1029 in ?? () from /usr/lib64/kde4/amarok_context_applet_albums.so
#11 0x00007f01efe19511 in QMetaObject::activate (sender=0x29fb1b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff44f8fd20) at kernel/qobject.cpp:3556
#12 0x00007f01eb15f8b7 in Plasma::DataContainer::dataUpdated (this=<optimized out>, _t1=<optimized out>, _t2=<optimized out>) at /usr/src/debug/kdelibs-4.8.5/build/plasma/datacontainer.moc:126
#13 0x00007f01eb15fdde in Plasma::DataContainer::checkForUpdate (this=0x29fb1b0) at /usr/src/debug/kdelibs-4.8.5/plasma/datacontainer.cpp:295
#14 0x00007f01eb16168f in timerEvent (this=<optimized out>, event=<optimized out>) at /usr/src/debug/kdelibs-4.8.5/plasma/dataengine.cpp:387
#15 Plasma::DataEngine::timerEvent (this=<optimized out>, event=<optimized out>) at /usr/src/debug/kdelibs-4.8.5/plasma/dataengine.cpp:362
#16 0x00007f01efe1e409 in QObject::event (this=0x2a275c0, e=<optimized out>) at kernel/qobject.cpp:1166
#17 0x00007f01ef1880e4 in notify_helper (e=0x7fff44f90460, receiver=0x2a275c0, this=0x1d65b50) at kernel/qapplication.cpp:4557
#18 QApplicationPrivate::notify_helper (this=0x1d65b50, receiver=0x2a275c0, e=0x7fff44f90460) at kernel/qapplication.cpp:4529
#19 0x00007f01ef18ceb3 in QApplication::notify (this=0x7fff44f907e0, receiver=0x2a275c0, e=0x7fff44f90460) at kernel/qapplication.cpp:4418
#20 0x00007f01f1913156 in KApplication::notify (this=0x7fff44f907e0, receiver=0x2a275c0, event=0x7fff44f90460) at /usr/src/debug/kdelibs-4.8.5/kdeui/kernel/kapplication.cpp:311
#21 0x00007f01efe0562c in QCoreApplication::notifyInternal (this=0x7fff44f907e0, receiver=0x2a275c0, event=0x7fff44f90460) at kernel/qcoreapplication.cpp:915
#22 0x00007f01efe36418 in sendEvent (event=0x7fff44f90460, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#23 QTimerInfoList::activateTimers (this=0x1d5b9f0) at kernel/qeventdispatcher_unix.cpp:626
#24 0x00007f01efe33dcd in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#25 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#26 0x00007f01e845d5dd in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#27 0x00007f01e845ddd8 in ?? () from /usr/lib64/libglib-2.0.so.0
#28 0x00007f01e845dfa9 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#29 0x00007f01efe345ff in QEventDispatcherGlib::processEvents (this=0x1b1b000, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#30 0x00007f01ef22b91e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007f01efe04162 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007f01efe043b7 in QEventLoop::exec (this=0x7fff44f90770, flags=...) at kernel/qeventloop.cpp:204
#33 0x00007f01efe091d5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#34 0x000000000040908e in ?? ()
#35 0x00007f01ee71a23d in __libc_start_main () from /lib64/libc.so.6
#36 0x000000000040ba7d in _start ()

Possible duplicates by query: bug 307817, bug 307301, bug 307255, bug 306253, bug 304416.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-10-06 09:27:17 UTC

*** This bug has been marked as a duplicate of bug 258741 ***
Comment 2 peter@dharma.dyndns.info 2012-10-08 11:10:24 UTC
On Saturday 06 Oct 2012 09:27:17 you wrote:
> https://bugs.kde.org/show_bug.cgi?id=307959
> 
> Jekyll Wu <adaptee@gmail.com> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
> Status|UNCONFIRMED                 |RESOLVED
>          Resolution|---                         |DUPLICATE
> 
> --- Comment #1 from Jekyll Wu <adaptee@gmail.com> ---
> 
> 
> *** This bug has been marked as a duplicate of bug 258741 ***

I'm sorry for that, it took me some time before i found out that when the play 
list is removed, amarok starts up again.


Kind Regards, Peter
Comment 3 Myriam Schweingruber 2012-10-08 11:21:08 UTC
Peter, that is not the problem. You should upgrade as this is fixed in Amarok 2.6 since quite some time.
Comment 4 peter@dharma.dyndns.info 2012-10-08 11:28:12 UTC
On Monday 08 Oct 2012 11:21:08 you wrote:
> Peter, that is not the problem. You should upgrade as this is fixed in
> Amarok 2.6 since quite some time.

Thanks for your answer Myriam,
Yes i tried the 2.6 but downgraded again because the the upgrade of the 
database hangs. I can skip over that and forget about the statistics but it 
hangs again with the next startup.

Kind Regards, Peter
Comment 5 Myriam Schweingruber 2012-10-08 13:44:20 UTC
Did you report this as a separate issue with the output of amarok -d --nofork? Also running it in gdb would be helpful. But that belongs in another bug report.
Comment 6 peter@dharma.dyndns.info 2012-10-08 15:03:28 UTC
On Monday 08 Oct 2012 13:44:20 you wrote:
> Did you report this as a separate issue with the output of amarok -d
> --nofork? Also running it in gdb would be helpful. But that belongs in
> another bug report.

Thank you very much for the effort you take. Amarok is a great product for 
Linux.
I'm very happy now that Amarok works again, so it will take some time before i 
will try again the 2.6 version. Because i have been away for four mounts i 
started friday with the 2.6. 
I believe i did some reporting yesterday (maybe that went wrong) but not with 
the "-d --nofork" options.

Kind Regards, Peter