Bug 307788 - Zooming in map, Globe View, causes border to disappear
Summary: Zooming in map, Globe View, causes border to disappear
Status: RESOLVED FIXED
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: 1.3 (KDE 4.8)
Platform: Microsoft Windows Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: Thibaut Gridel
URL: http://s14.postimage.org/7bkyq6cj5/ma...
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-03 17:38 UTC by payam416
Modified: 2014-01-03 19:37 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
marble_border.jpg (39.55 KB, image/jpeg)
2012-10-03 19:45 UTC, Dennis Nienhüser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description payam416 2012-10-03 17:38:47 UTC
I have found this problem both with my widget and my stand-alone desktop version (v1.3.4). When you zoom in to certain areas of the map, such as the one shown, the border disappears. It seems to be the borders with the largest number of data points. This does not happen in the flat map views.

Reproducible: Always

Steps to Reproduce:
1. Open Marble Desktop 1.3.4, Globe view, plain map
2. Zoom into a large border, such as the one north of Mongolia (picture)
3. At close enough level, border disappears
Actual Results:  
Border disappears

Expected Results:  
Border does not disappear
Comment 1 Dennis Nienhüser 2012-10-03 19:45:08 UTC
Created attachment 74325 [details]
marble_border.jpg

Attaching the linked image to ensure it'll be accessible in the future.

Marble 1.4.1. is available for download, can you try whether the problem is fixed in there already? http://files.kde.org/marble/downloads/windows/marble-setup-1.4.1.exe
Comment 2 payam416 2012-10-03 19:59:18 UTC
Yes. I was able to recreate the same problem with 1.4.1 version as well. I am using v0.12 as the source code, and have same problem with my application
Comment 3 Thibaut Gridel 2014-01-03 19:37:07 UTC
Git commit 51e4ce5588e9d3bd59c1c8c707aa22086a25823f by Thibaut Gridel.
Committed on 03/01/2014 at 19:32.
Pushed by tgridel into branch 'master'.

VectorComposer deprecation

The following patches remove the legacy drawing code used by so-called
vector map themes, which use data sets as their base for display.
Now, all rendering is done with the unified geodata framework.

REVIEW: 110005
Related: bug 244025

M  +17   -17   data/maps/earth/plain/plain.dgml
M  +39   -35   data/maps/earth/srtm/srtm.dgml
M  +1    -1    data/maps/earth/temp-july/temp-july.dgml

http://commits.kde.org/marble/51e4ce5588e9d3bd59c1c8c707aa22086a25823f