Bug 307482 - Batch queue manager batch numbering issues.
Summary: Batch queue manager batch numbering issues.
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: BatchQueueManager-Workflow (show other bugs)
Version: 2.5.0
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-27 13:45 UTC by Steve Brown
Modified: 2016-07-04 05:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 3.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Brown 2012-09-27 13:45:46 UTC
1. I select files to be resized.  When I click 'Batch Queue Manager', the selected items appear in a second tabbed page labeled '#2'.  The page named #1 is empty and batch #2 cannot be processed until empty batch #1 is removed.

2. With empty batch #1 removed and batch #2 remaining, when you add another batch, the tab says '#2' -- there are two #2s.

Reproducible: Always

Steps to Reproduce:
1. Select files.
2. Press B.
3. In the 'Queues' section of the form, you will see two tabs, #1 and #2.
4. Remove #1.
5. Select more items and press B.
6. In the 'Queues' section of the form, you will see two tabs, #2 and #2.
Actual Results:  
In the 'Queues' section of the form, you will see two tabs, #1 and #2.  #1 is empty.

Expected Results:  
I expect the first group of selected items to go in batch #1 and the second group in batch #2.

For the first group of selected items, the software should not have added a tabbed page.  It should have used page #1, which was there already.  It doesn't seem like you can start with 0 pages, since when you try to remove all pages, you are left with page #1.
Comment 1 Steve Brown 2012-09-27 13:47:47 UTC
Version: 3.2.0-23-generic #36-Ubuntu (Linux Mint)
Comment 2 caulier.gilles 2012-09-27 14:29:04 UTC
Version: 3.2.0-23-generic #36-Ubuntu (Linux Mint) ==> What this version ID ?

Which digiKam release you use ? Go to Help menu for details...

Gilles Caulier
Comment 3 Steve Brown 2012-09-27 15:55:38 UTC
Hi Gilles,

Sorry, I gave the wrong version number.  I'm using release 2.5.0, which I selected in the drop-down list above.  Apparently, I'm a few releases behind, but that's what came with the current release of Linux Mint.  What's the best way to get a later release so I can see if this problem still exists?

Steve


(In reply to comment #2)
> Version: 3.2.0-23-generic #36-Ubuntu (Linux Mint) ==> What this version ID ?
> 
> Which digiKam release you use ? Go to Help menu for details...
> 
> Gilles Caulier
Comment 4 caulier.gilles 2012-12-22 17:44:55 UTC
Git commit ba67ae87ad5d0781bf4fb9f872e3381dd4c18c63 by Gilles Caulier.
Committed on 22/12/2012 at 18:40.
Pushed by cgilles into branch 'master'.

Fix numbering issue with BQM tab ID when one queue is removed

M  +7    -0    utilities/queuemanager/views/queuepool.cpp

http://commits.kde.org/digikam/ba67ae87ad5d0781bf4fb9f872e3381dd4c18c63
Comment 5 caulier.gilles 2012-12-22 22:00:46 UTC
For the problem #1, use CTRL+B to add item to current tab in BQM. Do not use B which add a new queue as well.