Bug 307442 - KWin crashes sometimes while switching/minimizing/maximizing windows
Summary: KWin crashes sometimes while switching/minimizing/maximizing windows
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 4.9.1
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-26 15:41 UTC by Jesse
Modified: 2012-09-26 19:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse 2012-09-26 15:41:34 UTC
Application: kwin (4.9.1)
KDE Platform Version: 4.9.1 (Compiled from sources)
Qt Version: 4.8.3
Operating System: Linux 3.5.4-zen x86_64
Distribution: "Gentoo Base System release 2.2"

-- Information about the crash:
- What I was doing when the application crashed:
Just switching/minimizing/maximizing a window from the task manager. This might be a mesa bug rather than kwin but please check.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f26e12ff7c0 (LWP 23750))]

Thread 2 (Thread 0x7f26cd928700 (LWP 23768)):
#0  0x00007f26f1c06d6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f26f38410c7 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f26f3b2a5e0 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f26f38410f9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f26f1c02fea in start_thread () from /lib64/libpthread.so.0
#4  0x00007f26efbf1d7d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f26e12ff7c0 (LWP 23750)):
[KCrash Handler]
#5  0x00007f26ce6c3d65 in i915_set_vertex_buffers (pipe=0xae8cd0, count=1, buffers=<optimized out>) at i915_state.c:1000
#6  0x00007f26ce86347f in update_array (st=0xbab220) at ../../src/mesa/state_tracker/st_atom_array.c:577
#7  0x00007f26ce862eb7 in st_validate_state (st=st@entry=0xbab220) at ../../src/mesa/state_tracker/st_atom.c:223
#8  0x00007f26ce86967b in st_Clear (ctx=0xb42010, mask=2) at ../../src/mesa/state_tracker/st_cb_clear.c:457
#9  0x00007f26f68b65fc in KWin::SceneOpenGL::paintBackground (this=this@entry=0x905a70, region=...) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/scene_opengl.cpp:186
#10 0x00007f26f68a56df in KWin::Scene::paintGenericScreen (this=0x905a70, orig_mask=32) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/scene.cpp:200
#11 0x00007f26f68b2491 in KWin::SceneOpenGL::paintGenericScreen (this=0x905a70, mask=32, data=...) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/scene_opengl.cpp:173
#12 0x00007f26f68a423a in KWin::Scene::finalPaintScreen (this=0x905a70, mask=32, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/scene.cpp:190
#13 0x00007f26f68c3523 in KWin::EffectsHandlerImpl::paintScreen (this=0xbb80c0, mask=mask@entry=32, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/effects.cpp:244
#14 0x00007f26f30af1a7 in KWin::Effect::paintScreen (this=this@entry=0xd26040, mask=mask@entry=32, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/libkwineffects/kwineffects.cpp:142
#15 0x00007f26f68c34cb in KWin::EffectsHandlerImpl::paintScreen (this=0xbb80c0, mask=mask@entry=32, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/effects.cpp:241
#16 0x00007f26f30af1a7 in KWin::Effect::paintScreen (this=this@entry=0xf5d290, mask=mask@entry=32, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/libkwineffects/kwineffects.cpp:142
#17 0x00007f26f68c34cb in KWin::EffectsHandlerImpl::paintScreen (this=0xbb80c0, mask=mask@entry=32, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/effects.cpp:241
#18 0x00007f26f30af1a7 in KWin::Effect::paintScreen (this=this@entry=0xabdb40, mask=mask@entry=32, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/libkwineffects/kwineffects.cpp:142
#19 0x00007f26f68c34cb in KWin::EffectsHandlerImpl::paintScreen (this=0xbb80c0, mask=mask@entry=32, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/effects.cpp:241
#20 0x00007f26f30af1a7 in KWin::Effect::paintScreen (this=this@entry=0xee4b60, mask=mask@entry=32, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/libkwineffects/kwineffects.cpp:142
#21 0x00007f26f68c34cb in KWin::EffectsHandlerImpl::paintScreen (this=0xbb80c0, mask=mask@entry=32, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/effects.cpp:241
#22 0x00007f26f30af1a7 in KWin::Effect::paintScreen (this=this@entry=0xf6c850, mask=mask@entry=32, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/libkwineffects/kwineffects.cpp:142
#23 0x00007f26f68c34cb in KWin::EffectsHandlerImpl::paintScreen (this=0xbb80c0, mask=32, region=..., data=...) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/effects.cpp:241
#24 0x00007f26f68a589b in KWin::Scene::paintScreen (this=0x905a70, mask=0x7fff5a85b12c, region=0x7fff5a85b1d0) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/scene.cpp:146
#25 0x00007f26f68ba2b2 in KWin::SceneOpenGL::paint (this=0x905a70, damage=..., toplevels=...) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/scene_opengl_glx.cpp:481
#26 0x00007f26f689f468 in KWin::Workspace::performCompositing (this=0x875960) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/composite.cpp:440
#27 0x00007f26f1fa50bc in QObject::event (this=0x875960, e=<optimized out>) at kernel/qobject.cpp:1157
#28 0x00007f26f114c09c in QApplicationPrivate::notify_helper (this=this@entry=0x6c35c0, receiver=receiver@entry=0x875960, e=e@entry=0x7fff5a85b8b0) at kernel/qapplication.cpp:4557
#29 0x00007f26f115051a in QApplication::notify (this=0x7fff5a85bee0, receiver=0x875960, e=0x7fff5a85b8b0) at kernel/qapplication.cpp:4418
#30 0x00007f26f2c7a7e6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#31 0x00007f26f1f909ae in QCoreApplication::notifyInternal (this=0x7fff5a85bee0, receiver=0x875960, event=0x7fff5a85b8b0) at kernel/qcoreapplication.cpp:915
#32 0x00007f26f1fc12b2 in sendEvent (event=0x7fff5a85b8b0, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#33 QTimerInfoList::activateTimers (this=0x6c40d8) at kernel/qeventdispatcher_unix.cpp:611
#34 0x00007f26f1fc1310 in QEventDispatcherUNIX::activateTimers (this=this@entry=0x6c2e20) at kernel/qeventdispatcher_unix.cpp:868
#35 0x00007f26f1fc1468 in QEventDispatcherUNIX::processEvents (this=0x6c2e20, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#36 0x00007f26f11ec3b7 in QEventDispatcherX11::processEvents (this=0x6c2e20, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#37 0x00007f26f1f8f6ff in QEventLoop::processEvents (this=this@entry=0x7fff5a85bbf0, flags=...) at kernel/qeventloop.cpp:149
#38 0x00007f26f1f8f988 in QEventLoop::exec (this=0x7fff5a85bbf0, flags=...) at kernel/qeventloop.cpp:204
#39 0x00007f26f1f94628 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#40 0x00007f26f68591f4 in kdemain (argc=3, argv=0x7fff5a85c028) at /var/tmp/portage/kde-base/kwin-4.9.1-r1/work/kwin-4.9.1/kwin/main.cpp:545
#41 0x00007f26efb2d495 in __libc_start_main () from /lib64/libc.so.6
#42 0x0000000000400911 in _start ()

Reported using DrKonqi
Comment 1 Thomas Lübking 2012-09-26 19:37:37 UTC
crashes in glClear(GL_COLOR_BUFFER_BIT);

It's the intel bug.

*** This bug has been marked as a duplicate of bug 252817 ***