Bug 307416 - Buttons on dock widgets rendered wrong when small icon size != 16
Summary: Buttons on dock widgets rendered wrong when small icon size != 16
Status: RESOLVED FIXED
Alias: None
Product: Oxygen
Classification: Plasma
Component: style (show other bugs)
Version: Git
Platform: unspecified Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-25 23:15 UTC by Christoph Feck
Modified: 2012-10-02 13:25 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.2


Attachments
Screen shot showing the issue (please excuse rotated RGB subpixels ;) (18.34 KB, image/png)
2012-09-25 23:15 UTC, Christoph Feck
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Feck 2012-09-25 23:15:14 UTC
Created attachment 74176 [details]
Screen shot showing the issue (please excuse rotated RGB subpixels ;)

To reproduce:
- change "Small" icons size in System Settings to a value > 16
- run a program that uses dock widgets, e.g. "designer"

See screen shot for the issue.
Comment 1 Hugo Pereira Da Costa 2012-09-29 16:32:10 UTC
Can reproduce (of course :)) though I did not know this size could be changed.
On it. (should be easy)
Comment 2 Hugo Pereira Da Costa 2012-09-29 16:58:43 UTC
Git commit efa70028f78f816d5da63143b482a022e96d7e84 by Hugo Pereira Da Costa.
Committed on 29/09/2012 at 18:57.
Pushed by hpereiradacosta into branch 'master'.

Properly scale dock window icons before painting.

M  +1    -0    kstyles/oxygen/oxygenstyle.cpp

http://commits.kde.org/kde-workspace/efa70028f78f816d5da63143b482a022e96d7e84
Comment 3 Hugo Pereira Da Costa 2012-09-29 17:01:17 UTC
Git commit 4f3e55f8df50914b1fe19ec238c977e2aa3d7c1c by Hugo Pereira Da Costa.
Committed on 29/09/2012 at 18:57.
Pushed by hpereiradacosta into branch 'KDE/4.9'.

Properly scale dock window icons before painting.

M  +1    -0    kstyles/oxygen/oxygenstyle.cpp

http://commits.kde.org/kde-workspace/4f3e55f8df50914b1fe19ec238c977e2aa3d7c1c
Comment 4 Albert Astals Cid 2012-10-02 13:25:47 UTC
The bug has been included in 4.9.2 due to a respin of the tarballs needed to fix a different more critical issue.