Bug 307386 - In the file browser, Ctrl-clicking and ending Shift-clicking does the same as normal clicking
Summary: In the file browser, Ctrl-clicking and ending Shift-clicking does the same as...
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: File Browser (show other bugs)
Version: 2.6-git
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: 2.7
Assignee: Amarok Developers
URL:
Keywords: release_blocker
: 253225 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-25 15:53 UTC by Andreas Hartmetz
Modified: 2013-01-01 23:16 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.7


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Hartmetz 2012-09-25 15:53:25 UTC
When trying to select or deselect a file or folder in the file browser using Ctrl-click, the file or folder is opened instead.

Reproducible: Always
Comment 1 Matěj Laitl 2012-12-15 10:49:36 UTC
Yes, looking into it for the 2.7 final.
Comment 2 Matěj Laitl 2012-12-15 10:50:23 UTC
*** Bug 253225 has been marked as a duplicate of this bug. ***
Comment 3 Matěj Laitl 2012-12-16 00:46:13 UTC
Andreas, why did you add that, ehm, adult site link as URL? ;)
Comment 4 Matěj Laitl 2013-01-01 23:16:43 UTC
Git commit b2149a74c29734f206674c14d65f52c006437f56 by Matěj Laitl.
Committed on 01/01/2013 at 23:55.
Pushed by laitl into branch 'master'.

FileView, FileBrowser: rework of keyboard, mouse & context menu behaviour

Also, some minor fixes to enable smooth keyboard navigation are done

CHANGES:
 * Harmonize keyboard, mouse and context menu behaviour of the Files pane
   so that it matches Local Music and Saved Playlists panes.
FIXED-IN: 2.7

M  +2    -0    ChangeLog
M  +1    -0    src/browsers/CollectionTreeView.cpp
M  +82   -80   src/browsers/filebrowser/FileBrowser.cpp
M  +20   -1    src/browsers/filebrowser/FileBrowser.h
M  +189  -150  src/browsers/filebrowser/FileView.cpp
M  +25   -14   src/browsers/filebrowser/FileView.h

http://commits.kde.org/amarok/b2149a74c29734f206674c14d65f52c006437f56