Bug 307307 - NTFS drives are mounted as case sensitive file systems instead of case insensitive ones
Summary: NTFS drives are mounted as case sensitive file systems instead of case insens...
Status: RESOLVED INTENTIONAL
Alias: None
Product: solid
Classification: Unclassified
Component: libsolid-udisks (show other bugs)
Version: 4.9.1
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Lukáš Tinkl
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-24 07:28 UTC by Xwang
Modified: 2012-10-22 09:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xwang 2012-09-24 07:28:08 UTC
When I mount NTFS usb external drive with the device notifier applet, the file system is mounted as a case sensitive one creating issues when the same hard disk is used in a Windows environment (the only reason I can see to use an NTFS partition is to share data between Linux and Windows).
The applet should mount NTFS via lowntfs -o windows_names -o ignore_case by default or, at least, leave the user the option to select if mounting NTFS as case sensitive or case insensitive system.

 

Reproducible: Always

Steps to Reproduce:
1. Attach an NTFS usb drive
2. Mount it with the device manager applet
3. Go to the mount folder and create two directories named test and Test respectively
Actual Results:  
Both directory are created

Expected Results:  
The second directory should not be created because, if system is case insensitive, as it is supposed to be in Windows, the directory whit the same name already exists.
Comment 1 Xwang 2012-10-07 12:27:41 UTC
As a workaround, I've created a bash script named ntfs-3g.sh in /usr/bin, I've made it executable and changed the actual links

mount.lowntfs-3g -> lowntfs-3g
mount.ntfs -> ntfs-3g
mount.ntfs-3g -> ntfs-3g

to

mount.lowntfs-3g -> lowntfs-3g
mount.ntfs -> ntfs-3g.sh
mount.ntfs-3g -> ntfs-3g.sh

The bash script contains the following lines:

#!/bin/bash

lowntfs-3g -o windows_names -o ignore_case $@
Comment 2 Xwang 2012-10-20 13:00:33 UTC
(In reply to comment #1)
> As a workaround, I've created a bash script named ntfs-3g.sh in /usr/bin,
> I've made it executable and changed the actual links
> 
> mount.lowntfs-3g -> lowntfs-3g
> mount.ntfs -> ntfs-3g
> mount.ntfs-3g -> ntfs-3g
> 
> to
> 
> mount.lowntfs-3g -> lowntfs-3g
> mount.ntfs -> ntfs-3g.sh
> mount.ntfs-3g -> ntfs-3g.sh
> 
> The bash script contains the following lines:
> 
> #!/bin/bash
> 
> lowntfs-3g -o windows_names -o ignore_case $@

The above workaround does not work as expected.
So the bug is confirmed as exposed above.
Comment 3 Lukáš Tinkl 2012-10-22 09:41:51 UTC
Please report this bug to upstream udisks bugzilla at https://bugs.freedesktop.org/enter_bug.cgi?product=udisks