Bug 306943 - Broken font rendering in some applications
Summary: Broken font rendering in some applications
Status: RESOLVED NOT A BUG
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: 4.9
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-17 16:44 UTC by Nikos Chantziaras
Modified: 2012-10-29 07:39 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
The process list shown through krunner. (99.89 KB, image/png)
2012-09-17 16:45 UTC, Nikos Chantziaras
Details
The process list shown through ksysguard. (128.75 KB, image/png)
2012-09-17 16:45 UTC, Nikos Chantziaras
Details
The process list shown through ksysguard using "-graphicssystem native". (115.58 KB, image/png)
2012-09-17 16:46 UTC, Nikos Chantziaras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikos Chantziaras 2012-09-17 16:44:31 UTC
It seems that some applications (for example krunner and ksnapshot) display fonts in a somewhat broken manner. To demonstrate, I attached a screenshot of krunner's "System Activity" in krunner_process_list.png. Look at how "Shared Mem" is rendered, for example. And the same process list display, but through "System Monitor" is in ksysguard_process_list.png. Notice how "System Monitor" has correct font display.  I found out that I can trigger the same bug in System Monitor if I launch it with:

  ksysguard -graphicssystem native

Then it looks like in screenshot ksysguard_process_list_native.png. Look for example at how the word "Table" (in "Process Table") is rendered compared to the previous screenshot.

Another application that has the same problem is KSnapshot.  And indeed, if I launch it manually with:

  ksnapshot -graphicssystem raster

then the problem goes away.

In System Settings, in the Desktop Effects section's "Advanced" tab, I have "Raster" set as the "Qt graphics system".  My Linux distro (Gentoo) also has this set in the environment:

  QT_GRAPHICSSYSTEM=raster

It would seem that some KDE application ignore those settings.

Reproducible: Always

Steps to Reproduce:
1. Press Alt+F2 (or whatever shortcut you've set to bring up krunner.)
2. Click the "System Activity" button.
Actual Results:  
Fonts look weird.

Expected Results:  
Fonts should look the same as everywhere else.

Gentoo Linux 64-bit, KDE 4.9.1, Qt 4.8.3. The graphics driver doesn't seem to affect this; the problem is there with the official NVidia driver, the AMD Catalyst driver, and the open source xf86-video-ati driver.
Comment 1 Nikos Chantziaras 2012-09-17 16:45:20 UTC
Created attachment 73981 [details]
The process list shown through krunner.
Comment 2 Nikos Chantziaras 2012-09-17 16:45:55 UTC
Created attachment 73982 [details]
The process list shown through ksysguard.
Comment 3 Nikos Chantziaras 2012-09-17 16:46:29 UTC
Created attachment 73983 [details]
The process list shown through ksysguard using "-graphicssystem native".
Comment 4 Christoph Feck 2012-09-17 17:37:39 UTC
Please report to Qt developers via https://bugreports.qt-project.org/

The applications you mentioned need to run with native graphicssystem to access certain X11 resources that are unavailable with raster graphicssystem.
Comment 5 Nikos Chantziaras 2012-09-17 18:04:44 UTC
OK: https://bugreports.qt-project.org/browse/QTBUG-27257
Comment 6 Nikos Chantziaras 2012-10-01 11:54:01 UTC
Reopening, since upstream rejected the bug "because the native graphics system on X11 is no longer supported". Leaving it as "resolved upstream" doesn't make sense now.

I guess KDE will have to deal with this. For what it's worth, ksnapshot works correctly here when manually forcing raster instead of native. I don't know how to force krunner to use raster.
Comment 7 Christoph Feck 2012-10-01 14:22:30 UTC
I have locally compiled KRunner and KSnapshot to not force "native" mode.

KRunner: Broken feedback mouse cursor icon
KSnapshot: Corrupted snapshots in "Section of Window" mode

If you want these applications to work correctly with raster, please report to those applications separately, since they have to be changed separately.
Comment 8 valdikss 2012-10-29 07:39:23 UTC
Affects me too, I fixed it like this:
Start shortcut manager, replace "ksnapshot" with "ksnapshot -graphicssystem raster"

Open /usr/share/autostart/krunner.desktop
replace "Exec=krunner" with "Exec=krunner -graphicssystem raster"