Bug 306825 - impossible to start any torrent: error "One or more storage volumes are not mounted.."
Summary: impossible to start any torrent: error "One or more storage volumes are not m...
Status: RESOLVED DUPLICATE of bug 308638
Alias: None
Product: ktorrent
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Linux
: NOR major with 2 votes (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
: 308095 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-15 10:00 UTC by Eugenio
Modified: 2014-07-24 15:07 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugenio 2012-09-15 10:00:56 UTC
I can not start any torrent, every time an error message tell me to mount the storage volumes.

The error message is "One or more storage volumes are not mounted. In order to start this torrent, they need to be mounted."
Obviously I download the torrent in my home, not in a external storage volume.

Ktorrent 4.3.0 libktorrent 1.3.0
I'm sorry for my bad english

Reproducible: Always

Steps to Reproduce:
1. add a torrent and start it
2. this error message appear
Actual Results:  
I can't download anything

Expected Results:  
The torrent should start, if I save the file in my internal hard disk
Comment 1 Joris Guisson 2012-09-17 11:11:14 UTC
Is /home a separate partition ? 

For each torrent, ktorrent will create a torX (with X being a number) directory in ~/.kde/share/apps/ktorrent/

These directories will contain a file name mount_points, which contains a list of mount_points for each torrent, what is in those files ?
Comment 2 Eugenio 2012-09-17 11:47:55 UTC
I use btrfs and /home is a subvolume, so I don't know if it can be considered a different partition.

I have a subvolume that is the root tree for the system, this subvolume contains the home subvolume.

The file mount_points is empty, but if I delete it the problem is solved and I can start the downloading!
But if I add a new torrent I have to delete this file, otherwise ktorrent show the error.

Thank you!
Comment 3 Joris Guisson 2012-09-17 13:42:20 UTC
OK, when I start downloading a torrent to a btrfs subvolume, it starts but the mount point gets wrongfully detected as /
Comment 4 Joris Guisson 2012-09-17 14:46:20 UTC
The problem is that the method I'm using to get all the mount points (using KDE's solid library), doesn't seem to handle btrfs subvolumes properly.

I have created a bug for this: bug 306937)

I'm gonna add a workaround for this until this is fixed in kdelibs.
Comment 5 Eugenio 2012-09-17 15:13:04 UTC
Ok, so it's a problem related to btrfs. I should have expected it!

Thanks!
Comment 6 Andriy Gapon 2012-09-22 14:11:49 UTC
I experience what looks like exactly the same problem with ZFS/FreeBSD with KTorrent 4.3.0.
I checked mount_points file and it originally contained only a single space character.
Even if I change the file (when KTorrent) is not running to contain either a proper mount point directory name or ZFS dataset name, KTorrent still insists that the volume is not mounted.

Maybe I am using incorrect format for  mount_points?  What should it be?
Also, is there a way to disable this feature?
Comment 7 Andriy Gapon 2012-09-22 14:16:19 UTC
OK, found a workaround - completely clearing the file.
But having to do that is an annoyance.
Comment 8 Joris Guisson 2012-09-24 09:08:20 UTC
Git commit 4ffaa9e1e80dac501b4c3def9740520edb6d14d5 by Joris Guisson.
Committed on 24/09/2012 at 11:07.
Pushed by guisson into branch 'master'.

Add workaround for broken handling of btrfs subvolumes by solid

M  +3    -0    ChangeLog
M  +43   -22   src/util/fileops.cpp

http://commits.kde.org/libktorrent/4ffaa9e1e80dac501b4c3def9740520edb6d14d5
Comment 9 Joris Guisson 2012-09-24 09:09:13 UTC
Git commit f76e1b0b637e53af64ecd813e8541019e50bb8bb by Joris Guisson.
Committed on 24/09/2012 at 11:07.
Pushed by guisson into branch '1.3'.

Backport to 1.3: Add workaround for broken handling of btrfs subvolumes by solid

M  +3    -0    ChangeLog
M  +43   -22   src/util/fileops.cpp

http://commits.kde.org/libktorrent/f76e1b0b637e53af64ecd813e8541019e50bb8bb
Comment 10 Andriy Gapon 2012-09-24 10:32:12 UTC
ls -l /proc/mounts
ls: /proc/mounts: No such file or directory

Sorry, !Windows != Linux.
Comment 11 Joris Guisson 2012-09-24 10:38:48 UTC
(In reply to comment #10)
> ls -l /proc/mounts
> ls: /proc/mounts: No such file or directory
> 
> Sorry, !Windows != Linux.

Your point being ?
Comment 12 Andriy Gapon 2012-09-24 10:41:15 UTC
Will your latest change work well on FreeBSD, other BSDs and etc?
Comment 13 Max 2012-09-24 14:40:35 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > ls -l /proc/mounts
> > ls: /proc/mounts: No such file or directory
> > 
> > Sorry, !Windows != Linux.
> 
> Your point being ?

This fix is for linux only, thus you should check for Q_OS_LINUX rather than for !Q_WS_WIN
Comment 14 grundik-com 2012-10-05 17:38:28 UTC
Seems like this issue also appears, when kde started in chroot.
Comment 15 Joris Guisson 2012-10-18 18:57:36 UTC
*** Bug 308095 has been marked as a duplicate of this bug. ***
Comment 16 Manuel Arguelles 2012-10-24 13:23:51 UTC
Hello,

I'm getting this for every single torrent, KTorrent Version 4.3.0 Using KDE Development Platform 4.9.2. (kdelibs: 4.9.2-2)

I don't know what btrfs subvolumes are so probably I'm not using it. 

My filesystem is mounted in /:
/dev/sda3         820G  139G  640G  18% /
and I have 
/dev/mapper/something  94G   55G   35G  62% /home/user/something

But the torrent is not downloaded into /home/user/something, it goes into /home/user/downloads

cat /home/user/.kde4/share/apps/ktorrent/tor104/mount_points

Nothing, file just has a 0x0A character (new line) So, what should I do?
Comment 17 Toderel Adrian-Aurel 2012-10-28 12:54:20 UTC
this bug has no business with fs type, ie btrfs! i have LVM and over it ext4 fs partitions and i see same stupid shit with this last version!

equo search net-p2p/ktorrent
>>  @@ Searching...
>>      @@ Package: net-p2p/ktorrent-4.3.0 branch: 5, [sabayonlinux.org] 
>>         Available:     version: 4.3.0 ~ tag: NoTag ~ revision: 0
>>         Installed:     version: 4.3.0 ~ tag: NoTag ~ revision: 0
>>         Slot:          4
>>         Homepage:      http://ktorrent.org/ 
>>         Description:   A BitTorrent program for KDE. 
>>         License:       GPL-2
>>  Keywords:  net-p2p/ktorrent
>>  Found:     1 entry

previous version,  was a working one 

in ktorrent log file i see this:

Sun Oct 28 13:58:29 2012: Qt Debug: ktorrent(8299)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
Sun Oct 28 13:58:31 2012: FreeBytes 49,97 GiO
Sun Oct 28 13:58:31 2012: Downloaded 0 O
Sun Oct 28 13:58:31 2012: Remaining 13,96 GiO
Sun Oct 28 13:58:31 2012: FreeBytes 49,97 GiO
Sun Oct 28 13:58:31 2012: Downloaded 0 O
Sun Oct 28 13:58:31 2012: Remaining 13,96 GiO
Sun Oct 28 13:58:31 2012: Starting download « PRIVATE INFO »
Sun Oct 28 13:58:31 2012: UTP: established connection with 64.56.228.175
Sun Oct 28 13:58:33 2012: UTP: Connection 29687|29688 closed 
Sun Oct 28 13:58:35 2012: Error : Storage volume  is not mounted
Sun Oct 28 13:58:35 2012: Adding group for tracker tracker.ccc.de
Sun Oct 28 13:58:35 2012: Adding group for tracker tracker.istole.it
Sun Oct 28 13:58:35 2012: Adding group for tracker tracker.openbittorrent.com
Sun Oct 28 13:58:35 2012: Adding group for tracker tracker.publicbt.com

my proc mounts file is here, my partitions is ok, can read and write files and so on ... judging from log messages my partition, where i selected to be downloaded, is detected and free space corectly counted!

then why this stupid error!? what means storage volumes!? martian aliens!? my partitions is here and any other apps from my $PATH can read and write files! what else a torrent app needs!?

in ktorrent config menu i deselected any implicit file paths and all advanced antifragmentation and prealocation file options and still not working ... jumped over magnets and tried with manually downloaded torrent seeds, no luck ...

i know for sure ktorrent 4.2.1 was a very stable one, working beautifully, because in previous month i downloaded 80 GiB of torrent movies with 1:2 seed ratio, this means i pushed up 160 GiB of data and ktorrent 4.2.1 and my desktop has an almost  two weeks continuous uptime! no crash. light cpu usage, beautiful interface ... i really begin to love this kde app! 

ktorrent is one of the best torrent app in the linux world and someone managed to stuck it in an incomprehensible stone wall
Comment 18 Manuel Arguelles 2012-10-29 12:23:29 UTC
(In reply to comment #17)
What Andriy Gapon said seems to work, select the torrent with the red X (the one that is having the bug), go to Advanced -> Open Directory -> Temporary Directory. You will see a file called mount_points, close ktorrent, remove that file, open ktorrent again...

Works but it is annoying as hell...
Comment 19 Emmett Culley 2012-10-30 23:04:25 UTC
The above no no difference.  After stopping ktorrent, deleting mount_points and restarting ktorrent.  I got the same error and mount_points was recreated with the same contents (/fs1/work).
Comment 20 BrainDrain 2012-11-09 15:29:16 UTC
Same problem here. The older version, i think that one included in kde 4.9.1, worked like a charm. I can't use ktorrent.
Comment 21 BrainDrain 2012-11-09 15:46:23 UTC
I downgraded back to ktorrent 4.2.1 and libktorrent 1.2.1, now it works.

https://bugs.archlinux.org/task/31499
Comment 22 Maciej Mrozowski 2012-11-26 22:29:36 UTC
Please reopen as issue is not fixed at all.

Taking 1.3.0 tarball, I applied all git patches from 1.3 branch since v1.3.0 tag (including the one mentioned here), and bug is still there. On Linux.
(regulars cannot reopen bugs here anymore?)
Comment 23 Guido Winkelmann 2012-11-27 00:14:27 UTC
I am also experiencing the described problems (on KTorrent 4.3.0) but I am not using btrfs, I'm using ext4 on all my partitions.

Just in case anybody still thinks this is a btrfs- or zfs related bug...
Comment 24 Conrad 2012-12-01 16:48:10 UTC
I, too, experience this problem. /home is a ext4 partition and problem exists since updating to 4.3.0 on my gentoo system.
Comment 25 darkbasic 2012-12-02 23:42:53 UTC
The same with ext4. Please reopen.
Comment 26 Christoph Feck 2012-12-06 12:57:40 UTC
Reopen, based on comment #22.
Comment 27 Joris Guisson 2012-12-08 11:37:05 UTC
All these problems should be resolved by the fix for bug 308638, which is in ktorrent and not in libktorrent (so the person of comment #22 tested the wrong thing).

Btw, anybody running ktorrent in a chroot without mounting /proc and /dev in that chroot, is asking for problems.

*** This bug has been marked as a duplicate of bug 308638 ***
Comment 28 Maciej Mrozowski 2012-12-08 14:16:51 UTC
Btw, person in comment #22 tested the fix for _this_ bug as proposed by yourself in  comment #8 :)

Git commit f76e1b0b637e53af64ecd813e8541019e50bb8bb by Joris Guisson.
Committed on 24/09/2012 at 11:07.
Pushed by guisson into branch '1.3'.

Backport to 1.3: Add workaround for broken handling of btrfs subvolumes by solid

M  +3    -0    ChangeLog
M  +43   -22   src/util/fileops.cpp

http://commits.kde.org/libktorrent/f76e1b0b637e53af64ecd813e8541019e50bb8bb
Comment 29 Emmett Culley 2012-12-08 19:27:16 UTC
This problem is fixed for me in version 4.3.0.  This was NOT a btrfs specific issue as the directory that ktorrent failed to access was an NFS4 share.
Comment 30 darkbasic 2012-12-08 19:42:03 UTC
Agree, it definitely isn't btrfs specific.
Comment 31 harrypanagopulos 2012-12-18 17:21:23 UTC
(In reply to comment #18)
> (In reply to comment #17)
> What Andriy Gapon said seems to work, select the torrent with the red X (the
> one that is having the bug), go to Advanced -> Open Directory -> Temporary
> Directory. You will see a file called mount_points, close ktorrent, remove
> that file, open ktorrent again...
> 
> Works but it is annoying as hell...

The following will save you a lot of time 
$ find /home/whateveryourhomeiscalled/.kde4/ -name "mount_points" -exec rm -i {} \
Comment 32 Gregory M. Turner 2012-12-22 05:03:12 UTC
The bug is not fixed.  It has nothing to do with btrfs, I don't use that filesystem and I have this bug.  Others on the interweb claim this is caused by using magnet links in chrome -- that is indeed where I have been encountering the problem.

Here is a backtrace of the code leading up to the error on my ktorrent-4.3.0 build:

#0  0x000000386c6e11fd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x000000387164aa04 in g_main_context_poll (n_fds=11, fds=0x2b821e0, timeout=136, context=0x22d4650, priority=<optimized out>) at gmain.c:3440
#2  g_main_context_iterate (context=context@entry=0x22d4650, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3141
#3  0x000000387164ab2c in g_main_context_iteration (context=0x22d4650, may_block=1) at gmain.c:3207
#4  0x0000003873bab106 in QEventDispatcherGlib::processEvents (this=0x2298b30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x000000387427bdc6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#6  0x0000003873b7b7ef in QEventLoop::processEvents (this=this@entry=0x7fff74fe7050, flags=...) at kernel/qeventloop.cpp:149
#7  0x0000003873b7bad0 in QEventLoop::exec (this=0x7fff74fe7050, flags=...) at kernel/qeventloop.cpp:204
#8  0x00000038746743e7 in QDialog::exec (this=0x22ea1d0) at dialogs/qdialog.cpp:554
#9  0x000000387bdc4b7a in KMessageBox::createKMessageBox (dialog=dialog@entry=0x22ea1d0, icon=..., text=..., strlist=..., ask=..., checkboxReturn=checkboxReturn@entry=0x7fff74fe747f, 
    options=..., details=..., notifyType=notifyType@entry=QMessageBox::Warning) at /usr/src/debug/kde-base/kdelibs-4.9.3/kdelibs-4.9.3/kdeui/dialogs/kmessagebox.cpp:344
#10 0x000000387bdc5127 in KMessageBox::createKMessageBox (dialog=dialog@entry=0x22ea1d0, icon=icon@entry=QMessageBox::Warning, text=..., strlist=..., ask=..., 
    checkboxReturn=checkboxReturn@entry=0x7fff74fe747f, options=..., details=...) at /usr/src/debug/kde-base/kdelibs-4.9.3/kdelibs-4.9.3/kdeui/dialogs/kmessagebox.cpp:159
#11 0x000000387bdc8365 in warningContinueCancelListWId (options=..., dontAskAgainName=..., buttonCancel_=..., buttonContinue_=..., caption=..., strlist=..., text=..., 
    parent_id=62914580) at /usr/src/debug/kde-base/kdelibs-4.9.3/kdelibs-4.9.3/kdeui/dialogs/kmessagebox.cpp:715
#12 KMessageBox::warningContinueCancelListWId (parent_id=62914580, text=..., strlist=..., caption=..., buttonContinue_=..., buttonCancel_=..., dontAskAgainName=..., options=...)
    at /usr/src/debug/kde-base/kdelibs-4.9.3/kdelibs-4.9.3/kdeui/dialogs/kmessagebox.cpp:680
#13 0x000000387bdc853e in KMessageBox::warningContinueCancelList (parent=<optimized out>, text=..., strlist=..., caption=..., buttonContinue=..., buttonCancel=..., 
    dontAskAgainName=..., options=...) at /usr/src/debug/kde-base/kdelibs-4.9.3/kdelibs-4.9.3/kdeui/dialogs/kmessagebox.cpp:677
#14 0x0000000000432881 in kt::Core::checkMissingFiles (this=0x2412c00, tc=0x2d990a0) at /usr/src/debug/net-p2p/ktorrent-4.3.0/ktorrent-4.3.0/ktorrent/core.cpp:1214
#15 0x0000000000433569 in kt::Core::aboutToBeStarted (this=<optimized out>, tc=<optimized out>, ret=@0x7fff74fe7adf: true)
    at /usr/src/debug/net-p2p/ktorrent-4.3.0/ktorrent-4.3.0/ktorrent/core.cpp:1313
#16 0x0000000000436880 in kt::Core::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>)
    at /usr/src/debug/net-p2p/ktorrent-4.3.0/ktorrent-4.3.0_build/ktorrent/core.moc:152
#17 0x0000003873b9227f in QMetaObject::activate (sender=0x2d990a0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff74fe7aa0) at kernel/qobject.cpp:3547
#18 0x00000038752c0317 in bt::TorrentInterface::aboutToBeStarted (this=<optimized out>, _t1=0x2d990a0, _t2=<optimized out>)
    at /usr/src/debug/net-libs/libktorrent-1.3.0/libktorrent-1.3.0_build/src/torrentinterface.moc:166
#19 0x00000038752d5d77 in bt::TorrentControl::start (this=0x2d990a0) at /usr/src/debug/net-libs/libktorrent-1.3.0/libktorrent-1.3.0/src/torrent/torrentcontrol.cpp:397
#20 0x000000387563b971 in kt::QueueManager::startSafely (this=this@entry=0x2412a60, tc=tc@entry=0x2d990a0)
    at /usr/src/debug/net-p2p/ktorrent-4.3.0/ktorrent-4.3.0/libktcore/torrent/queuemanager.cpp:731
#21 0x000000387563baf4 in startInternal (tc=0x2d990a0, this=0x2412a60) at /usr/src/debug/net-p2p/ktorrent-4.3.0/ktorrent-4.3.0/libktcore/torrent/queuemanager.cpp:102
#22 kt::QueueManager::startInternal (this=0x2412a60, tc=0x2d990a0) at /usr/src/debug/net-p2p/ktorrent-4.3.0/ktorrent-4.3.0/libktcore/torrent/queuemanager.cpp:91
#23 0x000000387563d9f6 in kt::QueueManager::orderQueue (this=this@entry=0x2412a60) at /usr/src/debug/net-p2p/ktorrent-4.3.0/ktorrent-4.3.0/libktcore/torrent/queuemanager.cpp:588
#24 0x000000387563e1fd in kt::QueueManager::torrentAdded (this=0x2412a60, tc=0x2d990a0, start_torrent=true)
    at /usr/src/debug/net-p2p/ktorrent-4.3.0/ktorrent-4.3.0/libktcore/torrent/queuemanager.cpp:661
#25 0x000000000043141e in kt::Core::init (this=this@entry=0x2412c00, tc=tc@entry=0x2d990a0, group=..., location=..., silently=silently@entry=false)
    at /usr/src/debug/net-p2p/ktorrent-4.3.0/ktorrent-4.3.0/ktorrent/core.cpp:345
#26 0x0000000000431e11 in kt::Core::loadFromData (this=this@entry=0x2412c00, data=..., dir=..., group=..., silently=silently@entry=false, url=...)
    at /usr/src/debug/net-p2p/ktorrent-4.3.0/ktorrent-4.3.0/ktorrent/core.cpp:379
#27 0x00000000004322b4 in kt::Core::load (this=0x2412c00, data=..., url=..., group=..., savedir=...) at /usr/src/debug/net-p2p/ktorrent-4.3.0/ktorrent-4.3.0/ktorrent/core.cpp:597
#28 0x00000000004344b6 in kt::Core::onMetadataDownloaded (this=0x2412c00, mlink=..., data=..., options=...)
    at /usr/src/debug/net-p2p/ktorrent-4.3.0/ktorrent-4.3.0/ktorrent/core.cpp:1490
#29 0x000000000043685a in kt::Core::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>)
    at /usr/src/debug/net-p2p/ktorrent-4.3.0/ktorrent-4.3.0_build/ktorrent/core.moc:163
#30 0x0000003873b9175e in QObject::event (this=0x2412c00, e=<optimized out>) at kernel/qobject.cpp:1195
#31 0x00000038741dbbec in QApplicationPrivate::notify_helper (this=this@entry=0x22d5320, receiver=receiver@entry=0x2412c00, e=e@entry=0x2cda440) at kernel/qapplication.cpp:4557
#32 0x00000038741e003a in QApplication::notify (this=0x7fff74fe9700, receiver=0x2412c00, e=0x2cda440) at kernel/qapplication.cpp:4418
#33 0x000000000043d332 in kt::App::notify (this=<optimized out>, receiver=<optimized out>, event=<optimized out>)
    at /usr/src/debug/net-p2p/ktorrent-4.3.0/ktorrent-4.3.0/ktorrent/app.cpp:99
#34 0x0000003873b7caed in QCoreApplication::notifyInternal (this=0x7fff74fe9700, receiver=receiver@entry=0x2412c00, event=event@entry=0x2cda440) at kernel/qcoreapplication.cpp:915
#35 0x0000003873b804e0 in sendEvent (event=0x2cda440, receiver=0x2412c00) at ../../src/corelib/kernel/qcoreapplication.h:231
---Type <return> to continue, or q <return> to quit---
#36 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x2297670) at kernel/qcoreapplication.cpp:1539
#37 0x0000003873baaf93 in sendPostedEvents () at ../../src/corelib/kernel/qcoreapplication.h:236
#38 postEventSourceDispatch (s=s@entry=0x22d3a60) at kernel/qeventdispatcher_glib.cpp:279
#39 0x000000387164a714 in g_main_dispatch (context=0x22d4650) at gmain.c:2539
#40 g_main_context_dispatch (context=context@entry=0x22d4650) at gmain.c:3075
#41 0x000000387164aa68 in g_main_context_iterate (context=context@entry=0x22d4650, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3146
#42 0x000000387164ab2c in g_main_context_iteration (context=0x22d4650, may_block=1) at gmain.c:3207
#43 0x0000003873bab106 in QEventDispatcherGlib::processEvents (this=0x2298b30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#44 0x000000387427bdc6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#45 0x0000003873b7b7ef in QEventLoop::processEvents (this=this@entry=0x7fff74fe89d0, flags=...) at kernel/qeventloop.cpp:149
#46 0x0000003873b7bad0 in QEventLoop::exec (this=0x7fff74fe89d0, flags=...) at kernel/qeventloop.cpp:204
#47 0x0000003873b807e8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#48 0x000000000042b53b in main (argc=1, argv=0x7fff74fe9838) at /usr/src/debug/net-p2p/ktorrent-4.3.0/ktorrent-4.3.0/ktorrent/main.cpp:186

It's very annoying that there is no way to re-open the bug.... maybe I should create a new one since obviously nobody is going to notice but the people who are affected?   At least I was finally able to create an account so I could add my comment -- took me months just to figure out how to do that, since, for some reason the system never sends the promised validation e-mail when I request it (only was able to work around it using a gmail account,  it still never sends).
Comment 33 Christoph Feck 2012-12-22 13:55:34 UTC
You are testing 4.3.0, and the patches fixing this bug are post this release. Please test latest master versions of libktorrent+ktorrent.
Comment 34 Gregory M. Turner 2012-12-22 15:53:49 UTC
(In reply to comment #33)
> You are testing 4.3.0, and the patches fixing this bug are post this
> release. Please test latest master versions of libktorrent+ktorrent.

Whoopsie, right you are... sorry, I don't know how I got myself convinced that this was not the case.  Now a bit embarrassed to have been all grumpy about this when I didn't even have my facts straight :/  sorry about that.

Too lazy to figure out how to properly merge master (I'm relying on portage's ebuild to do all of the heavy lifting for me, which is tarball-based) -- but I cherry-picked 4ffaa9e1 onto libktorrent-4.3.0 and recompiled ktorrent against it, and...

What do you know, the bug is fixed... :)

So sorry for the noise (and pointless grumpyness) -- and thanks for all your efforts on ktorrent, except for this one thing it's been the most awesome torrent client ever for me!

executive summary: bug fixed; grumpy -> embarassed; sorry; thanks!

-gmt
Comment 35 Mark Haferkamp 2014-07-24 15:07:47 UTC
I just got this issue on KTorrent 4.3.1 on Chakra Linux after installing Debian on a btrfs partition, moving all my /home data to Debian's btrfs partition, and changing Chakra's /home to a symlink pointing to /mnt/debian/home. Since I also removed another symlink that KTorrent was using to access a subfolder in /home, I got a lot of file not found errors, but the option to change where KTorrent looks worked for most torrents.

I fixed the one torrent it didn't work for by removing its mount_points file per comment #2, manually editing the file_map file to point to the new place, and restarting KTorrent. I suspect manually editing file_map wasn't necessary, but it seemed easier than going through the GUI again.