Bug 306242 - Wrong file name placement in icon view
Summary: Wrong file name placement in icon view
Status: RESOLVED DUPLICATE of bug 302703
Alias: None
Product: dolphin
Classification: Unclassified
Component: view-engine: icons mode (show other bugs)
Version: 2.1
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-04 09:31 UTC by David de Cos
Modified: 2012-09-04 11:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David de Cos 2012-09-04 09:31:25 UTC
If you switch from Details View to Icon View, the file names are placed on the right of the icons, not under them. If a name is long enough, it overlaps with the next icon to the right, creating a mess. If you select another directory while in Icon View, the problem disappears.

Reproducible: Always

Steps to Reproduce:
As it depends on some dolphin settings, I've figure out how to reproduce it starting with a default dolphin configuration. I suggest you move your dolphinrc to dolphinrc.old or whatever.

1. Start dolphin with the default settings.
2. Switch to Details View.
3. Go to Configure Dolphin -> View Modes -> Details tab -> Untick Expandable Folders -> Accept
4. Switch to Icon View.
Actual Results:  
The file names are placed on the right of the icons. They may even overlap with the next icon to the right.

Expected Results:  
Names under icons, as usual.

This is an annoying bug, because I use Details View by default, but always switch to Icon View in certain folders (photos, videos), and the view gets really messed up. It only started happening after upgrading to KDE 4.9. I have reproduced both in an OpenSuSE and a Kubuntu machine.
Comment 1 Frank Reininghaus 2012-09-04 11:08:03 UTC
Thanks for the bug report! This issue has been reported already.

*** This bug has been marked as a duplicate of bug 302703 ***