Bug 306206 - kded4 memory leak
Summary: kded4 memory leak
Status: RESOLVED DUPLICATE of bug 271934
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: 4.8
Platform: Fedora RPMs Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-03 17:34 UTC by Marius Bjørnstad
Modified: 2014-04-13 13:05 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
valgrind log (271.67 KB, application/x-xz)
2012-11-07 15:40 UTC, Laurent Bonnaud
Details
valgrind log from kded4 (64.60 KB, application/octet-stream)
2013-03-06 18:14 UTC, Gabriel Ramirez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marius Bjørnstad 2012-09-03 17:34:46 UTC
kded4 memory usage slowly increases. 

It has been killed once by the out of memory killer, then the system tray icons were no longer hidden, and the Sleep and Hibernate options were no longer in the system menu. Logging out and back in restored everything to its normal state.

I am a heavy user of the "Sleep" function, and this bug could be related to a problem with Sleep. A few times there is no password prompt when waking up from Sleep mode.

After 3 days it uses 1.1 GB. From "ps auxww":
fa2k     29920  0.0  6.9 3588052 1149936 ?     Sl   Aug31   1:19 kded4


Reproducible: Always

Steps to Reproduce:
1. Leave a session running for a long time
2. Maybe: use the Sleep (suspend to RAM) function
Actual Results:  
kded4 memory use slowly increases in small increments. Appears to be correlated with opening new windows.


Work-around: Log out and back in again
Comment 1 Christoph Feck 2012-09-03 19:57:03 UTC
Please check which kded module is responsible. For more information, see http://kdepepo.wordpress.com/2011/05/11/troubleshooting-kded4-bugs/
Comment 2 Marius Bjørnstad 2012-09-03 20:58:11 UTC
I get about 30 messages per second like the following in the kernel log
(dmesg). Maybe that is related to the memory use.

[426199.823707] ehci_hcd 0000:00:12.2: port 3 resume error -110

The messages started when I connected a bad USB device. Sorry I didn't
think of this before. I can't reboot now, but I'll do it in a couple of
days and report if it still happens.

I tried to start and stop "Power Management", and about 1 minute later,
I got a segmentation fault. The only message was "Application: KDE
Daemon (kded4), signal: Segmentation fault" ("The generated crash
information is not useful"). Now kded4 quit and was restarted, and the
memory usage is low again ~50 MB, but it increases at about 1 MB per 20 min.



On 09/03/2012 08:57 PM, Christoph Feck wrote:
> https://bugs.kde.org/show_bug.cgi?id=306206
>
> Christoph Feck <christoph@maxiom.de> changed:
>
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|                            |christoph@maxiom.de
>            Severity|minor                       |normal
>
> --- Comment #1 from Christoph Feck <christoph@maxiom.de> ---
> Please check which kded module is responsible. For more information, see
> http://kdepepo.wordpress.com/2011/05/11/troubleshooting-kded4-bugs/
>
Comment 3 Marius Bjørnstad 2012-09-11 16:34:04 UTC
It still happens, and the memory remains high even when I stop various services. It's somewhat difficult to disable services and log in, because it takes hours to see if it's actually leaking. I will update this bug if I find anything.
Comment 4 Laurent Bonnaud 2012-10-28 14:44:33 UTC
I am also seeing this bug in Kubuntu quantal with KDE 4.9.2.  Here is the kded memory usage I see in a KDE session that has been running for 7 days:

$ ps aux |grep kded
bonnaud   3377  0.0 15.3 1185376 620392 ?      Sl   Oct20   3:23 kdeinit4: kded4 [kdeinit]
Comment 5 Christoph Feck 2012-10-28 14:56:59 UTC
Please read comment #1. Without the information, which module is responsible, we cannot do anything. Start with disabling the power management related modules (see bug 294497, bug 271934).
Comment 6 Laurent Bonnaud 2012-11-07 15:40:14 UTC
Created attachment 75078 [details]
valgrind log

I ran kded with valgrind.  Many memory leaks are reported.  The main one is:

==4846== 4,364,285 bytes in 136,872 blocks are possibly lost in loss record 9,681 of 9,681
==4846==    at 0x402CB7A: malloc (in /usr/lib/valgrind/vgpreload_memcheck-x86-linux.so)
==4846==    by 0x5DCB7EA: standard_malloc (gmem.c:85)
==4846==    by 0x5DCBB62: g_malloc (gmem.c:159)
==4846==    by 0x5DE37E1: g_memdup (gstrfuncs.c:392)
==4846==    by 0x5DA0989: g_bytes_new (gbytes.c:95)
==4846==    by 0x5DF724B: g_variant_new_from_trusted (gvariant.c:326)
==4846==    by 0x97ABA8B: parse_value_from_blob (gdbusmessage.c:1219)
==4846==    by 0x97ABC95: parse_value_from_blob (gdbusmessage.c:1439)
==4846==    by 0x97ABE7B: parse_value_from_blob (gdbusmessage.c:1354)
==4846==    by 0x97ABC95: parse_value_from_blob (gdbusmessage.c:1439)
==4846==    by 0x97AD86E: g_dbus_message_new_from_blob (gdbusmessage.c:1793)
==4846==    by 0x97B908E: _g_dbus_worker_do_read_cb (gdbusprivate.c:753)
Comment 7 Christoph Feck 2012-11-07 22:59:17 UTC
Laurent, thanks for the valgrind log. Could you increase the number of callers visible, so that we can see which KDE component calls the glib stuff? E.g. valgrind --num-callers=30 (or more, if we cannot see the caller).

For more information, see http://people.gnome.org/~newren/tutorials/developing-with-gnome/html/ch03s03.html
Comment 8 Vangelis 2012-11-11 15:41:54 UTC
I face the same very annoying problem. After a few hours of work, kded4 consumes more than 2GB memory itself.

Is it correct if I run the valgrind command like this and provide the log file?

valgrind -v --leak-check=full --num-callers=50 kdeinit4 kded4 >& kded4-valgrind.log
Comment 9 Jekyll Wu 2013-01-02 11:23:27 UTC
Laurent,  I think another suspect in your valigrind log is  kded_notificationhelper.so
Comment 10 Christoph Feck 2013-01-12 02:55:31 UTC
Was anyone able to pinpoint the kded module responsible for the leak?
Comment 11 Vangelis 2013-02-14 18:40:48 UTC
(In reply to comment #10)
> Was anyone able to pinpoint the kded module responsible for the leak?

Power management is the culprit for me.
Already posted this in this bug: https://bugs.kde.org/show_bug.cgi?id=271934
Comment 12 Marius Bjørnstad 2013-02-15 11:08:07 UTC
Sorry, I meant to reply but forgot. I upgraded my hardware and I'm not seeing the bug any more. Perfectly flat memory usage. I don't know if it's the new H/W or 4.10 that fixed it, so I can't be of much help. It did seem that the suspend/resume process sometimes didn't fully complete on my old hardware though.
Comment 13 Gabriel Ramirez 2013-03-06 18:14:00 UTC
Created attachment 77807 [details]
valgrind log from kded4

my desktop computer  running Fedora 17 x86_64 kde 4.10 (happened with kde 4.9.x too) have the kded4 memory leak

if I disable the Power Management module the leaks stops

in my case the leaks happens in a desktop computer, I have a netbook Fedora 17 kde 4.9.2 and it don't have any memory leaks

I tried to run kded4 under valgrind with the following command line

valgrind -v --leak-check=full --trace-children=yes --num-callers=50 kded4 >& /tmp/kded4-valgrind

thanks, 

gabrielo
Comment 14 Vangelis 2013-03-06 18:50:22 UTC
Since it looks like it is hardware related problem, here is the output of my lspci -vv

00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 12)
        Subsystem: Toshiba America Info Systems Device 0001
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort+ >SERR- <PERR- INTx-
        Latency: 0
        Capabilities: <access denied>

00:01.0 PCI bridge: Intel Corporation Core Processor PCI Express x16 Root Port (rev 12) (prog-if 00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        I/O behind bridge: 00004000-00004fff
        Memory behind bridge: d2000000-d30fffff
        Prefetchable memory behind bridge: 00000000c0000000-00000000d1ffffff
        Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- <SERR- <PERR-
        BridgeCtl: Parity- SERR- NoISA- VGA+ MAbort- >Reset- FastB2B-
                PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
        Capabilities: <access denied>
        Kernel driver in use: pcieport
        Kernel modules: shpchp

00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
        Subsystem: Toshiba America Info Systems Device 0001
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 43
        Region 0: Memory at d3806000 (64-bit, non-prefetchable) [size=16]
        Capabilities: <access denied>
        Kernel driver in use: mei
        Kernel modules: mei

00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06) (prog-if 20 [EHCI])
        Subsystem: Toshiba America Info Systems Device 0001
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at d3805c00 (32-bit, non-prefetchable) [size=1K]
        Capabilities: <access denied>
        Kernel driver in use: ehci_hcd

00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 06)
        Subsystem: Toshiba America Info Systems Device 0001
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 44
        Region 0: Memory at d3800000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd-hda-intel

00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 06) (prog-if 00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
        I/O behind bridge: 00006000-00006fff
        Memory behind bridge: d3700000-d37fffff
        Prefetchable memory behind bridge: 00000000d3a00000-00000000d3bfffff
        Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- <SERR- <PERR-
        BridgeCtl: Parity- SERR- NoISA- VGA- MAbort- >Reset- FastB2B-
                PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
        Capabilities: <access denied>
        Kernel driver in use: pcieport
        Kernel modules: shpchp

00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 06) (prog-if 00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
        I/O behind bridge: 00003000-00003fff
        Memory behind bridge: d3600000-d36fffff
        Prefetchable memory behind bridge: 00000000d3c00000-00000000d3dfffff
        Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- <SERR- <PERR-
        BridgeCtl: Parity- SERR- NoISA- VGA- MAbort- >Reset- FastB2B-
                PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
        Capabilities: <access denied>
        Kernel driver in use: pcieport
        Kernel modules: shpchp

00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 06) (prog-if 00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Bus: primary=00, secondary=04, subordinate=04, sec-latency=0
        I/O behind bridge: 00007000-00007fff
        Memory behind bridge: d3500000-d35fffff
        Prefetchable memory behind bridge: 00000000d3e00000-00000000d3ffffff
        Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- <SERR- <PERR-
        BridgeCtl: Parity- SERR- NoISA- VGA- MAbort- >Reset- FastB2B-
                PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
        Capabilities: <access denied>
        Kernel driver in use: pcieport
        Kernel modules: shpchp

00:1c.3 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 4 (rev 06) (prog-if 00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Bus: primary=00, secondary=05, subordinate=05, sec-latency=0
        I/O behind bridge: 00008000-00008fff
        Memory behind bridge: d3400000-d34fffff
        Prefetchable memory behind bridge: 00000000d4000000-00000000d41fffff
        Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- <SERR- <PERR-
        BridgeCtl: Parity- SERR- NoISA- VGA- MAbort- >Reset- FastB2B-
                PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
        Capabilities: <access denied>
        Kernel driver in use: pcieport
        Kernel modules: shpchp

00:1c.5 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 6 (rev 06) (prog-if 00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Bus: primary=00, secondary=06, subordinate=06, sec-latency=0
        I/O behind bridge: 00002000-00002fff
        Memory behind bridge: d3300000-d33fffff
        Prefetchable memory behind bridge: 00000000d3100000-00000000d31fffff
        Secondary status: 66MHz- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- <SERR- <PERR-
        BridgeCtl: Parity- SERR- NoISA- VGA- MAbort- >Reset- FastB2B-
                PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
        Capabilities: <access denied>
        Kernel driver in use: pcieport
        Kernel modules: shpchp

00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 06) (prog-if 20 [EHCI])
        Subsystem: Toshiba America Info Systems Device 0001
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 19
        Region 0: Memory at d3805800 (32-bit, non-prefetchable) [size=1K]
        Capabilities: <access denied>
        Kernel driver in use: ehci_hcd

00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a6) (prog-if 01 [Subtractive decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Bus: primary=00, secondary=07, subordinate=07, sec-latency=32
        I/O behind bridge: 0000f000-00000fff
        Memory behind bridge: d3200000-d32fffff
        Prefetchable memory behind bridge: 00000000fff00000-00000000000fffff
        Secondary status: 66MHz- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ <SERR- <PERR-
        BridgeCtl: Parity- SERR- NoISA- VGA- MAbort- >Reset- FastB2B-
                PriDiscTmr- SecDiscTmr- DiscTmrStat- DiscTmrSERREn-
        Capabilities: <access denied>

00:1f.0 ISA bridge: Intel Corporation Mobile 5 Series Chipset LPC Interface Controller (rev 06)
        Subsystem: Toshiba America Info Systems Device 0001
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Capabilities: <access denied>
        Kernel modules: lpc_ich

00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 06) (prog-if 01 [AHCI 1.0])
        Subsystem: Toshiba America Info Systems Device 0001
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin B routed to IRQ 41
        Region 0: I/O ports at 5028 [size=8]
        Region 1: I/O ports at 5034 [size=4]
        Region 2: I/O ports at 5020 [size=8]
        Region 3: I/O ports at 5030 [size=4]
        Region 4: I/O ports at 5000 [size=32]
        Region 5: Memory at d3805000 (32-bit, non-prefetchable) [size=2K]
        Capabilities: <access denied>
        Kernel driver in use: ahci

00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 06)
        Subsystem: Toshiba America Info Systems Device 0001
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin C routed to IRQ 18
        Region 0: Memory at d3804000 (64-bit, non-prefetchable) [size=4K]
        Capabilities: <access denied>
        Kernel driver in use: intel ips
        Kernel modules: intel_ips

01:00.0 VGA compatible controller: NVIDIA Corporation GT216 [GeForce GT 330M] (rev a2) (prog-if 00 [VGA controller])
        Subsystem: Toshiba America Info Systems Device 0001
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at d2000000 (32-bit, non-prefetchable) [size=16M]
        Region 1: Memory at c0000000 (64-bit, prefetchable) [size=256M]
        Region 3: Memory at d0000000 (64-bit, prefetchable) [size=32M]
        Region 5: I/O ports at 4000 [size=128]
        [virtual] Expansion ROM at d3080000 [disabled] [size=512K]
        Capabilities: <access denied>
        Kernel driver in use: nvidia
        Kernel modules: nvidia_current_updates, nouveau, nvidiafb

01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
        Subsystem: Toshiba America Info Systems Device 0001
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at d3000000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd-hda-intel

02:00.0 SD Host controller: Ricoh Co Ltd MMC/SD Host Controller (rev 01)
        Subsystem: Toshiba America Info Systems Device 0001
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at d3700200 (32-bit, non-prefetchable) [size=256]
        Capabilities: <access denied>
        Kernel driver in use: sdhci-pci
        Kernel modules: sdhci-pci

02:00.1 System peripheral: Ricoh Co Ltd R5U2xx (R5U230 / R5U231 / R5U241) [Memory Stick Host Controller] (rev 01)
        Subsystem: Toshiba America Info Systems Device 0001
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin B routed to IRQ 5
        Region 0: Memory at d3700100 (32-bit, non-prefetchable) [size=256]
        Capabilities: <access denied>

03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8191SEvB Wireless LAN Controller (rev 10)
        Subsystem: Realtek Semiconductor Co., Ltd. Device 8182
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 17
        Region 0: I/O ports at 3000 [size=256]
        Region 1: Memory at d3600000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: rtl8192se
        Kernel modules: rtl8192se

06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
        Subsystem: Toshiba America Info Systems Device 0002
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 42
        Region 0: I/O ports at 2000 [size=256]
        Region 2: Memory at d3104000 (64-bit, prefetchable) [size=4K]
        Region 4: Memory at d3100000 (64-bit, prefetchable) [size=16K]
        Expansion ROM at d3120000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: r8169
        Kernel modules: r8169

ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
        Subsystem: Intel Corporation Device 8086
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0

ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
        Subsystem: Intel Corporation Device 8086
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0

ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
        Subsystem: Intel Corporation Device 8086
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0

ff:02.1 Host bridge: Intel Corporation Core Processor QPI Physical 0 (rev 02)
        Subsystem: Intel Corporation Device 8086
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0

ff:02.2 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
        Subsystem: Intel Corporation Device 8086
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0

ff:02.3 Host bridge: Intel Corporation Core Processor Reserved (rev 02)
        Subsystem: Intel Corporation Device 8086
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
Comment 15 Jiri Slaby 2013-03-10 15:02:07 UTC
The only thing we have in common is the vendor (intel). Other than that I see no intersection. FWIW I see the issue with 4.10.0.
Comment 16 Jiri Slaby 2013-03-10 16:07:19 UTC
Ok, so I created two separate bugs for the issues valgrind has found here: bug 316473, bug 316473.
Comment 17 Jiri Slaby 2013-03-10 16:30:23 UTC
(In reply to comment #12)
> Sorry, I meant to reply but forgot. I upgraded my hardware and I'm not
> seeing the bug any more. Perfectly flat memory usage. I don't know if it's
> the new H/W or 4.10 that fixed it, 

Do you have systemd version > 197?
Comment 18 Vangelis 2013-03-10 16:45:57 UTC
(In reply to comment #15)
> The only thing we have in common is the vendor (intel). Other than that I
> see no intersection. FWIW I see the issue with 4.10.0.

I had the same memory leak issue with 4.9.x as well on my laptop
Comment 19 Gabriel Ramirez 2013-03-11 19:05:53 UTC
Mi machine is intel  core 2duo, Fedora 17 x86_64 but it's a desktop

the machine can sleep and hibernate correctly, 
also put's to sleep the monitor correctly via dvi and in the past via vga

my problem in my case is which kded4 grows the resident memory and consumes virtual memory too (swap) until killed and restarting kded4 and the cycle begin again

the grow in memory happens without sleeping or hibernate the machine

the problem happened with kde 4.9.x 4.10 and currently happen with 4.10.1

I only restart after 7 or more days of uptime sometimes 40 days 
I have to kill kded4 several times but besides that the os and kde worked perfectly

and I have a netbook Fedora 17 i686 kde 4.9.2 and now 4.10.1 and it don't have the problem and it sleep, hibernates and turn off the lcd correctly.

thanks, 

gabrielo
Comment 20 Andrew 2013-04-16 14:03:51 UTC
It leaks for me too.
I'm on up to date Kubuntu 12.04 64 bit with KDE 4.10.2 from backports.
After disabling power management memory usage remains steady.
Comment 21 Rex Dieter 2013-05-07 23:01:49 UTC
May be a dup of bug #271934
Comment 22 Bill McGonigle 2013-12-10 16:32:45 UTC
Disabling power management also seems to work for me.  Previously, kded4 was at 3GB resident, 12GB virtual(!).  I was happily able to cleanly kill it with HUP and restart it as a regular background process without losing my session.

This is an AMD A6-3650 based desktop (MSI board).
Comment 23 Christoph Feck 2014-04-13 13:05:05 UTC

*** This bug has been marked as a duplicate of bug 271934 ***