Bug 306013 - Gwenview crash then updating folder-tree in the sidebar
Summary: Gwenview crash then updating folder-tree in the sidebar
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: 2.8.4
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
: 310092 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-08-29 23:33 UTC by solix
Modified: 2013-01-05 15:07 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description solix 2012-08-29 23:33:11 UTC
Application: gwenview (2.8.4)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-29-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I was updating folder-tree in the sidebar by pressing F5 on the keyboard

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa4708607c0 (LWP 13787))]

Thread 4 (Thread 0x7fa459b41700 (LWP 13798)):
#0  0x00007fff77dff8de in ?? ()
#1  0x00007fa469c8915d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007fa46f5d5bb4 in do_gettime (frac=0x7fa459b40a98, sec=0x7fa459b40a90) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007fa46f6adb8d in QTimerInfoList::updateCurrentTime (this=0x7fa454002860) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007fa46f6adec3 in QTimerInfoList::timerWait (this=0x7fa454002860, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007fa46f6ac97c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fa459b40b6c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007fa46f6aca25 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007fa4699d7846 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007fa4699d7f5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007fa4699d8164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007fa46f6ad426 in QEventDispatcherGlib::processEvents (this=0x7fa4540008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007fa46f67cc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007fa46f67ced7 in QEventLoop::exec (this=0x7fa459b40cd0, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007fa46f57bfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x00007fa46f65c9ff in QInotifyFileSystemWatcherEngine::run (this=0x24415c0) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007fa46f57efcb in QThreadPrivate::start (arg=0x24415c0) at thread/qthread_unix.cpp:298
#17 0x00007fa466a5bb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#18 0x00007fa46a098e9a in start_thread (arg=0x7fa459b41700) at pthread_create.c:308
#19 0x00007fa46d2344bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#20 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fa458a14700 (LWP 13799)):
#0  __pthread_mutex_unlock (mutex=0x1) at pthread_mutex_unlock.c:289
#1  0x00007fa469a135d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa4699d7c49 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa4699d80a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fa4699d8164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fa46f6ad426 in QEventDispatcherGlib::processEvents (this=0x7fa44c0008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fa46f67cc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fa46f67ced7 in QEventLoop::exec (this=0x7fa458a13cd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fa46f57bfa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007fa46f65c9ff in QInotifyFileSystemWatcherEngine::run (this=0x2749f10) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007fa46f57efcb in QThreadPrivate::start (arg=0x2749f10) at thread/qthread_unix.cpp:298
#11 0x00007fa466a5bb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#12 0x00007fa46a098e9a in start_thread (arg=0x7fa458a14700) at pthread_create.c:308
#13 0x00007fa46d2344bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fa452b58700 (LWP 13807)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa46f57f4db in wait (time=18446744073709551615, this=0x23cdbc0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x23bbfd8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fa47019d04e in Gwenview::SemanticInfoThread::run (this=0x23bbfc0) at ../../lib/semanticinfo/nepomuksemanticinfobackend.cpp:145
#4  0x00007fa46f57efcb in QThreadPrivate::start (arg=0x23bbfc0) at thread/qthread_unix.cpp:298
#5  0x00007fa466a5bb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#6  0x00007fa46a098e9a in start_thread (arg=0x7fa452b58700) at pthread_create.c:308
#7  0x00007fa46d2344bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#8  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa4708607c0 (LWP 13787)):
[KCrash Handler]
#6  KSharedPtr (o=<error reading variable: Cannot access memory at address 0x30>, this=0x7fff77de39e0) at /usr/include/ksharedptr.h:84
#7  Gwenview::DocumentView::document (this=0x0) at ../../lib/documentview/documentview.cpp:639
#8  0x000000000042f9b6 in Gwenview::ViewMainPage::reload (this=0x274d370) at ../../app/viewmainpage.cpp:665
#9  0x00007fa46f692281 in QMetaObject::activate (sender=0x27da790, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff77de3c00) at kernel/qobject.cpp:3547
#10 0x00007fa46de9c132 in QAction::triggered (this=<optimized out>, _t1=false) at .moc/release-shared/moc_qaction.cpp:277
#11 0x00007fa46de9c31f in QAction::activate (this=0x27da790, event=<optimized out>) at kernel/qaction.cpp:1257
#12 0x00007fa46de9c48f in QAction::event (this=<optimized out>, e=<optimized out>) at kernel/qaction.cpp:1183
#13 0x00007fa46eaf3aaa in KAction::event (this=<optimized out>, event=0x7fff77de4220) at ../../kdeui/actions/kaction.cpp:131
#14 0x00007fa46dea2894 in notify_helper (e=0x7fff77de4220, receiver=0x27da790, this=0x222ce90) at kernel/qapplication.cpp:4559
#15 QApplicationPrivate::notify_helper (this=0x222ce90, receiver=0x27da790, e=0x7fff77de4220) at kernel/qapplication.cpp:4531
#16 0x00007fa46dea7713 in QApplication::notify (this=0x7fff77de56f0, receiver=0x27da790, e=0x7fff77de4220) at kernel/qapplication.cpp:4420
#17 0x00007fa46ebdc9e6 in KApplication::notify (this=0x7fff77de56f0, receiver=0x27da790, event=0x7fff77de4220) at ../../kdeui/kernel/kapplication.cpp:311
#18 0x00007fa46f67de9c in QCoreApplication::notifyInternal (this=0x7fff77de56f0, receiver=0x27da790, event=0x7fff77de4220) at kernel/qcoreapplication.cpp:876
#19 0x00007fa46ded48b9 in sendEvent (event=0x7fff77de4220, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#20 QShortcutMap::dispatchEvent (this=<optimized out>, e=0x7fff77de47c0) at kernel/qshortcutmap.cpp:879
#21 0x00007fa46ded5d8a in QShortcutMap::tryShortcutEvent (this=0x222cfb0, o=<optimized out>, e=0x7fff77de47c0) at kernel/qshortcutmap.cpp:364
#22 0x00007fa46dea8f92 in QApplication::notify (this=0x7fff77de56f0, receiver=0x27e5720, e=0x7fff77de47c0) at kernel/qapplication.cpp:3983
#23 0x00007fa46ebdc9e6 in KApplication::notify (this=0x7fff77de56f0, receiver=0x27e5720, event=0x7fff77de47c0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007fa46f67de9c in QCoreApplication::notifyInternal (this=0x7fff77de56f0, receiver=0x27e5720, event=0x7fff77de47c0) at kernel/qcoreapplication.cpp:876
#25 0x00007fa46df46c49 in QKeyMapper::sendKeyEvent (keyWidget=0x27e5720, grab=<optimized out>, type=QEvent::KeyPress, code=16777268, modifiers=..., text=..., autorepeat=false, count=1, nativeScanCode=71, nativeVirtualKey=65474, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1866
#26 0x00007fa46df470bb in QKeyMapperPrivate::translateKeyEvent (this=0x226f180, keyWidget=0x27e5720, event=0x7fff77de52b0, grab=false) at kernel/qkeymapper_x11.cpp:1836
#27 0x00007fa46df21637 in QApplication::x11ProcessEvent (this=0x7fff77de56f0, event=0x7fff77de52b0) at kernel/qapplication_x11.cpp:3625
#28 0x00007fa46df4b0d2 in x11EventSourceDispatch (s=0x222dee0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#29 0x00007fa4699d7d53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fa4699d80a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fa4699d8164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007fa46f6ad3bf in QEventDispatcherGlib::processEvents (this=0x21cb770, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#33 0x00007fa46df4ad5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007fa46f67cc82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007fa46f67ced7 in QEventLoop::exec (this=0x7fff77de5650, flags=...) at kernel/qeventloop.cpp:204
#36 0x00007fa46f681f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#37 0x00000000004269c5 in main (argc=6, argv=0x7fff77de5a18) at ../../app/main.cpp:142

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-11-14 15:16:20 UTC
*** Bug 310092 has been marked as a duplicate of this bug. ***
Comment 2 Aurelien Gateau 2012-12-10 16:53:16 UTC

*** This bug has been marked as a duplicate of bug 297262 ***
Comment 3 Benni Hill 2012-12-31 02:29:51 UTC
Not a duplicate.

Proposed fix:
https://git.reviewboard.kde.org/r/108042/
Comment 4 Ilya Basin 2012-12-31 07:52:39 UTC
the patch works for me
Comment 5 Benni Hill 2013-01-05 15:07:13 UTC
Git commit 7022f769d181970278b9d5d2f12378ec901c071f by Benjamin Löwe.
Committed on 31/12/2012 at 03:19.
Pushed by bennihill into branch 'KDE/4.10'.

Fix for bug 306013 - Gwenview crash when updating folder-tree in
the sidebar

Thanks to Ilya Basin for helping to fix this.
REVIEW: 108042
FIXED-IN: 4.10.0

M  +5    -1    app/viewmainpage.cpp

http://commits.kde.org/gwenview/7022f769d181970278b9d5d2f12378ec901c071f