Bug 305767 - Opening an existing document crashes
Summary: Opening an existing document crashes
Status: RESOLVED DUPLICATE of bug 305006
Alias: None
Product: calligrawords
Classification: Unclassified
Component: opendocument (show other bugs)
Version: Git
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Calligra Words Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-25 16:17 UTC by Myriam Schweingruber
Modified: 2012-10-15 19:52 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Myriam Schweingruber 2012-08-25 16:17:33 UTC
Application: calligrawords (2.6 Pre-Alpha)
KDE Platform Version: 4.9.00
Qt Version: 4.8.2
Operating System: Linux 3.5.0-11-generic x86_64
Distribution: Ubuntu quantal (development branch)

-- Information about the crash:
I was trying to open an existing document from the startup dialog in Calligra Words when the crash happened

-- Backtrace:
Application: Calligra Words (kdeinit4), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f90fe89a780 (LWP 8873))]

Thread 3 (Thread 0x7f90e76f1700 (LWP 8874)):
#0  0x00007f910386c9e3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9100992f94 in g_idle_add_full () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f90e614f700 (LWP 8880)):
#0  0x00007f910386af9d in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f91009ce55f in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f90d80009a0 in ?? ()
#3  0x000000007fffffff in ?? ()
#4  0x0000000000000001 in ?? ()
#5  0x5697c8e173ea2400 in ?? ()
#6  0x00007f90d80009a0 in ?? ()
#7  0x00007f9100992b24 in g_main_context_get_poll_func () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f91009cf231 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f90d80009a0 in ?? ()
#10 0x0000000000000001 in ?? ()
#11 0x00007f90d80029b0 in ?? ()
#12 0x00000000ffffffff in ?? ()
#13 0x00007f9100992f32 in g_idle_add_full () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007f90d80009a0 in ?? ()
#15 0xffffffff7fffffff in ?? ()
#16 0x00007f90e614ed00 in ?? ()
#17 0x00007f90d80009a0 in ?? ()
#18 0x0000000000000001 in ?? ()
#19 0x00007f90e614ed00 in ?? ()
#20 0x00007f90d80008c0 in ?? ()
#21 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f90fe89a780 (LWP 8873)):
[KCrash Handler]
#6  0x00007f91037bc405 in __GI_raise (sig=<optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f91037bfb6b in __GI_abort () at abort.c:91
#8  0x00007f9104b63402 in qt_message_output (msgType=msgType@entry=QtFatalMsg, buf=0x43888d8 "ASSERT: \"pageIndex < m_pageTops.count()\" in file /home/myriam/kde/src/calligra/words/part/KWViewModeNormal.cpp, line 204") at global/qglobal.cpp:2284
#9  0x00007f9104b63778 in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=msgType@entry=QtFatalMsg, msg=0x7f9104ccb3c8 "ASSERT: \"%s\" in file %s, line %d", ap=ap@entry=0x7fff693d1ec8) at global/qglobal.cpp:2330
#10 0x00007f9104b63904 in qFatal (msg=<optimized out>) at global/qglobal.cpp:2513
#11 0x00007f90e9e1601f in KWViewModeNormal::documentToView (this=0x26b3540, point=..., viewConverter=0x20177a8) at /home/myriam/kde/src/calligra/words/part/KWViewModeNormal.cpp:204
#12 0x00007f90e9e1466d in KWViewMode::documentToView (this=0x26b3540, rect=..., viewConverter=0x20177a8) at /home/myriam/kde/src/calligra/words/part/KWViewMode.cpp:40
#13 0x00007f90e9dee035 in KWCanvasBase::updateCanvas (this=0x26b0c18, rc=...) at /home/myriam/kde/src/calligra/words/part/KWCanvasBase.cpp:697
#14 0x00007f90f073ccef in KoShapeManager::update (this=0x26b12f0, rect=..., shape=0x4388220, selectionHandles=true) at /home/myriam/kde/src/calligra/libs/flake/KoShapeManager.cpp:569
#15 0x00007f90f0724bb5 in KoShape::update (this=0x4388220) at /home/myriam/kde/src/calligra/libs/flake/KoShape.cpp:585
#16 0x00007f90f073654e in KoShapeContainer::update (this=0x4388220) at /home/myriam/kde/src/calligra/libs/flake/KoShapeContainer.cpp:232
#17 0x00007f90e84341f8 in TextShape::update (this=0x4388220) at /home/myriam/kde/src/calligra/plugins/textshape/TextShape.cpp:389
#18 0x00007f90f073aa65 in KoShapeManager::addShape (this=0x26b12f0, shape=0x4388220, repaint=KoShapeManager::PaintShapeOnAdd) at /home/myriam/kde/src/calligra/libs/flake/KoShapeManager.cpp:230
#19 0x00007f90f073d5b4 in KoShapeManager::qt_static_metacall (_o=0x26b12f0, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fff693d2640) at /home/myriam/kde/build/calligra/libs/flake/KoShapeManager.moc:68
#20 0x00007f9104c7e31f in QMetaObject::activate (sender=0x15d3060, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff693d2640) at kernel/qobject.cpp:3547
#21 0x00007f90e9de175a in KWDocument::shapeAdded (this=0x15d3060, _t1=0x4388220, _t2=KoShapeManager::AddWithoutRepaint) at /home/myriam/kde/build/calligra/words/part/moc_KWDocument.cpp:153
#22 0x00007f90e9df607e in KWDocument::addFrame (this=0x15d3060, frame=0x43c8350) at /home/myriam/kde/src/calligra/words/part/KWDocument.cpp:412
#23 0x00007f90e9de14f7 in KWDocument::qt_static_metacall (_o=0x15d3060, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0x7fff693d2880) at /home/myriam/kde/build/calligra/words/part/moc_KWDocument.cpp:88
#24 0x00007f9104c7e31f in QMetaObject::activate (sender=0x20456c0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff693d2880) at kernel/qobject.cpp:3547
#25 0x00007f90e9de41d9 in KWFrameSet::frameAdded (this=0x20456c0, _t1=0x43c8350) at /home/myriam/kde/build/calligra/words/part/moc_KWFrameSet.cpp:101
#26 0x00007f90e9e3be08 in KWFrameSet::addFrame (this=0x20456c0, frame=0x43c8350) at /home/myriam/kde/src/calligra/words/part/frames/KWFrameSet.cpp:68
#27 0x00007f90e9e3a6d1 in KWFrame::KWFrame (this=0x43c8350, shape=0x4388220, parent=0x20456c0, anchor=0x0) at /home/myriam/kde/src/calligra/words/part/frames/KWFrame.cpp:49
#28 0x00007f90e9e34be3 in KWFrameLayout::createNewFramesForPage (this=0x15d30a8, pageNumber=2) at /home/myriam/kde/src/calligra/words/part/frames/KWFrameLayout.cpp:210
#29 0x00007f90e9e5a47d in KWPageInsertCommand::redo (this=0x38a4880) at /home/myriam/kde/src/calligra/words/part/commands/KWPageInsertCommand.cpp:108
#30 0x00007f90e9df4dbf in KWDocument::insertPage (this=0x15d3060, afterPageNum=1, masterPageName=..., addUndoRedoCommand=false) at /home/myriam/kde/src/calligra/words/part/KWDocument.cpp:234
#31 0x00007f90e9df4ecc in KWDocument::appendPage (this=0x15d3060, masterPageName=..., addUndoRedoCommand=false) at /home/myriam/kde/src/calligra/words/part/KWDocument.cpp:248
#32 0x00007f90e9e2d0e9 in KWRootAreaProvider::provideNext (this=0x20443e0, documentLayout=0x20130d0) at /home/myriam/kde/src/calligra/words/part/KWRootAreaProvider.cpp:193
#33 0x00007f90e9e2dd39 in KWRootAreaProvider::provide (this=0x20443e0, documentLayout=0x20130d0) at /home/myriam/kde/src/calligra/words/part/KWRootAreaProvider.cpp:300
#34 0x00007f90f0caf9bc in KoTextDocumentLayout::doLayout (this=0x20130d0) at /home/myriam/kde/src/calligra/libs/textlayout/KoTextDocumentLayout.cpp:732
#35 0x00007f90f0caee0a in KoTextDocumentLayout::layout (this=0x20130d0) at /home/myriam/kde/src/calligra/libs/textlayout/KoTextDocumentLayout.cpp:608
#36 0x00007f90f0cb0192 in KoTextDocumentLayout::executeScheduledLayout (this=0x20130d0) at /home/myriam/kde/src/calligra/libs/textlayout/KoTextDocumentLayout.cpp:819
#37 0x00007f90f0cb0a03 in KoTextDocumentLayout::qt_static_metacall (_o=0x20130d0, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0x1fba940) at /home/myriam/kde/build/calligra/libs/textlayout/KoTextDocumentLayout.moc:66
#38 0x00007f9104c7d7fe in QObject::event (this=0x20130d0, e=<optimized out>) at kernel/qobject.cpp:1195
#39 0x00007f9104011d9c in QApplicationPrivate::notify_helper (this=this@entry=0x13328d0, receiver=receiver@entry=0x20130d0, e=e@entry=0x202f540) at kernel/qapplication.cpp:4556
#40 0x00007f910401620a in QApplication::notify (this=0x7fff693d5e80, receiver=0x20130d0, e=0x202f540) at kernel/qapplication.cpp:4417
#41 0x00007f90f16a82c0 in KoApplication::notify (this=0x7fff693d5e80, receiver=0x20130d0, event=0x202f540) at /home/myriam/kde/src/calligra/libs/main/KoApplication.cpp:504
#42 0x00007f9104c6892e in QCoreApplication::notifyInternal (this=0x7fff693d5e80, receiver=receiver@entry=0x20130d0, event=event@entry=0x202f540) at kernel/qcoreapplication.cpp:915
#43 0x00007f9104c6c7b1 in sendEvent (event=0x202f540, receiver=0x20130d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#44 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x119f2b0) at kernel/qcoreapplication.cpp:1539
#45 0x00007f9104c96ec3 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#46 postEventSourceDispatch (s=0x1335000) at kernel/qeventdispatcher_glib.cpp:279
#47 0x00007f9100992cc5 in g_timeout_source_new_seconds () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#48 0x0000000000992b02 in ?? ()
#49 0x0000000000000000 in ?? ()

Reported using DrKonqi
Comment 1 Camilla Boemann 2012-08-25 16:23:19 UTC
Yes I've seen this in master as well
Comment 2 Gopalakrishna Bhat 2012-08-31 15:45:28 UTC
Same backtrace so marking as duplicate

*** This bug has been marked as a duplicate of bug 305006 ***