Bug 305494 - Akregator always claims it wasn't closed correctly
Summary: Akregator always claims it wasn't closed correctly
Status: RESOLVED WORKSFORME
Alias: None
Product: akregator
Classification: Unclassified
Component: general (show other bugs)
Version: 4.9
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-20 14:50 UTC by Thomas Tanghus
Modified: 2015-08-07 07:48 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Tanghus 2012-08-20 14:50:19 UTC
Since updating to KDE 4.9 Akregator always claims that it wasn't closed correctly, and gives you the options to restore session, not restore, or to be asked later. It doesn't matter what you choose, nor does it matter if you run it from within Kontact or standalone. And there is no indication of a crash.

Reproducible: Always

Steps to Reproduce:
As described above.
Actual Results:  
You get prompted to restore or not.

Expected Results:  
It should only prompt if the application had crashed or forced closed.
Comment 1 Thomas Tanghus 2012-11-09 22:11:23 UTC
Still present on 4.9.3
Comment 2 Belomir 2013-01-07 08:14:01 UTC
Appeared for me after upgrading from kubuntu-backports ppa to 4.9.5
kubuntu 12.04, kde 4.9.5
Comment 3 zless 2013-02-14 18:02:11 UTC
The same in KDE 4.10 with kdepim-akregator 4.10.0-1 in AechLinux x64.
Comment 4 Frank Osterfeld 2013-03-03 10:34:03 UTC
Git commit f58fed85c84a268187cbdf58414dbe877190fba5 by Frank Osterfeld.
Committed on 03/03/2013 at 11:29.
Pushed by osterfeld into branch 'KDE/4.10'.

Do not ask to restore the session each time again

M  +1    -0    akregator/src/akregator_part.cpp

http://commits.kde.org/kdepim/f58fed85c84a268187cbdf58414dbe877190fba5
Comment 5 Thomas Tanghus 2013-04-25 00:35:35 UTC
I'm sorry to say it, but I'm running 4.10.2 and still have this problem.
Comment 6 Mathias Homann 2013-09-24 07:45:38 UTC
appeared for me in KDE 4.11.1 after rebuilding my ~/.kde4 settings folder from scratch.
Comment 7 Thomas Tanghus 2015-05-02 16:18:18 UTC
Closing this as I haven't experienced it in a long time.
Comment 8 Pal Körössy 2015-07-16 07:26:10 UTC
I have been experiencing this bug for ages (now KDE 4.14.9 OpenSUSE 13.2)
No changes after deletig ~kde4/
Thomas, would you please reopen it?
Comment 9 Mathias Homann 2015-07-16 07:37:32 UTC
same here - ever so often this comes back, sometimes with no discernible reason, sometimes because kontact crashed on exit which it does ever so often.

please reopen.
Comment 10 Pal Körössy 2015-07-16 07:56:33 UTC
For me deleting/renaming the folder ~/.kde4/share/apps/kontact solved the problem.
Comment 11 Pal Körössy 2015-08-07 07:48:19 UTC
(In reply to Pal Körössy from comment #10)
> For me deleting/renaming the folder ~/.kde4/share/apps/kontact solved the
> problem.

After one week the problem is back. Please reopen.