Bug 305214 - Word crash
Summary: Word crash
Status: RESOLVED DUPLICATE of bug 305006
Alias: None
Product: calligrawords
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Calligra Words Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-15 20:05 UTC by Erik Torp
Modified: 2012-08-31 15:44 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Torp 2012-08-15 20:05:08 UTC
Application: calligrawords (2.6 Pre-Alpha)
KDE Platform Version: 4.9.00
Qt Version: 4.8.3
Operating System: Linux 3.2.0-23-generic i686
Distribution: Linux Mint 13 Maya

-- Information about the crash:
- What I was doing when the application crashed:
Pressing the insert button in the right hand "Text editing menu" menu

-- Backtrace:
Application: Calligra Words (kdeinit4), signal: Aborted
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb7792740 (LWP 21688))]

Thread 2 (Thread 0xb4dcbb40 (LWP 21689)):
#0  0x0892e60d in g_ptr_array_set_size () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0x0895b726 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x0895bfaf in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x0895c201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x00d72fca in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/project-neon/lib/libQtCore.so.4
#5  0x00d3966d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/project-neon/lib/libQtCore.so.4
#6  0x00d397db in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/project-neon/lib/libQtCore.so.4
#7  0x00c1a195 in QThread::exec() () from /opt/project-neon/lib/libQtCore.so.4
#8  0x00d17582 in ?? () from /opt/project-neon/lib/libQtCore.so.4
#9  0x00c1c94d in ?? () from /opt/project-neon/lib/libQtCore.so.4
#10 0x00703d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#11 0x08db8ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb7792740 (LWP 21688)):
[KCrash Handler]
#7  0x0081c416 in __kernel_vsyscall ()
#8  0x08cfc1ef in raise () from /lib/i386-linux-gnu/libc.so.6
#9  0x08cff835 in abort () from /lib/i386-linux-gnu/libc.so.6
#10 0x00c10477 in qt_message_output(QtMsgType, char const*) () from /opt/project-neon/lib/libQtCore.so.4
#11 0x00c10616 in ?? () from /opt/project-neon/lib/libQtCore.so.4
#12 0x00c10a42 in qFatal(char const*, ...) () from /opt/project-neon/lib/libQtCore.so.4
#13 0x00c1002e in qt_assert(char const*, char const*, int) () from /opt/project-neon/lib/libQtCore.so.4
#14 0x043b62a9 in KWViewModeNormal::documentToView (this=0xa9c0588, point=..., viewConverter=0xa27454c) at /build/buildd/project-neon-calligra-2+git20120814+r73149/words/part/KWViewModeNormal.cpp:204
#15 0x043b4e46 in KWViewMode::documentToView (this=0xa9c0588, rect=..., viewConverter=0xa27454c) at /build/buildd/project-neon-calligra-2+git20120814+r73149/words/part/KWViewMode.cpp:40
#16 0x0439207c in KWCanvasBase::updateCanvas (this=0xab2e784, rc=...) at /build/buildd/project-neon-calligra-2+git20120814+r73149/words/part/KWCanvasBase.cpp:697
#17 0x0416fa5f in KoShapeManager::update (this=0xab2e188, rect=..., shape=0xc57ec08, selectionHandles=true) at /build/buildd/project-neon-calligra-2+git20120814+r73149/libs/flake/KoShapeManager.cpp:569
#18 0x0415a842 in KoShape::update (this=0xc57ec08) at /build/buildd/project-neon-calligra-2+git20120814+r73149/libs/flake/KoShape.cpp:585
#19 0x04169d19 in KoShapeContainer::update (this=0xc57ec08) at /build/buildd/project-neon-calligra-2+git20120814+r73149/libs/flake/KoShapeContainer.cpp:232
#20 0x056c280f in TextShape::update (this=0xc57ec08) at /build/buildd/project-neon-calligra-2+git20120814+r73149/plugins/textshape/TextShape.cpp:389
#21 0x0416dafb in KoShapeManager::addShape (this=0xab2e188, shape=0xc57ec08, repaint=KoShapeManager::PaintShapeOnAdd) at /build/buildd/project-neon-calligra-2+git20120814+r73149/libs/flake/KoShapeManager.cpp:230
#22 0x0417025a in KoShapeManager::qt_static_metacall (_o=0xab2e188, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0xbfb6ced4) at /build/buildd/project-neon-calligra-2+git20120814+r73149/obj-i686-linux-gnu/libs/flake/KoShapeManager.moc:68
#23 0x00d57845 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /opt/project-neon/lib/libQtCore.so.4
#24 0x04387155 in KWDocument::shapeAdded (this=0xa198fb0, _t1=0xc57ec08, _t2=KoShapeManager::AddWithoutRepaint) at /build/buildd/project-neon-calligra-2+git20120814+r73149/obj-i686-linux-gnu/words/part/moc_KWDocument.cpp:153
#25 0x04399223 in KWDocument::addFrame (this=0xa198fb0, frame=0xc5cb958) at /build/buildd/project-neon-calligra-2+git20120814+r73149/words/part/KWDocument.cpp:412
#26 0x04386ee4 in KWDocument::qt_static_metacall (_o=0xa198fb0, _c=QMetaObject::InvokeMetaMethod, _id=9, _a=0xbfb6d068) at /build/buildd/project-neon-calligra-2+git20120814+r73149/obj-i686-linux-gnu/words/part/moc_KWDocument.cpp:88
#27 0x00d57845 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /opt/project-neon/lib/libQtCore.so.4
#28 0x04388232 in KWFrameSet::frameAdded (this=0xa5e7d58, _t1=0xc5cb958) at /build/buildd/project-neon-calligra-2+git20120814+r73149/obj-i686-linux-gnu/words/part/moc_KWFrameSet.cpp:101
#29 0x043d91ae in KWFrameSet::addFrame (this=0xa5e7d58, frame=0xc5cb958) at /build/buildd/project-neon-calligra-2+git20120814+r73149/words/part/frames/KWFrameSet.cpp:68
#30 0x043d7b63 in KWFrame::KWFrame (this=0xc5cb958, shape=0xc57ec08, parent=0xa5e7d58, anchor=0x0) at /build/buildd/project-neon-calligra-2+git20120814+r73149/words/part/frames/KWFrame.cpp:49
#31 0x043d2ccd in KWFrameLayout::createNewFramesForPage (this=0xa198fd4, pageNumber=2) at /build/buildd/project-neon-calligra-2+git20120814+r73149/words/part/frames/KWFrameLayout.cpp:210
#32 0x043f6928 in KWPageInsertCommand::redo (this=0xc4c7c00) at /build/buildd/project-neon-calligra-2+git20120814+r73149/words/part/commands/KWPageInsertCommand.cpp:108
#33 0x04397f66 in KWDocument::insertPage (this=0xa198fb0, afterPageNum=1, masterPageName=..., addUndoRedoCommand=false) at /build/buildd/project-neon-calligra-2+git20120814+r73149/words/part/KWDocument.cpp:234
#34 0x04398082 in KWDocument::appendPage (this=0xa198fb0, masterPageName=..., addUndoRedoCommand=false) at /build/buildd/project-neon-calligra-2+git20120814+r73149/words/part/KWDocument.cpp:248
#35 0x043cbce8 in KWRootAreaProvider::provideNext (this=0xa5e9730, documentLayout=0xa5e9ea0) at /build/buildd/project-neon-calligra-2+git20120814+r73149/words/part/KWRootAreaProvider.cpp:193
#36 0x043cc7c0 in KWRootAreaProvider::provide (this=0xa5e9730, documentLayout=0xa5e9ea0) at /build/buildd/project-neon-calligra-2+git20120814+r73149/words/part/KWRootAreaProvider.cpp:300
#37 0x035eb6af in KoTextDocumentLayout::doLayout (this=0xa5e9ea0) at /build/buildd/project-neon-calligra-2+git20120814+r73149/libs/textlayout/KoTextDocumentLayout.cpp:732
#38 0x035ead44 in KoTextDocumentLayout::layout (this=0xa5e9ea0) at /build/buildd/project-neon-calligra-2+git20120814+r73149/libs/textlayout/KoTextDocumentLayout.cpp:608
#39 0x035ebcc7 in KoTextDocumentLayout::executeScheduledLayout (this=0xa5e9ea0) at /build/buildd/project-neon-calligra-2+git20120814+r73149/libs/textlayout/KoTextDocumentLayout.cpp:819
#40 0x035ec434 in KoTextDocumentLayout::qt_static_metacall (_o=0xa5e9ea0, _c=QMetaObject::InvokeMetaMethod, _id=6, _a=0xc5c4230) at /build/buildd/project-neon-calligra-2+git20120814+r73149/obj-i686-linux-gnu/libs/textlayout/KoTextDocumentLayout.moc:66
#41 0x00d51d7a in QMetaCallEvent::placeMetaCall(QObject*) () from /opt/project-neon/lib/libQtCore.so.4
#42 0x00d52e18 in QObject::event(QEvent*) () from /opt/project-neon/lib/libQtCore.so.4
#43 0x0105616c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /opt/project-neon/lib/libQtGui.so.4
#44 0x01053a6a in QApplication::notify(QObject*, QEvent*) () from /opt/project-neon/lib/libQtGui.so.4
#45 0x002f62f2 in KApplication::notify(QObject*, QEvent*) () from /opt/project-neon/lib/libkdeui.so.5
#46 0x00d3bee2 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /opt/project-neon/lib/libQtCore.so.4
#47 0x00d3f649 in QCoreApplication::sendEvent(QObject*, QEvent*) () from /opt/project-neon/lib/libQtCore.so.4
#48 0x00d3cdde in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /opt/project-neon/lib/libQtCore.so.4
#49 0x00d3ca9b in QCoreApplication::sendPostedEvents(QObject*, int) () from /opt/project-neon/lib/libQtCore.so.4
#50 0x00d7367a in QCoreApplication::sendPostedEvents() () from /opt/project-neon/lib/libQtCore.so.4
#51 0x00d7281e in ?? () from /opt/project-neon/lib/libQtCore.so.4
#52 0x0895bd86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#53 0x0895c125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#54 0x0895c201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#55 0x00d72faa in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/project-neon/lib/libQtCore.so.4
#56 0x0111f8b0 in ?? () from /opt/project-neon/lib/libQtGui.so.4
#57 0x00d3966d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/project-neon/lib/libQtCore.so.4
#58 0x00d397db in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/project-neon/lib/libQtCore.so.4
#59 0x00d3c55e in QCoreApplication::exec() () from /opt/project-neon/lib/libQtCore.so.4
#60 0x010536de in QApplication::exec() () from /opt/project-neon/lib/libQtGui.so.4
#61 0x0661bd39 in kdemain (argc=1, argv=0x9fd6a50) at /build/buildd/project-neon-calligra-2+git20120814+r73149/words/part/main.cpp:43
#62 0x0804d78f in _start ()

Reported using DrKonqi
Comment 1 Camilla Boemann 2012-08-15 22:13:19 UTC
Could you please try with a newer version and also could you please describe a bbit more detailed what you do?
Comment 2 Gopalakrishna Bhat 2012-08-31 15:43:22 UTC
I am able to reproduce this. 
1) Open a blank document.
2) Insert a page break through the docker or Ctrl + Enter.
Comment 3 Gopalakrishna Bhat 2012-08-31 15:44:30 UTC
Same backtrace so marking as duplicate

*** This bug has been marked as a duplicate of bug 305006 ***