Bug 305015 - Oxygen tooltips has no borders
Summary: Oxygen tooltips has no borders
Status: RESOLVED INTENTIONAL
Alias: None
Product: Oxygen
Classification: Unclassified
Component: style (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Hugo Pereira Da Costa
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-12 11:22 UTC by Tenno Seremel
Modified: 2012-08-12 17:14 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tenno Seremel 2012-08-12 11:22:02 UTC
Oxygen (as opposed to, say, Plastique) tooltips has no borders and this cannot be configured. I think there should be an option to specify tooltip border color.

Qt: 4.8.2
KDE: 4.8.4 (4.8.4)

Reproducible: Always

Steps to Reproduce:
1. Set Oxygen widget style.
2. Turn off KWin compositing.
3. Hover any item in a GUI that has a tooltip info.
Actual Results:  
Tooltip appears without any border which looks pretty weird when tooltip's and window's background color is the same.

Expected Results:  
Tooltip should have a border.

http://forum.kde.org/viewtopic.php?f=17&t=107304
Comment 1 Christoph Feck 2012-08-12 12:15:39 UTC
Tooltips use a shadow, so on very dark color themes, it should probably use a glow instead (as window decorations).
Comment 2 Hugo Pereira Da Costa 2012-08-12 16:15:52 UTC
@Christoph
Glow is for active windows, which tooltips are not. Besides the bug report is about compositing turned off, so no shadow/glow. 
My suggestion would be to just change the color scheme to use high contrast background for tooltips wrt window, since there are dedicated settings for that in the color scheme.
As far as I know there is no solution within oxygen, that would work with all colorscheme any way.
So closing as wontfix, sorry.
Comment 3 Hugo Pereira Da Costa 2012-08-12 16:17:16 UTC
PS actually, tooltips do have a 1 pixel border (contrast), that is only visible however, if the background color is not too dark.
Comment 4 Tenno Seremel 2012-08-12 17:14:12 UTC
So, there is no solution right now so you won't do and change it and just close this bug instead? The hell reasoning is that? This is seriously dumb. Whatever, suit yourself.