Bug 304959 - Advanced slideshow
Summary: Advanced slideshow
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Generic-Presentation (show other bugs)
Version: 2.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-11 05:45 UTC by jlazenby
Modified: 2016-07-09 12:06 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.1.0


Attachments
New crash information added by DrKonqi (9.62 KB, text/plain)
2013-05-08 21:43 UTC, john
Details
New crash information added by DrKonqi (7.03 KB, text/plain)
2013-07-26 11:43 UTC, werner.dilling
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jlazenby 2012-08-11 05:45:26 UTC
Application: digikam (2.5.0)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-27-generic-pae i686
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
After setting 3 second delay, show captions, no filename, no transitions; It crashed when I tried to start the advanced slideshow

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xaeaf08c0 (LWP 3693))]

Thread 5 (Thread 0xac856b40 (LWP 3696)):
#0  0xb77bb424 in __kernel_vsyscall ()
#1  0xb357e96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb483e3dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb4b03350 in wait (time=4294967295, this=0x8f0da28) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x8f0d994, mutex=0x8f0d990, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0x0820346e in Digikam::ScanController::run (this=0x8ef1a30) at /build/buildd/digikam-2.5.0/core/digikam/database/scancontroller.cpp:647
#6  0xb4b02de0 in QThreadPrivate::start (arg=0x8ef1a30) at thread/qthread_unix.cpp:298
#7  0xb357ad4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb4830ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xabeffb40 (LWP 3697)):
#0  0xb3037dcd in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb4b61315 in do_gettime (frac=0xabefee30, sec=0xabefee28) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb4c4b226 in QTimerInfoList::updateCurrentTime (this=0xab502074) at kernel/qeventdispatcher_unix.cpp:343
#4  0xb4c4b57a in QTimerInfoList::timerWait (this=0xab502074, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#5  0xb4c49e23 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xabefef3c) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb4c49ebd in timerSourcePrepare (source=0xab502040, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb31d2872 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb31d2faf in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb31d3201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb4c4a8e7 in QEventDispatcherGlib::processEvents (this=0xab500468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0xb4c1650d in QEventLoop::processEvents (this=0xabeff0c0, flags=...) at kernel/qeventloop.cpp:149
#12 0xb4c167a9 in QEventLoop::exec (this=0xabeff0c0, flags=...) at kernel/qeventloop.cpp:204
#13 0xb4aff94c in QThread::exec (this=0x8f0e4a8) at thread/qthread.cpp:501
#14 0xb4bf3b5d in QInotifyFileSystemWatcherEngine::run (this=0x8f0e4a8) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb4b02de0 in QThreadPrivate::start (arg=0x8f0e4a8) at thread/qthread_unix.cpp:298
#16 0xb357ad4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb4830ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xab4ffb40 (LWP 3699)):
#0  0xb77bb424 in __kernel_vsyscall ()
#1  0xb357e96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb483e3dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb4b03350 in wait (time=4294967295, this=0x9022f58) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x9022d98, mutex=0x9022d94, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb6abab2c in Digikam::ParkingThread::run (this=0x9022d88) at /build/buildd/digikam-2.5.0/core/libs/threads/threadmanager.cpp:119
#6  0xb4b02de0 in QThreadPrivate::start (arg=0x9022d88) at thread/qthread_unix.cpp:298
#7  0xb357ad4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb4830ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0x9f338b40 (LWP 3746)):
#0  0xb77bb424 in __kernel_vsyscall ()
#1  0xb357e96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb483e3dc in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb4b03350 in wait (time=4294967295, this=0xafb12c8) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0xafb08fc, mutex=0xafb08f8, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xaa5d475a in KIPIPlugins::LoadRawThumbThread::run (this=0xafb0c68) at /build/buildd/digikam-2.5.0/extra/kipi-plugins/common/libkipiplugins/dialogs/imagedialog.cpp:547
#6  0xb4b02de0 in QThreadPrivate::start (arg=0xafb0c68) at thread/qthread_unix.cpp:298
#7  0xb357ad4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb4830ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xaeaf08c0 (LWP 3693)):
[KCrash Handler]
#7  isEmpty (this=0xffffb401) at /usr/include/qt4/QtCore/qstring.h:705
#8  KUrl::KUrl (this=0xbfd14d6c, str=...) at ../../kdecore/io/kurl.cpp:403
#9  0xa307c9ec in KIPIAdvancedSlideshowPlugin::SlideShowLoader::checkIsIn (this=0xb198b60, index=-1) at /build/buildd/digikam-2.5.0/extra/kipi-plugins/advancedslideshow/plugin/slideshowloader.cpp:278
#10 0xa307cf80 in KIPIAdvancedSlideshowPlugin::SlideShowLoader::getCurrent (this=0xb198b60) at /build/buildd/digikam-2.5.0/extra/kipi-plugins/advancedslideshow/plugin/slideshowloader.cpp:255
#11 0xa3069f3e in KIPIAdvancedSlideshowPlugin::SlideShow::loadNextImage (this=0xb194410) at /build/buildd/digikam-2.5.0/extra/kipi-plugins/advancedslideshow/widgets/slideshow.cpp:334
#12 0xa306e338 in KIPIAdvancedSlideshowPlugin::SlideShow::slotTimeOut (this=0xb194410) at /build/buildd/digikam-2.5.0/extra/kipi-plugins/advancedslideshow/widgets/slideshow.cpp:266
#13 0xa306e4ed in KIPIAdvancedSlideshowPlugin::SlideShow::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=<optimized out>, _c=<optimized out>) at /build/buildd/digikam-2.5.0/obj-i686-linux-gnu/extra/kipi-plugins/advancedslideshow/slideshow.moc:58
#14 0xb4c2e6b1 in QMetaObject::activate (sender=0xb1a60d0, m=0xb4d754d8, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3547
#15 0xb4c81625 in QTimer::timeout (this=0xb1a60d0) at .moc/release-shared/moc_qtimer.cpp:148
#16 0xb4c37566 in QTimer::timerEvent (this=0xb1a60d0, e=0xbfd1555c) at kernel/qtimer.cpp:280
#17 0xb4c32ac4 in QObject::event (this=0xb1a60d0, e=0xbfd1555c) at kernel/qobject.cpp:1157
#18 0xb5184ed4 in notify_helper (e=0xbfd1555c, receiver=0xb1a60d0, this=0x8e18e90) at kernel/qapplication.cpp:4559
#19 QApplicationPrivate::notify_helper (this=0x8e18e90, receiver=0xb1a60d0, e=0xbfd1555c) at kernel/qapplication.cpp:4531
#20 0xb518a30d in QApplication::notify (this=0xbfd1555c, receiver=0xb1a60d0, e=0xbfd1555c) at kernel/qapplication.cpp:4288
#21 0xb5d0a401 in KApplication::notify (this=0xbfd158e0, receiver=0xb1a60d0, event=0xbfd1555c) at ../../kdeui/kernel/kapplication.cpp:311
#22 0xb4c1797e in QCoreApplication::notifyInternal (this=0xbfd158e0, receiver=0xb1a60d0, event=0xbfd1555c) at kernel/qcoreapplication.cpp:876
#23 0xb4c4c990 in sendEvent (event=0xbfd1555c, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#24 QTimerInfoList::activateTimers (this=0x8e1897c) at kernel/qeventdispatcher_unix.cpp:611
#25 0xb4c4a0f8 in timerSourceDispatch (source=0x8e18948) at kernel/qeventdispatcher_glib.cpp:186
#26 timerSourceDispatch (source=0x8e18948) at kernel/qeventdispatcher_glib.cpp:180
#27 0xb31d2d86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#28 0xb31d3125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#29 0xb31d3201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#30 0xb4c4a887 in QEventDispatcherGlib::processEvents (this=0x8dd58a0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#31 0xb523daaa in QGuiEventDispatcherGlib::processEvents (this=0x8dd58a0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#32 0xb4c1650d in QEventLoop::processEvents (this=0xbfd157c4, flags=...) at kernel/qeventloop.cpp:149
#33 0xb4c167a9 in QEventLoop::exec (this=0xbfd157c4, flags=...) at kernel/qeventloop.cpp:204
#34 0xb4c1beba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#35 0xb5182a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#36 0x080b69e4 in main (argc=186278576, argv=0xb48e7470) at /build/buildd/digikam-2.5.0/core/digikam/main/main.cpp:232

This bug may be a duplicate of or related to bug 299191.

Possible duplicates by query: bug 304412, bug 299191.

Reported using DrKonqi
Comment 1 caulier.gilles 2012-08-11 18:27:06 UTC
It crash in KDELibs (KUrl API). I suspect a binary compatibility issue on your system between KDELibs and kipi-plugins.

Check your system and update KIPI-plugins to last 2.7.0 or 2.8.0 and try again...

Gilles Caulier
Comment 2 john 2013-05-08 21:43:22 UTC
Created attachment 79787 [details]
New crash information added by DrKonqi

digikam (3.1.0) on KDE Platform 4.10.2 using Qt 4.8.4

- What I was doing when the application crashed:
Opening "Advanced Slideshow" to view album with captions and titles on perhaps 40 photos

-- Backtrace (Reduced):
#7  isEmpty (this=<optimized out>) at /usr/include/qt4/QtCore/qstring.h:705
#8  KUrl::KUrl (this=0xbf8b1388, str=...) at ../../kdecore/io/kurl.cpp:403
#9  0x9376d225 in KIPIAdvancedSlideshowPlugin::SlideShowLoader::checkIsIn (this=this@entry=0xc0496e0, index=-1) at /build/buildd/digikam-3.1.0/extra/kipi-plugins/advancedslideshow/plugin/slideshowloader.cpp:280
#10 0x9376dab0 in KIPIAdvancedSlideshowPlugin::SlideShowLoader::getCurrent (this=0xc0496e0) at /build/buildd/digikam-3.1.0/extra/kipi-plugins/advancedslideshow/plugin/slideshowloader.cpp:258
#11 0x9376231e in KIPIAdvancedSlideshowPlugin::SlideShow::loadNextImage (this=this@entry=0xaa3c148) at /build/buildd/digikam-3.1.0/extra/kipi-plugins/advancedslideshow/widgets/slideshow.cpp:338
Comment 3 werner.dilling 2013-07-26 11:43:11 UTC
Created attachment 81357 [details]
New crash information added by DrKonqi

digikam (2.6.0) on KDE Platform 4.8.5 (4.8.5) "release 2" using Qt 4.8.1

no further infos available

-- Backtrace (Reduced):
#6  KUrl::KUrl (this=0x7fff9b89a450, str=...) at /usr/src/debug/kdelibs-4.8.5/kdecore/io/kurl.cpp:403
#7  0x00007ff6a00adfff in KIPIAdvancedSlideshowPlugin::SlideShowLoader::checkIsIn (this=this@entry=0x6333f50, index=-1) at /usr/src/debug/digikam-2.6.0/extra/kipi-plugins/advancedslideshow/plugin/slideshowloader.cpp:279
#8  0x00007ff6a00ae4ec in KIPIAdvancedSlideshowPlugin::SlideShowLoader::getCurrent (this=0x6333f50) at /usr/src/debug/digikam-2.6.0/extra/kipi-plugins/advancedslideshow/plugin/slideshowloader.cpp:256
#9  0x00007ff6a009e0ac in KIPIAdvancedSlideshowPlugin::SlideShow::loadNextImage (this=0x62f9230) at /usr/src/debug/digikam-2.6.0/extra/kipi-plugins/advancedslideshow/widgets/slideshow.cpp:334
#10 0x00007ff6a00a1e55 in KIPIAdvancedSlideshowPlugin::SlideShow::slotTimeOut (this=0x62f9230) at /usr/src/debug/digikam-2.6.0/extra/kipi-plugins/advancedslideshow/widgets/slideshow.cpp:266
Comment 4 caulier.gilles 2015-06-27 13:43:24 UTC
New digiKam 4.11.0 is available :

https://www.digikam.org/node/740

Can you reproduce the problem with this release ?

Gilles caulier
Comment 5 caulier.gilles 2015-08-22 06:34:16 UTC
digiKam 4.12.0 is out :

https://www.digikam.org/node/741

We need a fresh feedback using this release please...
Thanks in advance.
Comment 6 caulier.gilles 2016-07-09 12:06:22 UTC
This problem is not reproducible with last 5.0.0.
I close this file now. Don't hesitate to re-open it if necessary.
Gilles Caulier