Bug 304665 - When choosing "System Settings" for anti-aliasing, the system wide settings are actually not being used.
Summary: When choosing "System Settings" for anti-aliasing, the system wide settings a...
Status: RESOLVED DUPLICATE of bug 244857
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_fonts (show other bugs)
Version: 4.8.4
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-06 13:18 UTC by Andrey
Modified: 2012-12-06 12:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey 2012-08-06 13:18:52 UTC
There is a list "Use anti-aliasing" in System Settings -> Application Appearance -> Fonts which gives you 3 options: Enabled, Disabled, System Settings.

If you choose "System Settings", you expect that system wide settings will be used (see section "Anti-aliasing text" in official documentation http://docs.kde.org/stable/en/kde-workspace/kcontrol/fonts/index.html). As far as I know, the right way to control these settings is maintaining "10-antialias.conf" symlink in /etc/fonts/conf.d directory.

However, there is a problem: the global on/off settings for antialiasing actually doesn't work. Instead the previous enabled/disabled setting is used.

Reproducible: Always

Steps to Reproduce:
Let's consider the case when the system wide settings enable anti-aliasing (i.e. there is a 10-antialias.conf symbolic link in /etc/fonts/conf.d).
1. Go to System Settings -> Application Appearance -> Fonts.
2. Choose "Disabled", click "Apply". Then choose "System Settings" and apply again.
Actual Results:  
Anti-aliasing will be disabled, despite the system wide settings.

Expected Results:  
I expect that the system wide settings will be used, i.e. anti-aliasing will be enabled.

Here I will give my guess about the reasons of this behavior.
When choosing "Disabled" and clicking "Apply" the file .fonts.conf in home directory is created:
andrey@andrey-ThinkPad-X220:~$ tail -6 .fonts.conf
 <match target="font">
  <edit mode="assign" name="antialias">
   <bool>false</bool>
  </edit>
 </match>
</fontconfig>

When choosing "System Settings" this file is still present, and it overrides system settings.
I think that solution is removing the section corresponding to anti-aliasing from local .fonts.conf when choosing "System Settings". We can do this manually, or we can remove this file. In this case global settings will finally be used.
Comment 1 Jekyll Wu 2012-12-04 07:51:51 UTC
Thanks for reporting .

*** This bug has been marked as a duplicate of bug 244857 ***