Bug 304376 - KDE Crashes with no visible side-effects other than a crash report.
Summary: KDE Crashes with no visible side-effects other than a crash report.
Status: RESOLVED DUPLICATE of bug 301828
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kded (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-01 11:31 UTC by piet de weerdt
Modified: 2012-08-01 12:15 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description piet de weerdt 2012-08-01 11:31:33 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.8.4 (4.8.4) "release 513"
Qt Version: 4.8.2
Operating System: Linux 3.1.10-1.16-default x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
1) Evolution, Okular and kaffiene are active applications.
2) Crossover (Wine) is running "MS Visio 2003"
3) crossover was installed from "install-crossover-pro-9.0.1.sh"
4) recoll was indexing some files but seems to have stopped. Could be done or as a result of the crash. Indexing is set to "real-time"

This has happened a few times, typically once every 3-4 days, similar applications are normally active other than perhaps SlickEdit

The crash can be reproduced some of the time.

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Aborted
[Current thread is 1 (Thread 0x7f9d5993d760 (LWP 3350))]

Thread 8 (Thread 0x7f9d3fb32700 (LWP 3353)):
#0  0x00007f9d56f32ff3 in poll () from /lib64/libc.so.6
#1  0x00007f9d53af5a98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9d53af5f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f9d585a1e36 in QEventDispatcherGlib::processEvents (this=0x7f9d380008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f9d58571842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9d58571a97 in QEventLoop::exec (this=0x7f9d3fb31e20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9d584715f7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f9d5847461b in QThreadPrivate::start (arg=0x8880d0) at thread/qthread_unix.cpp:307
#8  0x00007f9d581dcf05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f9d56f3c10d in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f9d3f331700 (LWP 3358)):
#0  0x00007f9d53af586d in ?? () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f9d53af5f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9d585a1e36 in QEventDispatcherGlib::processEvents (this=0x7f9d300008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#3  0x00007f9d58571842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#4  0x00007f9d58571a97 in QEventLoop::exec (this=0x7f9d3f330df0, flags=...) at kernel/qeventloop.cpp:204
#5  0x00007f9d584715f7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#6  0x00007f9d5855162f in QInotifyFileSystemWatcherEngine::run (this=0x894430) at io/qfilesystemwatcher_inotify.cpp:248
#7  0x00007f9d5847461b in QThreadPrivate::start (arg=0x894430) at thread/qthread_unix.cpp:307
#8  0x00007f9d581dcf05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f9d56f3c10d in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f9d2fbca700 (LWP 3436)):
#0  0x00007f9d581df014 in pthread_mutex_lock () from /lib64/libpthread.so.0
#1  0x00007f9d53af498d in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9d53af592d in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f9d53af62c2 in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f9d3c1fd946 in ?? () from /usr/lib64/libgio-2.0.so.0
#5  0x00007f9d53b1adb6 in ?? () from /usr/lib64/libglib-2.0.so.0
#6  0x00007f9d581dcf05 in start_thread () from /lib64/libpthread.so.0
#7  0x00007f9d56f3c10d in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f9d27fff700 (LWP 3456)):
#0  0x00007f9d56f32ff3 in poll () from /lib64/libc.so.6
#1  0x00007f9d53af5a98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9d53af5f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f9d585a1e36 in QEventDispatcherGlib::processEvents (this=0x7f9d1c0008c0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f9d58571842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9d58571a97 in QEventLoop::exec (this=0x7f9d27ffee20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9d584715f7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f9d5847461b in QThreadPrivate::start (arg=0x7f9d20002390) at thread/qthread_unix.cpp:307
#8  0x00007f9d581dcf05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f9d56f3c10d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f9d2db2c700 (LWP 3566)):
[KCrash Handler]
#6  0x00007f9d56e95d95 in raise () from /lib64/libc.so.6
#7  0x00007f9d56e972ab in abort () from /lib64/libc.so.6
#8  0x00007f9d572aff2d in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib64/libstdc++.so.6
#9  0x00007f9d572ae0d6 in ?? () from /usr/lib64/libstdc++.so.6
#10 0x00007f9d572ae103 in std::terminate() () from /usr/lib64/libstdc++.so.6
#11 0x00007f9d572aeb1f in __cxa_pure_virtual () from /usr/lib64/libstdc++.so.6
#12 0x00007f9d5857602c in QCoreApplication::postEvent (receiver=0x7f9d08022120, event=0x7f9d08007f90, priority=<optimized out>) at kernel/qcoreapplication.cpp:1361
#13 0x00007f9d58586fa4 in queued_activate (argv=0x7f9d2db2ada0, c=0x7f9d08021b80, signal=13, sender=0x7f9d08029cc0) at kernel/qobject.cpp:3440
#14 QMetaObject::activate (sender=0x7f9d08029cc0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3516
#15 0x00007f9d56242d3f in QNetworkAccessHttpBackend::postRequest (this=0x7f9d08029cc0) at access/qnetworkaccesshttpbackend.cpp:675
#16 0x00007f9d562384c3 in QNetworkAccessBackend::start (this=0x7f9d08029cc0) at access/qnetworkaccessbackend.cpp:413
#17 0x00007f9d5625661b in QNetworkReplyImplPrivate::_q_startOperation (this=0x7f9d0803b3d0) at access/qnetworkreplyimpl.cpp:93
#18 0x00007f9d56256d6f in QNetworkReplyImplPrivate::setup (this=0x7f9d0803b3d0, op=<optimized out>, req=..., data=<optimized out>) at access/qnetworkreplyimpl.cpp:374
#19 0x00007f9d56233a4f in QNetworkAccessManager::createRequest (this=0x7f9d2db2bc78, op=QNetworkAccessManager::GetOperation, req=<optimized out>, outgoingData=0x0) at access/qnetworkaccessmanager.cpp:1003
#20 0x00007f9d56232134 in QNetworkAccessManager::get (this=0x7f9d2db2bc78, request=<optimized out>) at access/qnetworkaccessmanager.cpp:598
#21 0x00007f9d4f9d06f2 in Herqq::Upnp::HDataRetriever::retrieveData(QUrl const&, QUrl const&, QByteArray*) () from /usr/lib64/libHUpnp.so.1
#22 0x00007f9d4f9d104d in Herqq::Upnp::HDataRetriever::retrieveDeviceDescription(QUrl const&, QString*) () from /usr/lib64/libHUpnp.so.1
#23 0x00007f9d4f9c3f35 in Herqq::Upnp::HControlPointPrivate::buildDevice(QUrl const&, int, QString*) () from /usr/lib64/libHUpnp.so.1
#24 0x00007f9d4f9cf6d2 in Herqq::Upnp::DeviceBuildTask::run() () from /usr/lib64/libHUpnp.so.1
#25 0x00007f9d58467dd2 in QThreadPoolThread::run (this=0x88c2b0) at concurrent/qthreadpool.cpp:107
#26 0x00007f9d5847461b in QThreadPrivate::start (arg=0x88c2b0) at thread/qthread_unix.cpp:307
#27 0x00007f9d581dcf05 in start_thread () from /lib64/libpthread.so.0
#28 0x00007f9d56f3c10d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f9d25ffb700 (LWP 3933)):
#0  0x00007f9d56f32ff3 in poll () from /lib64/libc.so.6
#1  0x00007f9d53af5a98 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9d53af5f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f9d585a1e36 in QEventDispatcherGlib::processEvents (this=0x7f9cfc0056b0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f9d58571842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9d58571a97 in QEventLoop::exec (this=0x7f9d25ffae20, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9d584715f7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f9d5847461b in QThreadPrivate::start (arg=0x9fdd40) at thread/qthread_unix.cpp:307
#8  0x00007f9d581dcf05 in start_thread () from /lib64/libpthread.so.0
#9  0x00007f9d56f3c10d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f9d267fc700 (LWP 10928)):
#0  0x00007f9d56f38cd9 in syscall () from /lib64/libc.so.6
#1  0x00007f9d584730eb in _q_futex (val2=0, addr2=0x0, timeout=0x0, val=2, op=0, addr=0x740840) at thread/qmutex_unix.cpp:99
#2  QMutexPrivate::wait (this=0x740840, timeout=<optimized out>) at thread/qmutex_unix.cpp:113
#3  0x00007f9d5846eead in QMutex::lockInternal (this=<optimized out>) at thread/qmutex.cpp:450
#4  0x00007f9d5858b300 in relock (mtx2=0x72c000, mtx1=0x99f4d0) at ../../src/corelib/thread/qorderedmutexlocker_p.h:108
#5  relock (mtx2=0x72c000, mtx1=0x99f4d0) at kernel/qobject.cpp:817
#6  QObject::~QObject (this=0x7f9d08022120, __in_chrg=<optimized out>) at kernel/qobject.cpp:881
#7  0x00007f9d562675b9 in QHttpThreadDelegate::~QHttpThreadDelegate (this=0x7f9d08022120, __in_chrg=<optimized out>) at access/qhttpthreaddelegate.cpp:190
#8  0x00007f9d5858be38 in QObject::event (this=0x7f9d08022120, e=<optimized out>) at kernel/qobject.cpp:1185
#9  0x00007f9d576d8fe4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#10 0x00007f9d576dddb3 in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#11 0x00007f9d59339746 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#12 0x00007f9d58572d0c in QCoreApplication::notifyInternal (this=0x7fff8858cdd0, receiver=0x7f9d08022120, event=0x7f9d04007410) at kernel/qcoreapplication.cpp:915
#13 0x00007f9d585765ba in sendEvent (event=0x7f9d04007410, receiver=0x7f9d08022120) at kernel/qcoreapplication.h:231
#14 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x7f9d0801a220) at kernel/qcoreapplication.cpp:1539
#15 0x00007f9d585a19a3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#16 postEventSourceDispatch (s=0x7f9d04006610) at kernel/qeventdispatcher_glib.cpp:279
#17 0x00007f9d53af558d in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#18 0x00007f9d53af5d88 in ?? () from /usr/lib64/libglib-2.0.so.0
#19 0x00007f9d53af5f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#20 0x00007f9d585a1dcf in QEventDispatcherGlib::processEvents (this=0x7f9d040067d0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#21 0x00007f9d58571842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#22 0x00007f9d58571a97 in QEventLoop::exec (this=0x7f9d267fbe20, flags=...) at kernel/qeventloop.cpp:204
#23 0x00007f9d584715f7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#24 0x00007f9d5847461b in QThreadPrivate::start (arg=0x7f9d08026c60) at thread/qthread_unix.cpp:307
#25 0x00007f9d581dcf05 in start_thread () from /lib64/libpthread.so.0
#26 0x00007f9d56f3c10d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f9d5993d760 (LWP 3350)):
#0  0x00007f9d56f38cd9 in syscall () from /lib64/libc.so.6
#1  0x00007f9d584730eb in _q_futex (val2=0, addr2=0x0, timeout=0x0, val=2, op=0, addr=0x740840) at thread/qmutex_unix.cpp:99
#2  QMutexPrivate::wait (this=0x740840, timeout=<optimized out>) at thread/qmutex_unix.cpp:113
#3  0x00007f9d5846eead in QMutex::lockInternal (this=<optimized out>) at thread/qmutex.cpp:450
#4  0x00007f9d58586abb in lockInline (this=0x72c000) at ../../src/corelib/thread/qmutex.h:190
#5  lockInline (this=0x72c000) at kernel/qobject.cpp:3456
#6  QMutexLocker (m=<optimized out>, this=<optimized out>) at ../../src/corelib/thread/qmutex.h:109
#7  QMetaObject::activate (sender=0x90b328, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8858ca10) at kernel/qobject.cpp:3481
#8  0x00007f9d5858759f in QObject::destroyed (this=<optimized out>, _t1=0x90b328) at .moc/release-shared/moc_qobject.cpp:149
#9  0x00007f9d5858b04e in QObject::~QObject (this=0x90b328, __in_chrg=<optimized out>) at kernel/qobject.cpp:844
#10 0x00007f9d5937ae78 in KGlobalAccel::~KGlobalAccel() () from /usr/lib64/libkdeui.so.5
#11 0x00007f9d5937aef9 in KGlobalAccel::~KGlobalAccel() () from /usr/lib64/libkdeui.so.5
#12 0x00007f9d56e989a1 in __run_exit_handlers () from /lib64/libc.so.6
#13 0x00007f9d56e98a25 in exit () from /lib64/libc.so.6
#14 0x00007f9d57744c68 in ?? () from /usr/lib64/libQtGui.so.4
#15 0x00007f9d59337a08 in KApplication::xioErrhandler(_XDisplay*) () from /usr/lib64/libkdeui.so.5
#16 0x00007f9d58df851e in _XIOError () from /usr/lib64/libX11.so.6
#17 0x00007f9d58df5e2d in _XEventsQueued () from /usr/lib64/libX11.so.6
#18 0x00007f9d58de681f in XEventsQueued () from /usr/lib64/libX11.so.6
#19 0x00007f9d5777c4dc in ?? () from /usr/lib64/libQtGui.so.4
#20 0x00007f9d53af5264 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#21 0x00007f9d53af5ab2 in ?? () from /usr/lib64/libglib-2.0.so.0
#22 0x00007f9d53af5f59 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f9d585a1dcf in QEventDispatcherGlib::processEvents (this=0x616770, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#24 0x00007f9d5777c69e in ?? () from /usr/lib64/libQtGui.so.4
#25 0x00007f9d58571842 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007f9d58571a97 in QEventLoop::exec (this=0x7fff8858cd60, flags=...) at kernel/qeventloop.cpp:204
#27 0x00007f9d585768b5 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#28 0x00007f9d465d2495 in kdemain () from /usr/lib64/libkdeinit4_kded4.so
#29 0x00000000004088e4 in _start ()

Possible duplicates by query: bug 301828.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-08-01 12:15:54 UTC

*** This bug has been marked as a duplicate of bug 301828 ***