Bug 304095 - Some of the contact groups open in a collapsed state
Summary: Some of the contact groups open in a collapsed state
Status: RESOLVED FIXED
Alias: None
Product: telepathy
Classification: Unclassified
Component: contactlist (show other bugs)
Version: git-latest
Platform: Chakra Linux
: NOR normal
Target Milestone: Future
Assignee: Telepathy Bugs
URL:
Keywords:
: 301719 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-26 14:42 UTC by Venky
Modified: 2013-03-27 14:29 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Venky 2012-07-26 14:42:21 UTC
Few of my contact groups especially in yahoo open collapsed state after every re-connect

Reproducible: Always

Steps to Reproduce:
1.connect to a yahoo account
2.find a group with more than one person online and open the group to see the online members (it will be collapsed)
3. Disconnect and reconnect..the group will go back to collapsed

This happens with facebook too I suppose
Comment 1 Martin Klapetek 2012-07-26 15:36:53 UTC
This should be fixed in the-just-released 0.4.1, please reopen if it does not work for you.
Comment 2 Venky 2012-07-29 19:12:10 UTC
just tried it on 0.4.1 and my contact groups are still collapsed. ( i did try to expand them and restart ktp)
Comment 3 Michael 2012-08-14 19:21:05 UTC
I have this problem, too. I'm using Fedora KDE 17, ktp .4.1 and KDE 4.8.5. This is the weirdest thing. All of my groups are just fine and they always stay open except for one which always likes to close itself.
Comment 4 Michael 2012-08-14 19:32:59 UTC
Actually, the group doesn't need ktp to be restarted or me to log out and back in to collapse. Sometimes, it just collapses on it's own. In fact, it collapsed again while typing my last message.
Comment 5 Martin Klapetek 2012-08-14 20:18:40 UTC
Ok, that is really weird. I just checked the code and the one and only place we actually collapse the group, is when you click it. Not anywhere else.

What might have happened is that the all the contacts in that group went offline and then online, which caused the group to disappear and reappear and once it reappeared, it stayed collapsed. Is that possible?

Anyway, will look into that some more.
Comment 6 Michael 2012-08-14 20:28:40 UTC
Yes, that's very possible. It's never happened while I'm looking at it because it doesn't collapse on it's own very often, but there's only 3 people in that group, as opposed to my other groups with many people.
Comment 7 Martin Klapetek 2012-08-15 09:28:28 UTC
Git commit acdf50f47ba3f9afdcf18fdf64e834d80f94ec93 by Martin Klapetek.
Committed on 15/08/2012 at 11:24.
Pushed by mklapetek into branch 'master'.

Groups expanding/collapsing improvements

Reviewed-by: David Edmundson
REVIEW: 106025

M  +32   -5    contact-list-widget.cpp
M  +2    -0    contact-list-widget.h
M  +1    -0    contact-list-widget_p.h

http://commits.kde.org/telepathy-contact-list/acdf50f47ba3f9afdcf18fdf64e834d80f94ec93
Comment 8 Martin Klapetek 2012-08-15 09:29:52 UTC
If it's possible for you to test with latest git, please do so. I was testing it for good 10mins yesterday with all (im)possible combinations, works for me now.

Please test and post back, thanks.
Comment 9 Venky 2012-08-26 16:48:53 UTC
This is still an issue in 0.5 , I have groups which open collapsed even after I expand them and exit
Comment 10 Martin Klapetek 2012-08-27 08:18:41 UTC
Ok, is this happening with accounts list or groups list? Is it all groups, some (more than 1), or just the one that is called "Ungrouped"? 

Can you also look at ~/.kde/share/config/ktelepathyrc and see the section GroupsState. Open the contact list and see if the groups actually match the config file, where true means "expand", false means "collapse".
Comment 11 Venky 2012-08-28 00:22:26 UTC
I do not understand account list vs group list. I have a group in my contact list where users are from multiple protocol . I checked the ktelepathyrc all of the groupnames have true in them but some of them open collapsed.
I do not know if it matters but in the collapsed groups the users are logged in as mobile users and in one group the online users are google + users with cryptic ids like 2gb9m6eoxdfghtep1ogilghvjtp1h@public.talk.google.com
Comment 12 Orion 2012-09-07 09:13:56 UTC
I see this on v0.5 on Kubuntu 12.04 w KDE 4.9 as well. I use "groups" order, not account order
Comment 13 Martin Klapetek 2012-09-11 17:13:51 UTC
*** Bug 301719 has been marked as a duplicate of this bug. ***
Comment 14 Dennis Schridde 2013-01-04 19:33:11 UTC
I also see some groups collapsed, when I restart KDE. This is especially one group, where usually only one person is online at a time. (I hide offline contacts.)

Re: comment #10: .kde4/share/config/ktelepathyrc does certainly not match my groups. It lists some groups which do not exist currently (after showing offline contacts), many groups which are currently in my lists are not in the file, and even those which are in the file and do exist, have the wrong true/false state. This is using Telepathy/KDE 0.5.1.
Comment 15 Martin Klapetek 2013-01-04 19:58:16 UTC
Arghh I hate this bug. I did some investigation today and I have an idea what's wrong with it, but I have no idea yet where does the problem come from.

Confirming this issue.
Comment 16 Daniele E. Domenichelli 2013-03-27 09:53:13 UTC
Is this bug still valid? Version Fixed in reports "0.4.1"
Comment 17 Dennis Schridde 2013-03-27 11:32:58 UTC
It seems to work in 0.6.0_beta1
Comment 18 Orion 2013-03-27 14:28:35 UTC
Using Kubuntu 12.10 with daily builds PPA (0.6 beta + git) this behaviour can no longer be seen
Comment 19 David Edmundson 2013-03-27 14:29:33 UTC
Thanks guys.