Bug 304057 - Show mobile icon in text-ui as well
Summary: Show mobile icon in text-ui as well
Status: RESOLVED FIXED
Alias: None
Product: telepathy
Classification: Unclassified
Component: text-ui (show other bugs)
Version: 0.5.0
Platform: unspecified Linux
: NOR task
Target Milestone: Future
Assignee: Telepathy Bugs
URL:
Keywords:
: 319009 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-25 17:02 UTC by Martin Klapetek
Modified: 2014-04-14 13:05 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Klapetek 2012-07-25 17:02:50 UTC
The text-ui should display the mobile icon somewhere as well
Comment 1 David Edmundson 2012-07-26 12:24:29 UTC
Where?
Comment 2 Martin Klapetek 2012-07-26 12:30:16 UTC
That's why we need mobile presence icons and use only one icon instead (like GMail's web chat does).
Comment 3 Dennis Schridde 2013-04-06 10:17:05 UTC
I would also like to see this. I think Empathy does it with a phone icon after the peer's name in the tab title.
Comment 4 Martin Klapetek 2013-04-28 09:12:53 UTC
*** Bug 319009 has been marked as a duplicate of this bug. ***
Comment 5 Leon Handreke 2014-04-14 13:05:22 UTC
Git commit f42b8c58734a0c527bf8e3f0821aea85fc0de96a by Leon Handreke.
Committed on 13/04/2014 at 22:08.
Pushed by leonh into branch 'master'.

Overlay presence icon with phone as tab icon if user is on mobile

REVIEW: 117554
Reviewed-By: David Edmundson <david@davidedmundson.co.uk>

M  +14   -0    lib/channel-contact-model.cpp
M  +2    -0    lib/channel-contact-model.h
M  +25   -8    lib/chat-widget.cpp
M  +2    -0    lib/chat-widget.h

http://commits.kde.org/telepathy-text-ui/f42b8c58734a0c527bf8e3f0821aea85fc0de96a