Bug 303974 - hardly readable text in search bar due to poor color contrast
Summary: hardly readable text in search bar due to poor color contrast
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: part (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL: https://cloud.grossard.fr/apps/files_...
Keywords:
Depends on: 216599
Blocks: extramile
  Show dependency treegraph
 
Reported: 2012-07-23 18:42 UTC by Ludovic Grossard
Modified: 2012-09-25 22:30 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.2
grossard: Usability+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ludovic Grossard 2012-07-23 18:42:20 UTC
In the search bar of Kile, the text "Reached bottom, continued from top" is pink with a grey background, and is very difficult to read (see the screenshot). It is probably a color scheme problem. Indeed, with the oxygen color theme, the color for "Active Text" is pink (#FF80E0). "Window Text" would be more appropriate here.
It is probably a kate issue since the string is in katepart4.po

Reproducible: Always
Comment 1 Michel Ludwig 2012-07-24 08:38:18 UTC
Yes, that' right. Fowarding to KatePart.
Comment 2 Christoph Feck 2012-07-24 15:46:45 UTC
See also bug 216599.
Comment 3 Aurelien Gateau 2012-08-31 14:10:07 UTC
Git commit 0ec5ed1f6f9b782ca9fe3fbdafc7dc9177c0759e by Aurélien Gâteau.
Committed on 31/08/2012 at 16:07.
Pushed by gateau into branch 'KDE/4.9'.

Improve contrast of Oxygen colors

It mainly improves readability of ActiveText over Window background
Related: bug 216599
CCMAIL: nuno@oxygen-icons.org
FIXED-IN: 4.9.2

M  +7    -7    kcontrol/colors/schemes/Oxygen.colors

http://commits.kde.org/kde-workspace/0ec5ed1f6f9b782ca9fe3fbdafc7dc9177c0759e
Comment 4 Christoph Feck 2012-09-25 22:30:00 UTC
Git commit 772c9efa4606c815bea5059168234167ab9a2044 by Christoph Feck.
Committed on 26/09/2012 at 00:26.
Pushed by cfeck into branch 'KDE/4.9'.

Keep color changes in sync with kde-workspace
Related: bug 216599

M  +7    -7    kdeui/colors/kcolorscheme.cpp

http://commits.kde.org/kdelibs/772c9efa4606c815bea5059168234167ab9a2044