Bug 303911 - Add a context action to open an URL in the current tab
Summary: Add a context action to open an URL in the current tab
Status: RESOLVED FIXED
Alias: None
Product: rekonq
Classification: Unclassified
Component: general (show other bugs)
Version: latest git snapshot
Platform: unspecified All
: NOR wishlist (vote)
Target Milestone: 2.0
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-22 07:20 UTC by Adrián Chaves (Gallaecio)
Modified: 2013-03-11 18:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Patch to apply the feature. (2.14 KB, patch)
2012-07-22 07:23 UTC, Adrián Chaves (Gallaecio)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adrián Chaves (Gallaecio) 2012-07-22 07:20:32 UTC
When you right-click a link or a selected (URL) text, you get the options to open it in a new tab or in a new window. I think it would be nice to also be able to open it in the current tab instead.

Reproducible: Always
Comment 1 Adrián Chaves (Gallaecio) 2012-07-22 07:23:33 UTC
Created attachment 72679 [details]
Patch to apply the feature.

Implementation is easy, I wrote the patch while trying to figure out where to start to solve https://bugs.kde.org/show_bug.cgi?id=237095.

NOTE: This does not solve the referenced issue at all, although it is related.
Comment 2 Andrea Diamantini 2012-07-28 09:11:17 UTC
Sorry for missing reply. We'll see if your feature request can match 1.1 features :)
Comment 3 Andrea Diamantini 2012-08-14 15:22:06 UTC
Git commit 495d83777e2eaa7c7d604009cc99a446e2964f90 by Andrea Diamantini.
Committed on 14/08/2012 at 16:59.
Pushed by adjam into branch 'IconLink'.

Guess if url is on target blank and eventually show a describing icon

We show "window-new" or blank target links and "mail-message-new"
on mailto ones. The same as Konqueror does :)

Also, based on the hovering guess, shown different contextual menus
Related: bug 237095

M  +2    -0    src/CMakeLists.txt
M  +135  -12   src/webview.cpp
M  +7    -1    src/webview.h

http://commits.kde.org/rekonq/495d83777e2eaa7c7d604009cc99a446e2964f90
Comment 4 Andrea Diamantini 2012-08-14 15:42:14 UTC
Closed cause of the commit push. Reopening...
Comment 5 Andrea Diamantini 2012-08-14 15:43:40 UTC
*** Bug 237095 has been marked as a duplicate of this bug. ***
Comment 6 Adrián Chaves (Gallaecio) 2013-01-12 10:43:57 UTC
This feature is not available in Rekonq 2.0 (tested from http://www.w3schools.com/tags/tryit.asp?filename=tryhtml_a_target), didn’t the commit fixed it?
Comment 7 Andrea Diamantini 2013-01-13 09:11:09 UTC
1.x and 2.0 diverged at same point. It needs to be "backported".
Comment 8 Andrea Diamantini 2013-03-11 18:02:24 UTC
Git commit c7fa562d5e2bf312700b1f02863535887f80ba48 by Andrea Diamantini.
Committed on 11/03/2013 at 18:59.
Pushed by adjam into branch 'master'.

Guess if url is on target blank and show different contextual actions

I would not re-enable the "describing" icon part because it is NOT
really working here. I'm having troubles when I show the icon and
switch pages.
Hope this is enough
Related: bug 237095

M  +69   -9    src/webtab/webview.cpp
M  +4    -0    src/webtab/webview.h

http://commits.kde.org/rekonq/c7fa562d5e2bf312700b1f02863535887f80ba48