Bug 303630 - kde-workspace fails to compile, see kde-core-devel post in URL
Summary: kde-workspace fails to compile, see kde-core-devel post in URL
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: 4.9.0
Assignee: KWin default assignee
URL: http://www.mail-archive.com/kde-core-...
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-16 20:27 UTC by Timo Gurr
Modified: 2012-07-19 05:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.9.0


Attachments
kde-workspace-Compile-fix.patch (872 bytes, patch)
2012-07-16 20:28 UTC, Timo Gurr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timo Gurr 2012-07-16 20:27:46 UTC
Same failure here for quite a while. Attached is a git format patch incorporating the suggested fix from the kde-core-devel ml in a hopefully correct mannor.

(Sorry if I didn't choose the correct bugzilla product, I couldn't find kde-workspace and since it seems to be related to kwin and Martin answered on the ml I chose kwin.)

Reproducible: Always

Steps to Reproduce:
1. try to compile KDE/4.9 branch.
Comment 1 Timo Gurr 2012-07-16 20:28:26 UTC
Created attachment 72569 [details]
kde-workspace-Compile-fix.patch
Comment 2 Martin Flöser 2012-07-17 04:29:50 UTC
Thanks for the patch, but it's already fixed as of git commit cb90b1e6a1125d41b55a7a608b1d917f84306070
Comment 3 Timo Gurr 2012-07-18 19:59:33 UTC
In which branch has it been fixed? It doesn't seem to be in KDE/4.9, is this on purpose?
Comment 4 Martin Flöser 2012-07-19 05:13:07 UTC
Git commit d929ac6da7adf6eea0452ed28bf55fd8ac16614a by Martin Gräßlin, on behalf of Guy Maurel.
Committed on 12/07/2012 at 19:22.
Pushed by graesslin into branch 'KDE/4.9'.

missing include

Cherry-Picked from cb90b1e6a1125d41b55a7a608b1d917f84306070
FIXED-IN: 4.9.0
REVIEW: 105522

M  +1    -0    kwin/scripting/workspace_wrapper.h

http://commits.kde.org/kde-workspace/d929ac6da7adf6eea0452ed28bf55fd8ac16614a