Bug 303533 - 4.9 RC2 plasma meters are invisible on white background (regression)
Summary: 4.9 RC2 plasma meters are invisible on white background (regression)
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Plasma
Component: visuals (show other bugs)
Version: 4.8.97(RC2)
Platform: Arch Linux Linux
: NOR minor
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-14 23:03 UTC by Nikita Skovoroda
Modified: 2012-07-16 19:55 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.9


Attachments
Volume meter. Background: kate. (5.99 KB, image/png)
2012-07-14 23:03 UTC, Nikita Skovoroda
Details
Wi-Fi meters. Background: kate. (3.30 KB, image/png)
2012-07-14 23:04 UTC, Nikita Skovoroda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikita Skovoroda 2012-07-14 23:03:08 UTC
Plasma meters are almost invisible on white backgrounds.
This is a regression to 4.8 branch, where meters were clearly visible.
This is clearly visible on not-so-good screens (TN displays, notebooks, netbooks).

The new meters do look better, but it's hard to distingush between filled area and not filled area, so it's hard to tell what value the meter is showing.


Reproducible: Always

Steps to Reproduce:
0. Use a netbook or any other device with a TN display. Look from different angles. Try looking a little from top (common case for notebooks).
1. Use default colorscheme and plasma theme in KDE 4.8.97.
2. Open kate full-screen.
3. Change the volume using keyboard shortcuts.
4. Open any other plasmoid tooltip with a meter (like networkmanager).
Actual Results:  
The filled meter area is hardly distinguishable from not filled meter area.
It's not easy to tell what value the meter is showing.
Is it 0%, 50%, 70% or 100%?

Expected Results:  
The filled meter area should be clearly distinguishable from not filled area.
It should be easy to distingush between 0%, 50%, 70%, and 100% even without any additional information (like numbers in the volume bar).

0% vs 100% case is special, don't forget it.

Workaround: use different plasma theme.
Comment 1 Nikita Skovoroda 2012-07-14 23:03:59 UTC
Created attachment 72526 [details]
Volume meter. Background: kate.
Comment 2 Nikita Skovoroda 2012-07-14 23:04:31 UTC
Created attachment 72527 [details]
Wi-Fi meters. Background: kate.
Comment 3 Nikita Skovoroda 2012-07-15 12:53:20 UTC
https://projects.kde.org/projects/kde/kde-runtime/repository/revisions/e5cfd95f018bbe0dfd554c68099e459493245b2c — looks like this commit broke them. Not sure.
Comment 4 Marco Martin 2012-07-16 19:55:45 UTC
Git commit 42f4cc57fde9d1ccc9de42853b11e996df117539 by Marco Martin.
Committed on 16/07/2012 at 21:54.
Pushed by mart into branch 'KDE/4.9'.

more contrast
Related: bug 302717
FIXED-IN:4.9

M  +-    --    desktoptheme/air/widgets/bar_meter_horizontal.svgz
M  +-    --    desktoptheme/air/widgets/bar_meter_vertical.svgz

http://commits.kde.org/kde-runtime/42f4cc57fde9d1ccc9de42853b11e996df117539