Bug 303203 - bad fonts in "globe" view
Summary: bad fonts in "globe" view
Status: RESOLVED DUPLICATE of bug 199259
Alias: None
Product: marble
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-08 18:22 UTC by Vladislav
Modified: 2012-08-13 17:16 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
flat view (562.89 KB, image/png)
2012-07-08 19:04 UTC, Vladislav
Details
globe view (540.38 KB, image/png)
2012-07-08 19:05 UTC, Vladislav
Details
mercator view (831.23 KB, image/png)
2012-07-08 19:05 UTC, Vladislav
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladislav 2012-07-08 18:22:37 UTC
When I use Globe and Flat view modes with OSM, I see very bad fonts. 
In Globe view fonts antialiased badly.
In Flat view they are compressed in the meridian direction. When characters have some slope, it looks very bad.

In mercator view all works fine. And this problem doesn't depend on render type - X11 or software.


Reproducible: Always

Steps to Reproduce:
0. Open eyes
1. Start marble
2. Open OSM
3. View bad fonts
Comment 1 Vladislav 2012-07-08 19:04:49 UTC
Created attachment 72373 [details]
flat view
Comment 2 Vladislav 2012-07-08 19:05:21 UTC
Created attachment 72374 [details]
globe view
Comment 3 Vladislav 2012-07-08 19:05:58 UTC
Created attachment 72375 [details]
mercator view
Comment 4 Dennis Nienhüser 2012-08-13 17:16:16 UTC
It's a known technical limitation, see http://techbase.kde.org/Projects/Marble/FAQ#The_labels_and_features_on_the_OpenStreetMap_map_theme_look_blurry.21_How_can_I_fix_this.3F

In the long run we'll resolve it through vector rendering, see http://blogs.deusto.es/gsoc-deustotech/ for some recent information on that.

*** This bug has been marked as a duplicate of bug 199259 ***