Bug 303100 - amarok always crashes when I close the program
Summary: amarok always crashes when I close the program
Status: RESOLVED DUPLICATE of bug 285951
Alias: None
Product: amarok
Classification: Unclassified
Component: Context View/Lyrics (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-06 10:42 UTC by michele.chini
Modified: 2012-07-09 08:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description michele.chini 2012-07-06 10:42:42 UTC
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f947cfa87c0 (LWP 6287))]

Thread 12 (Thread 0x7f94599db700 (LWP 6290)):
#0  __libc_enable_asynccancel () at ../nptl/sysdeps/unix/sysv/linux/x86_64/cancellation.S:66
#1  0x00007f9479891ae8 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:85
#2  0x00007f9471cee35f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#3  0x00007f9471cdf76c in pa_mainloop_poll () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#4  0x00007f9471cdfdd9 in pa_mainloop_iterate () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#5  0x00007f9471cdfe90 in pa_mainloop_run () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#6  0x00007f9471cee30f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#7  0x00007f946d133d18 in ?? () from /usr/lib/x86_64-linux-gnu/libpulsecommon-1.1.so
#8  0x00007f946b5acb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x00007f9475faee9a in start_thread (arg=0x7f94599db700) at pthread_create.c:308
#10 0x00007f947989d4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7f944c7df700 (LWP 6292)):
#0  0x00007f9475fb0fc0 in __pthread_mutex_lock (mutex=0x7f9444000ac0) at pthread_mutex_lock.c:113
#1  0x00007f94744cc5a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f94744901df in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f9474490f04 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f9474491164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f947a228426 in QEventDispatcherGlib::processEvents (this=0x7f9444000920, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f947a1f7c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f947a1f7ed7 in QEventLoop::exec (this=0x7f944c7decd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f947a0f6fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f947a1d79ff in QInotifyFileSystemWatcherEngine::run (this=0x17a12e0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f947a0f9fcb in QThreadPrivate::start (arg=0x17a12e0) at thread/qthread_unix.cpp:298
#11 0x00007f946b5acb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#12 0x00007f9475faee9a in start_thread (arg=0x7f944c7df700) at pthread_create.c:308
#13 0x00007f947989d4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f944a1d6700 (LWP 6294)):
#0  0x00007f9479891b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9474491036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9474491164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f947a228426 in QEventDispatcherGlib::processEvents (this=0x7f943c0008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f947a1f7c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f947a1f7ed7 in QEventLoop::exec (this=0x7f944a1d5d00, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f947a0f6fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f947a0f9fcb in QThreadPrivate::start (arg=0x1998450) at thread/qthread_unix.cpp:298
#8  0x00007f946b5acb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x00007f9475faee9a in start_thread (arg=0x7f944a1d6700) at pthread_create.c:308
#10 0x00007f947989d4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f9448d36700 (LWP 6295)):
#0  0x00007f9479891b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f9474491036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9474491164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f947a228426 in QEventDispatcherGlib::processEvents (this=0x7f94400008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f947a1f7c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f947a1f7ed7 in QEventLoop::exec (this=0x7f9448d35d00, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f947a0f6fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f947a0f9fcb in QThreadPrivate::start (arg=0x19cfaa0) at thread/qthread_unix.cpp:298
#8  0x00007f946b5acb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x00007f9475faee9a in start_thread (arg=0x7f9448d36700) at pthread_create.c:308
#10 0x00007f947989d4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f943b7fe700 (LWP 6297)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f947a0fa4db in wait (time=18446744073709551615, this=0x1a215e0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1a21760, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f94775430eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1a21490, th=0x1a22530) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f94775459db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1a21830, th=0x1a22530) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f947754484f in ThreadWeaver::ThreadRunHelper::run (this=0x7f943b7fdd20, parent=0x1a21490, th=0x1a22530) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f94775448db in ThreadWeaver::Thread::run (this=0x1a22530) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f947a0f9fcb in QThreadPrivate::start (arg=0x1a22530) at thread/qthread_unix.cpp:298
#8  0x00007f946b5acb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x00007f9475faee9a in start_thread (arg=0x7f943b7fe700) at pthread_create.c:308
#10 0x00007f947989d4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f943a0a3700 (LWP 6298)):
#0  0x00007f9479891b12 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:89
#1  0x00007f9474491036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f9474491164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f947a228426 in QEventDispatcherGlib::processEvents (this=0x7f94300008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f947a1f7c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f947a1f7ed7 in QEventLoop::exec (this=0x7f943a0a2cd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f947a0f6fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f947a1d79ff in QInotifyFileSystemWatcherEngine::run (this=0x1bd3a20) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f947a0f9fcb in QThreadPrivate::start (arg=0x1bd3a20) at thread/qthread_unix.cpp:298
#9  0x00007f946b5acb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007f9475faee9a in start_thread (arg=0x7f943a0a3700) at pthread_create.c:308
#11 0x00007f947989d4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f943947a700 (LWP 6299)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f947a0fa4db in wait (time=18446744073709551615, this=0x1a215e0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1a21760, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f94775430eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1a21490, th=0x1c833c0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f94775459db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1a21830, th=0x1c833c0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f94775459f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1a21830, th=0x1c833c0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f947754484f in ThreadWeaver::ThreadRunHelper::run (this=0x7f9439479d20, parent=0x1a21490, th=0x1c833c0) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f94775448db in ThreadWeaver::Thread::run (this=0x1c833c0) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f947a0f9fcb in QThreadPrivate::start (arg=0x1c833c0) at thread/qthread_unix.cpp:298
#9  0x00007f946b5acb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007f9475faee9a in start_thread (arg=0x7f943947a700) at pthread_create.c:308
#11 0x00007f947989d4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f942bfff700 (LWP 6300)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f947a0fa4db in wait (time=18446744073709551615, this=0x1a215e0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1a21760, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f94775430eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1a21490, th=0x1c811f0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f94775459db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1a21830, th=0x1c811f0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f94775459f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x1a21830, th=0x1c811f0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f947754484f in ThreadWeaver::ThreadRunHelper::run (this=0x7f942bffed20, parent=0x1a21490, th=0x1c811f0) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f94775448db in ThreadWeaver::Thread::run (this=0x1c811f0) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f947a0f9fcb in QThreadPrivate::start (arg=0x1c811f0) at thread/qthread_unix.cpp:298
#9  0x00007f946b5acb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#10 0x00007f9475faee9a in start_thread (arg=0x7f942bfff700) at pthread_create.c:308
#11 0x00007f947989d4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f9438c79700 (LWP 6301)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f947a0fa4db in wait (time=18446744073709551615, this=0x1a215e0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1a21760, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f94775430eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1a21490, th=0x1c81ec0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f94775459db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1a21830, th=0x1c81ec0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f947754484f in ThreadWeaver::ThreadRunHelper::run (this=0x7f9438c78d20, parent=0x1a21490, th=0x1c81ec0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f94775448db in ThreadWeaver::Thread::run (this=0x1c81ec0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f947a0f9fcb in QThreadPrivate::start (arg=0x1c81ec0) at thread/qthread_unix.cpp:298
#8  0x00007f946b5acb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#9  0x00007f9475faee9a in start_thread (arg=0x7f9438c79700) at pthread_create.c:308
#10 0x00007f947989d4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f942b5e1700 (LWP 6302)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f94710ccdec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f94710ccf19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f946b5acb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#4  0x00007f9475faee9a in start_thread (arg=0x7f942b5e1700) at pthread_create.c:308
#5  0x00007f947989d4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f942a2ca700 (LWP 6306)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9476588222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f9476588259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f946b5acb74 in ?? () from /usr/lib/nvidia-current/libGL.so.1
#4  0x00007f9475faee9a in start_thread (arg=0x7f942a2ca700) at pthread_create.c:308
#5  0x00007f947989d4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f947cfa87c0 (LWP 6287)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f947be4602e in qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=..., begin=...) at /usr/include/qt4/QtCore/qalgorithms.h:322
#8  qDeleteAll<SmartPointerList<Collections::Collection> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#9  CollectionManager::~CollectionManager (this=0x16cc270, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:137
#10 0x00007f947be46209 in CollectionManager::~CollectionManager (this=0x16cc270, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:145
#11 0x00007f947be444b6 in CollectionManager::destroy () at ../../src/core-impl/collections/support/CollectionManager.cpp:107
#12 0x00007f947bf794cf in App::~App (this=0x7fffe431d5e0, __in_chrg=<optimized out>) at ../../src/App.cpp:248
#13 0x0000000000408e5a in main (argc=1, argv=0x7fffe431fa68) at ../../src/main.cpp:303


Reproducible: Always
Comment 1 Myriam Schweingruber 2012-07-09 08:08:08 UTC

*** This bug has been marked as a duplicate of bug 285951 ***