Bug 302815 - At shutdown, it will not shutdown. This error always occurs.
Summary: At shutdown, it will not shutdown. This error always occurs.
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: plasma4
Classification: Plasma
Component: desktop (show other bugs)
Version: 4.8.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-01 00:07 UTC by marcepzr
Modified: 2013-11-18 13:46 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description marcepzr 2012-07-01 00:07:41 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-26-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
<En detalle, comente que estaba haciendo cuando la aplicación se cerró.>

The crash can be reproduced every time.

-- Backtrace:
Application: Shell de escritorio Plasma (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f53a252d780 (LWP 1748))]

Thread 4 (Thread 0x7f53833f1700 (LWP 1750)):
#0  0x00007f53968bcd84 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007f539bd8b222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f539bd8b259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f53968b8e9a in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#4  0x00007f53a1e064bd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f537b272700 (LWP 1751)):
#0  0x00007f53a1dfab03 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f5395fb4036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5395fb4164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f539efd7426 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007f539efa6c82 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007f539efa6ed7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f539eea5fa7 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f539ef869ff in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007f539eea8fcb in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f53968b8e9a in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#10 0x00007f53a1e064bd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f5373fff700 (LWP 1754)):
#0  0x00007f53968bc05d in pthread_mutex_unlock () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007f5395fef5d1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5395fb3fe9 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5395fb4164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f539efd7426 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007f539efa6c82 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f539efa6ed7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f539eea5fa7 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007f539ef869ff in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f539eea8fcb in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007f53968b8e9a in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#11 0x00007f53a1e064bd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f53a252d780 (LWP 1748)):
[KCrash Handler]
#6  0x00007f539e52a199 in QRasterWindowSurface::~QRasterWindowSurface() () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#7  0x00007f539e52a219 in QRasterWindowSurface::~QRasterWindowSurface() () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#8  0x00007f539e5428de in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#9  0x00007f539e3733d9 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#10 0x00007f539e37352e in QWidgetPrivate::deleteExtra() () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#11 0x00007f539e37375c in QWidgetPrivate::~QWidgetPrivate() () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#12 0x00007f539e373a69 in QWidgetPrivate::~QWidgetPrivate() () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#13 0x00007f539efc0bd0 in QObject::~QObject() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#14 0x00007f539e3757dd in QWidget::~QWidget() () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#15 0x00007f539e375a19 in QWidget::~QWidget() () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#16 0x00007f539e8ff905 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#17 0x00007f53a1d4f921 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
#18 0x00007f53a1d4f9a5 in exit () from /lib/x86_64-linux-gnu/libc.so.6
#19 0x00007f53a1d35774 in __libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6
#20 0x0000000000400671 in _start ()

Informar a https://bugs.kde.org
Comment 1 Myriam Schweingruber 2012-08-06 02:00:01 UTC
This looks more like a Qt issue. Could you please install the libqt4-dbg package and provide a better backtrace? Please make sure you also update to the KDE 4.8.4 release, available in the Kubuntu backports PPA
Comment 2 Christoph Feck 2013-11-18 13:46:10 UTC

*** This bug has been marked as a duplicate of bug 261539 ***