Bug 302753 - Artist wanted: Amarok icon for audio bitrate missing
Summary: Artist wanted: Amarok icon for audio bitrate missing
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.5.90 (2.6 beta)
Platform: Ubuntu Linux
: NOR wishlist (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-29 15:45 UTC by Mark Fraser
Modified: 2012-07-11 12:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 2.6


Attachments
Play list pop up (83.59 KB, image/png)
2012-06-29 15:47 UTC, Mark Fraser
Details
Edit Filter window (45.59 KB, image/png)
2012-06-29 15:48 UTC, Mark Fraser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Fraser 2012-06-29 15:45:11 UTC
If you hover over a track in the play list a pop up appears showing various information for that track. The icon that is shown next to bit rate is the "default" icon. Same icon is shown in the "Edit Filter" window.

Reproducible: Always

Steps to Reproduce:
1.Hover over a track in the playlist
2.Watch the pop up appear
3.See that the icon next to bit rate is missing
Comment 1 Mark Fraser 2012-06-29 15:47:58 UTC
Created attachment 72218 [details]
Play list pop up
Comment 2 Mark Fraser 2012-06-29 15:48:45 UTC
Created attachment 72219 [details]
Edit Filter window
Comment 3 Myriam Schweingruber 2012-06-30 07:47:09 UTC
Do you have all oxygen packages installed? This is probably in the package oxygen-icon-theme-complete. Of course this assumes you are indeed using the Oxygen theme.
Comment 4 Mark Fraser 2012-06-30 10:56:48 UTC
dpkg -l oxygen* gives:

ii  oxygen-cursor-theme      0.0.2010-05-10-kde4.4.3- Oxygen Mouse Cursor Theme
ii  oxygen-icon-theme        4:4.8.90-0ubuntu1~precis Oxygen icon theme
ii  oxygen-icon-theme-comple 4:4.8.90-0ubuntu1~precis Oxygen icon theme - transitional package

Where should the icon be located so I can see if it is there?
Comment 5 Mark Fraser 2012-06-30 12:32:32 UTC
I've now downloaded the source and from the file MetaConstants.cpp it looks like it is showing the correct icon:
case Meta::valBitrate: return "application-octet-stream";

Doesn't look right though.
Comment 6 Myriam Schweingruber 2012-07-02 09:46:43 UTC
Yes, this is indeed wrong, it should show a metronome
Comment 7 Mark Fraser 2012-07-02 11:11:29 UTC
Thought the metronome was to show BPM.
Comment 8 Matěj Laitl 2012-07-03 20:12:45 UTC
Mark,
we simply don't have an icon for bitrate, so we've abused the application-octet-stream because it looks kinda similar to something we would imagine as bitrate. Feel free to provide an icon for it (in the same style as other icons) and we'll happily use it.

Myriam,
this is certainly not a regression, this icon was present at least by Ralf's commit form november 2010 and I have found no icon for bitrate in oxygen or in Amarok sources. Once found not a regression, I think this is not a release blocker, too.
Comment 9 Myriam Schweingruber 2012-07-08 00:05:25 UTC
hm, how about the icon audio-x-wav.png or the irc-voice.png? It's better than nothing and both suggest an output. Or maybe just office-chart-bar.png?
Comment 10 Matěj Laitl 2012-07-11 12:04:12 UTC
Git commit c06d689ea9b2aa50a400e676c7c178ecec923b86 by Matěj Laitl.
Committed on 11/07/2012 at 13:47.
Pushed by laitl into branch 'master'.

Change bitrate icon from application-octet-stream to audio-x-generic

This one is supposedly more descriptive. Partick, does this affect
Windows packaging somehow? Rather CCing you.

CCMAIL: Patrick von Reth <vonreth@kde.org>
FIXED-IN: 2.6

M  +1    -0    ChangeLog
M  +1    -1    src/core/meta/support/MetaConstants.cpp
M  +1    -1    src/playlist/PlaylistDefines.h

http://commits.kde.org/amarok/c06d689ea9b2aa50a400e676c7c178ecec923b86