Bug 302722 - Keditbookmarks crash when moving bookmarks to another folder
Summary: Keditbookmarks crash when moving bookmarks to another folder
Status: RESOLVED DUPLICATE of bug 256408
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-29 04:24 UTC by Hector Wilvert Ivan Valdez Reza
Modified: 2012-06-29 07:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hector Wilvert Ivan Valdez Reza 2012-06-29 04:24:01 UTC
Application: keditbookmarks (4.8.3 (4.8.3))
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-25-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:
Moving bookmarks (tried with 10 or more bookmarks) to another folder, from the right panel to one folder of the left panel.

The crash can be reproduced every time.

-- Backtrace:
Application: Editor de marcadores (keditbookmarks), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  ref (this=0x610074) at ../../include/QtCore/../../src/corelib/arch/qatomic_x86_64.h:121
#7  QString (other=..., this=0x7fffbbaf99b0) at ../../include/QtCore/../../src/corelib/tools/qstring.h:726
#8  nodeName (this=0x29563f0) at dom/qdom.cpp:142
#9  QDomElement::tagName (this=0x7fffbbaf9a60) at dom/qdom.cpp:4789
#10 0x00007febe0193ef8 in KBookmark::address (this=0x7fffbbaf9a60) at ../../kio/bookmarks/kbookmark.cc:482
#11 0x00007febe06f3df2 in KBookmarkModel::parent(QModelIndex const&) const () from /usr/lib/libkbookmarkmodel_private.so.4
#12 0x00007febdeefb5d3 in parent (this=0x7fffbbaf9af0) at kernel/qabstractitemmodel.h:393
#13 QAbstractItemModelPrivate::rowsAboutToBeRemoved (this=0x23aa820, parent=..., first=3, last=3) at kernel/qabstractitemmodel.cpp:726
#14 0x00007febdeefed48 in QAbstractItemModel::beginRemoveRows (this=<optimized out>, parent=..., first=3, last=<optimized out>) at kernel/qabstractitemmodel.cpp:2471
#15 0x00007febe06f4ac2 in KBookmarkModel::removeBookmark(KBookmark) () from /usr/lib/libkbookmarkmodel_private.so.4
#16 0x00007febe06ef79b in CreateCommand::undo() () from /usr/lib/libkbookmarkmodel_private.so.4
#17 0x00007febe06f26ca in DeleteCommand::redo() () from /usr/lib/libkbookmarkmodel_private.so.4
#18 0x00007febde67f533 in QUndoCommand::redo (this=0x30bfa00) at util/qundostack.cpp:208
#19 0x00007febe06f29d6 in DeleteCommand::redo() () from /usr/lib/libkbookmarkmodel_private.so.4
#20 0x00007febde67f533 in QUndoCommand::redo (this=0x299eb40) at util/qundostack.cpp:208
#21 0x00007febe06f29d6 in DeleteCommand::redo() () from /usr/lib/libkbookmarkmodel_private.so.4
#22 0x00007febe06f10e9 in ?? () from /usr/lib/libkbookmarkmodel_private.so.4
#23 0x00007febde67f533 in QUndoCommand::redo (this=0x305aa00) at util/qundostack.cpp:208
#24 0x00007febde680de3 in QUndoStack::push (this=<optimized out>, cmd=0x305aa00) at util/qundostack.cpp:583
#25 0x00007febe06ef4f6 in CommandHistory::addCommand(QUndoCommand*) () from /usr/lib/libkbookmarkmodel_private.so.4
#26 0x00007febe06f5277 in KBookmarkModel::dropMimeData(QMimeData const*, Qt::DropAction, int, int, QModelIndex const&) () from /usr/lib/libkbookmarkmodel_private.so.4
#27 0x00007febe0cebb71 in ?? () from /usr/lib/kde4/libkdeinit/libkdeinit4_keditbookmarks.so
#28 0x00007febde52e7b2 in QAbstractItemView::dropEvent (this=0x295f790, event=0x7fffbbafb040) at itemviews/qabstractitemview.cpp:2006
#29 0x00007febde05b491 in QWidget::event (this=0x295f790, event=0x7fffbbafb040) at kernel/qwidget.cpp:8552
#30 0x00007febde41b3b6 in QFrame::event (this=0x295f790, e=0x7fffbbafb040) at widgets/qframe.cpp:557
#31 0x00007febde52f89b in QAbstractItemView::viewportEvent (this=0x295f790, event=0x7fffbbafb040) at itemviews/qabstractitemview.cpp:1644
#32 0x00007febde5774b5 in QTreeView::viewportEvent (this=0x295f790, event=0x7fffbbafb040) at itemviews/qtreeview.cpp:1257
#33 0x00007febdef05028 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x2962b90, event=0x7fffbbafb040) at kernel/qcoreapplication.cpp:986
#34 0x00007febde00a85f in notify_helper (e=0x7fffbbafb040, receiver=0x2962b90, this=0x21782b0) at kernel/qapplication.cpp:4555
#35 QApplicationPrivate::notify_helper (this=0x21782b0, receiver=0x2962b90, e=0x7fffbbafb040) at kernel/qapplication.cpp:4531
#36 0x00007febde00fc5f in QApplication::notify (this=<optimized out>, receiver=<optimized out>, e=0x7fffbbafb040) at kernel/qapplication.cpp:4345
#37 0x00007febdf965bb6 in KApplication::notify (this=0x7fffbbafe1c0, receiver=0x2962b90, event=0x7fffbbafb040) at ../../kdeui/kernel/kapplication.cpp:311
#38 0x00007febdef04e9c in QCoreApplication::notifyInternal (this=0x7fffbbafe1c0, receiver=0x2962b90, event=0x7fffbbafb040) at kernel/qcoreapplication.cpp:876
#39 0x00007febde095163 in sendEvent (event=0x7fffbbafb040, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#40 QX11Data::xdndHandleDrop (this=<optimized out>, xe=<optimized out>, passive=<optimized out>) at kernel/qdnd_x11.cpp:1185
#41 0x00007febde0966f3 in QDragManager::drop (this=0x3081610) at kernel/qdnd_x11.cpp:1750
#42 0x00007febde099488 in QDragManager::eventFilter (this=0x3081610, o=<optimized out>, e=<optimized out>) at kernel/qdnd_x11.cpp:1314
#43 0x00007febdef04f6c in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x21782b0, receiver=0x3059600, event=0x7fffbbafb860) at kernel/qcoreapplication.cpp:967
#44 0x00007febde00a806 in QApplicationPrivate::notify_helper (this=0x21782b0, receiver=0x3059600, e=0x7fffbbafb860) at kernel/qapplication.cpp:4534
#45 0x00007febde0100bf in QApplication::notify (this=<optimized out>, receiver=0x3059600, e=0x7fffbbafb860) at kernel/qapplication.cpp:4102
#46 0x00007febdf965bb6 in KApplication::notify (this=0x7fffbbafe1c0, receiver=0x3059600, event=0x7fffbbafb860) at ../../kdeui/kernel/kapplication.cpp:311
#47 0x00007febdef04e9c in QCoreApplication::notifyInternal (this=0x7fffbbafe1c0, receiver=0x3059600, event=0x7fffbbafb860) at kernel/qcoreapplication.cpp:876
#48 0x00007febde00b862 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#49 QApplicationPrivate::sendMouseEvent (receiver=0x3059600, event=0x7fffbbafb860, alienWidget=0x0, nativeWidget=0x3059600, buttonDown=0x23ba4e0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3170
#50 0x00007febde08abf5 in QETWidget::translateMouseEvent (this=0x3059600, event=<optimized out>) at kernel/qapplication_x11.cpp:4617
#51 0x00007febde089bae in QApplication::x11ProcessEvent (this=0x7fffbbafe1c0, event=0x7fffbbafc130) at kernel/qapplication_x11.cpp:3732
#52 0x00007febde0b30d2 in x11EventSourceDispatch (s=0x2185b70, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#53 0x00007febda24ed53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#54 0x00007febda24f0a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#55 0x00007febda24f164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#56 0x00007febdef343bf in QEventDispatcherGlib::processEvents (this=0x214eb30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#57 0x00007febde0b2d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#58 0x00007febdef03c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#59 0x00007febdef03ed7 in QEventLoop::exec (this=0x297f5d0, flags=...) at kernel/qeventloop.cpp:204
#60 0x00007febde099183 in QDragManager::drag (this=0x3081610, o=<optimized out>) at kernel/qdnd_x11.cpp:2017
#61 0x00007febde01c4f8 in QDrag::exec (this=0x30563d0, supportedActions=..., defaultDropAction=Qt::MoveAction) at kernel/qdrag.cpp:284
#62 0x00007febde53b5a3 in QAbstractItemView::startDrag (this=0x29484e0, supportedActions=...) at itemviews/qabstractitemview.cpp:3540
#63 0x00007febde538f6e in QAbstractItemView::mouseMoveEvent (this=0x29484e0, event=<optimized out>) at itemviews/qabstractitemview.cpp:1725
#64 0x00007febde05b178 in QWidget::event (this=0x29484e0, event=0x7fffbbafd4c0) at kernel/qwidget.cpp:8347
#65 0x00007febde41b3b6 in QFrame::event (this=0x29484e0, e=0x7fffbbafd4c0) at widgets/qframe.cpp:557
#66 0x00007febde52f89b in QAbstractItemView::viewportEvent (this=0x29484e0, event=0x7fffbbafd4c0) at itemviews/qabstractitemview.cpp:1644
#67 0x00007febde5774b5 in QTreeView::viewportEvent (this=0x29484e0, event=0x7fffbbafd4c0) at itemviews/qtreeview.cpp:1257
#68 0x00007febdef05028 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x23ba4e0, event=0x7fffbbafd4c0) at kernel/qcoreapplication.cpp:986
#69 0x00007febde00a85f in notify_helper (e=0x7fffbbafd4c0, receiver=0x23ba4e0, this=0x21782b0) at kernel/qapplication.cpp:4555
#70 QApplicationPrivate::notify_helper (this=0x21782b0, receiver=0x23ba4e0, e=0x7fffbbafd4c0) at kernel/qapplication.cpp:4531
#71 0x00007febde0100bf in QApplication::notify (this=<optimized out>, receiver=0x23ba4e0, e=0x7fffbbafd4c0) at kernel/qapplication.cpp:4102
#72 0x00007febdf965bb6 in KApplication::notify (this=0x7fffbbafe1c0, receiver=0x23ba4e0, event=0x7fffbbafd4c0) at ../../kdeui/kernel/kapplication.cpp:311
#73 0x00007febdef04e9c in QCoreApplication::notifyInternal (this=0x7fffbbafe1c0, receiver=0x23ba4e0, event=0x7fffbbafd4c0) at kernel/qcoreapplication.cpp:876
#74 0x00007febde00b862 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#75 QApplicationPrivate::sendMouseEvent (receiver=0x23ba4e0, event=0x7fffbbafd4c0, alienWidget=0x23ba4e0, nativeWidget=0x24102d0, buttonDown=0x23ba4e0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3170
#76 0x00007febde08abf5 in QETWidget::translateMouseEvent (this=0x24102d0, event=<optimized out>) at kernel/qapplication_x11.cpp:4617
#77 0x00007febde089bae in QApplication::x11ProcessEvent (this=0x7fffbbafe1c0, event=0x7fffbbafdd90) at kernel/qapplication_x11.cpp:3732
#78 0x00007febde0b30d2 in x11EventSourceDispatch (s=0x2185b70, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#79 0x00007febda24ed53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#80 0x00007febda24f0a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#81 0x00007febda24f164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#82 0x00007febdef343bf in QEventDispatcherGlib::processEvents (this=0x214eb30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#83 0x00007febde0b2d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#84 0x00007febdef03c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#85 0x00007febdef03ed7 in QEventLoop::exec (this=0x7fffbbafe130, flags=...) at kernel/qeventloop.cpp:204
#86 0x00007febdef08f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#87 0x00007febe0cd4e4e in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_keditbookmarks.so
#88 0x00007febe091d76d in __libc_start_main (main=0x400640, argc=6, ubp_av=0x7fffbbafea68, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffbbafea58) at libc-start.c:226
#89 0x0000000000400671 in _start ()

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-06-29 07:06:03 UTC

*** This bug has been marked as a duplicate of bug 256408 ***