Bug 302597 - please add support for LibLastFm 1.0+
Summary: please add support for LibLastFm 1.0+
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Services/Last.fm (show other bugs)
Version: 2.5.90 (2.6 beta)
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: 2.7
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-26 20:28 UTC by Andrei Mihaila
Modified: 2012-08-14 16:01 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.7


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Mihaila 2012-06-26 20:28:13 UTC
Amarok doesn't detect LibLastFm 1.0+ (works fine with 0.3.3 for example). When I compiled it while having LibLastFm 1.0.1 installed the support for LastFm was disabled because the library was not found. Tried to hack the code that detects it (changed a line in the cmake/modules/FindLibLastFm.cmake) and the detection worked. I had a bit of hope ... but then the compilation failed on one of the files related to the support for LibLastFm.

Downgraded to LibLastFm 0.3.3 and it works as expected.

Anyway, good job on the rest of the features ... and when you can spare some time please add support for LibLastFm 1.0+.

Thank you!

Reproducible: Always

Steps to Reproduce:
1. install LibLastFm 1.0+
2. compile amarok 2.5.90
3.
Actual Results:  
the LastFm support is disabled

Expected Results:  
the LastFm support should be enabled and working
Comment 1 Sam Lade 2012-06-26 20:32:14 UTC
Unfortunately, liblastfm1 is API incompatible with the previous version. A port to liblastfm1 is available on our reviewboard here: https://git.reviewboard.kde.org/r/105276/ However, this has not yet been pushed to master for dependency reasons. You can apply the patch manually or just use the older liblastfm1. We'll increase the dependency once distros have had a chance to ship the new one.
Comment 2 Andrei Mihaila 2012-06-27 19:35:52 UTC
Thank you for the very quick answer!

Modified the Gentoo package (applied the patch, works nicely) and noticed the maintainers (https://bugs.gentoo.org/show_bug.cgi?id=419509).
Comment 3 Matěj Laitl 2012-07-03 13:14:30 UTC
(In reply to comment #2)
> Thank you for the very quick answer!
> 
> Modified the Gentoo package (applied the patch, works nicely) and noticed
> the maintainers (https://bugs.gentoo.org/show_bug.cgi?id=419509).

No, please don't do that. Amarok 2.5 and 2.6 wil require liblastfm 0.3* and Amarok 2.7 will be ported to liblastfm 1.0.
Comment 4 Sam Lade 2012-08-14 13:01:28 UTC
Reopened since 2.6 has been released. Liblastfm1 support will be merged shortly.
Comment 5 Matěj Laitl 2012-08-14 14:43:33 UTC
Git commit 24b3feaf279199100f1a0a41e40e22a5408d7411 by Matěj Laitl.
Committed on 14/08/2012 at 16:22.
Pushed by laitl into branch 'master'.

Merge branch 'liblastfm1'

Amarok developers, users building git: you'll need to upgrade your
liblastfm to >= 1.0.0 for Last.fm support to be included.

* liblastfm1:
  Update Last.fm info in CMakeLists, README, check its version in CMake
  fix port consistency as requested
  lastfm include cleanup
  port to liblastfm1 api

REVIEW: 105276
CCMAIL: amarok-devel@kde.org
CCMAIL: amarok@kde.org


http://commits.kde.org/amarok/24b3feaf279199100f1a0a41e40e22a5408d7411