Bug 302555 - Akonadi Google Calendar Resource crashes
Summary: Akonadi Google Calendar Resource crashes
Status: RESOLVED DUPLICATE of bug 298887
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Google Resource (show other bugs)
Version: 4.8
Platform: Compiled Sources Linux
: NOR crash
Target Milestone: ---
Assignee: Daniel Vrátil
Depends on:
Reported: 2012-06-26 12:18 UTC by Eggert Ehmke
Modified: 2012-06-26 13:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Eggert Ehmke 2012-06-26 12:18:18 UTC
Application: akonadi_googlecalendar_resource (4.8)
KDE Platform Version: 4.8.4 (4.8.4) (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.3.8-gentoo x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:
I just had activated the Google Calendar resource. Moments later, it crashed.

The crash can be reproduced every time.

-- Backtrace:
Application: Google Calendars and Tasks (akonadi_googlecalendar_resource), signal: Aborted
[KCrash Handler]
#6  0x000000309b035655 in *__GI_raise (sig=<optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x000000309b0368fa in *__GI_abort () at abort.c:93
#8  0x000000309e4bd89d in __gnu_cxx::__verbose_terminate_handler () at /var/tmp/portage/sys-devel/gcc-4.5.3-r2/work/gcc-4.5.3/libstdc++-v3/libsupc++/vterminate.cc:93
#9  0x000000309e4bbb66 in __cxxabiv1::__terminate (handler=<optimized out>) at /var/tmp/portage/sys-devel/gcc-4.5.3-r2/work/gcc-4.5.3/libstdc++-v3/libsupc++/eh_terminate.cc:39
#10 0x000000309e4bbb93 in std::terminate () at /var/tmp/portage/sys-devel/gcc-4.5.3-r2/work/gcc-4.5.3/libstdc++-v3/libsupc++/eh_terminate.cc:49
#11 0x000000309e4bbce5 in __cxxabiv1::__cxa_rethrow () at /var/tmp/portage/sys-devel/gcc-4.5.3-r2/work/gcc-4.5.3/libstdc++-v3/libsupc++/eh_throw.cc:116
#12 0x00000030a597c339 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#13 0x00000030a59807c3 in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#14 0x00007ff62bfa9253 in Akonadi::ResourceBase::init(Akonadi::ResourceBase*) () from /usr/lib64/libakonadi-kde.so.4
#15 0x0000000000414cf8 in init<CalendarResource> (argv=<optimized out>, argc=<optimized out>) at /usr/include/KDE/Akonadi/../../akonadi/resourcebase.h:188
#16 main (argc=<optimized out>, argv=<optimized out>) at /var/tmp/portage/kde-misc/akonadi-google-0.3/work/akonadi-google-0.3/calendar/calendarresource.cpp:594

Possible duplicates by query: bug 298081, bug 296407, bug 293802, bug 291697, bug 289446.

Reported using DrKonqi
Comment 1 Daniel Vrátil 2012-06-26 12:39:29 UTC

*** This bug has been marked as a duplicate of bug 298887 ***
Comment 2 Eggert Ehmke 2012-06-26 13:02:25 UTC
Hello Dan,

298887 has again been reported as duplicate of Bug 297824. This has been 
closed as fixed in April 2012 for KDE version 4.7.4. I am running KDE 4.8.4 
and still experience the bug. Are you sure this bug has been solved at all?


On Tuesday 26 June 2012 12:39:29 you wrote:
> https://bugs.kde.org/show_bug.cgi?id=302555
> Dan Vratil <dan@progdan.cz> changed:
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
> Status|NEW                         |RESOLVED
>          Resolution|---                         |DUPLICATE
> --- Comment #1 from Dan Vratil <dan@progdan.cz> ---
> *** This bug has been marked as a duplicate of bug 298887 ***
Comment 3 Daniel Vrátil 2012-06-26 13:25:43 UTC
> and still experience the bug. Are you sure this bug has been solved at all?
In bug #298887 I mentioned that the issue has been resolved in Akonadi Google 0.3.1 (and bug #297824 is FIXED-IN 0.3.1),  yet you reported this crash against 0.3 again. It's not surprising you keep experiencing the crash if you are still using old version...version of KDE is really not related 

Nothing of this really matters now though, because month or two ago, the project Akonadi Google has been split into two parts: the Akonadi Google Resources nad LibKGoogle
 - The Akonadi resources are now part of kdepim-runtime and will be shipped with KDE 4.9 (but are still available unofficially in a standalone git repository in /scratch/dvratil/akonadi-google-resources). 
 - LibKGoogle is now called LibKGAPI and it's a standalone project on http://projects.kde.org/libkgoogle (the repository is to be renamed yet).

Either notify your distribution maintainers to provide akonadi-google 0.3.1 and wait for KDE 4.9 to come with more bugfixes in the Akonadi Google resources (then you can throw akonadi-google away), or ask them to package LibKGAPI (currently in version 0.4.1) and a snapshot from the git repo mentioned above.