Bug 302439 - "Solve" button text shows garbage in problem solver popup
Summary: "Solve" button text shows garbage in problem solver popup
Status: RESOLVED FIXED
Alias: None
Product: kdevelop
Classification: Unclassified
Component: general (show other bugs)
Version: 4.3.0
Platform: Fedora RPMs Linux
: NOR normal with 20 votes (vote)
Target Milestone: 4.3.0
Assignee: kdevelop-bugs-null
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-24 12:10 UTC by Marcus U
Modified: 2013-01-04 17:37 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of the problem. (19.58 KB, image/png)
2012-06-24 12:11 UTC, Marcus U
Details
Another screenshot of the bug. (15.15 KB, image/png)
2012-06-24 12:12 UTC, Marcus U
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus U 2012-06-24 12:10:10 UTC
The solve button in the problem solver popup (don't know its real name so I'll just refer to it as "the popup") shows some grabled writing, as if the 'Solve' (visible in the button) was being written over with some random symbols (I honestly can't make them out, don't know if it's real writing or not). This didn't always happen, but as of late I have always got the same garbage output, even after updates and system restarts. This happens on both xfce and KDE, and I can't think of one system or KDevelop setting that I might have changed causing this to happen.

I'll upload some screenshots as soon as I figure out how to.

Reproducible: Always

Steps to Reproduce:
1. Run KDevelop
2. Scroll mouse at any problem found in the source code that causes "the popup" to come up (any does it for me, tried on both C and C++ source files).
3. Watch!
Actual Results:  
The text in the 'Solve' button is garbled.

Expected Results:  
Text in the button is clearly visible without any artifacts.
Comment 1 Marcus U 2012-06-24 12:11:37 UTC
Created attachment 72093 [details]
Screenshot of the problem.
Comment 2 Marcus U 2012-06-24 12:12:55 UTC
Created attachment 72094 [details]
Another screenshot of the bug.
Comment 3 Marcus U 2012-07-06 23:55:14 UTC
I've been doing some testing and it turns out that I might have been wrong... I can only reproduce this on xfce (when Qt-applications have GTK look), in both KDE and Openbox where Qt applications have their native look it works fine (at least I haven't caught anything in two weeks). I suspect this probably isn't a KDevelop problem after all...
Comment 4 heyleke+kde 2012-07-07 07:07:33 UTC
(In reply to comment #3)
> I've been doing some testing and it turns out that I might have been
> wrong... I can only reproduce this on xfce (when Qt-applications have GTK
> look), in both KDE and Openbox where Qt applications have their native look
> it works fine (at least I haven't caught anything in two weeks). I suspect
> this probably isn't a KDevelop problem after all...

a workaround this issue is e.g.
kdevelop --style CDE
Comment 5 Ivan Shapovalov 2013-01-04 17:36:03 UTC
Git commit 232ee03017a028f5b349b6529166fa41b4cc567b by Ivan Shapovalov.
Committed on 03/01/2013 at 22:47.
Pushed by shapovalov into branch 'master'.

Fix double-rendering of text in "Solve" button of the problem navigation context.

Fix the text of "Solve: ..." button/menu in the problem navigation
context being rendered two times and overlaid.

Don't know whether not giving the text to style options will have any
nasty side-effects, but well... Problem navigation context is so far the
only user of the rich-text push buttons.

REVIEW: 108144

M  +2    -1    util/richtextpushbutton.cpp

http://commits.kde.org/kdevplatform/232ee03017a028f5b349b6529166fa41b4cc567b