Bug 302391 - Make currently typed text in the URL-Bar recoverable
Summary: Make currently typed text in the URL-Bar recoverable
Status: RESOLVED FIXED
Alias: None
Product: rekonq
Classification: Unclassified
Component: general (show other bugs)
Version: latest git snapshot
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: 0.10
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-23 09:02 UTC by Franz Trischberger
Modified: 2012-12-13 23:33 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Key_Esc sets typed string to the UrlBar. (1.09 KB, application/octet-stream)
2012-06-24 08:06 UTC, Franz Trischberger
Details
Key Up on first and Down on last don't activate a ListItem, but only set _typedString to the UrlBar. (1.85 KB, application/octet-stream)
2012-06-24 09:03 UTC, Franz Trischberger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Franz Trischberger 2012-06-23 09:02:35 UTC
As soon as I navigate with KeyUP/Down when typing, the currently written text is lost. Especially if you type some longer text to get better results from the autocompletion, this is disturbing.
A solution could be to add an extra entry for the current text to the top of the completion list.
Or KeyUP on the first/KeyDown on the last element gives focus back to the URL-Bar and inserts the text typed by the user.

Reproducible: Always
Comment 1 Franz Trischberger 2012-06-23 14:56:13 UTC
Ah, I see - navigating to the Search Line gives me the actually typed text back in the URL-Bar. I don't know if that is so intuitive.
Furthermore pressing "Esc" should not only hide the completion list but set the text the user actually typed. (Don't know if "firefox does it, too" is an argument :D)
Comment 2 Franz Trischberger 2012-06-24 08:06:58 UTC
Created attachment 72088 [details]
Key_Esc sets typed string to the UrlBar.
Comment 3 Franz Trischberger 2012-06-24 09:03:10 UTC
Created attachment 72089 [details]
Key Up on first and Down on last don't activate a ListItem, but only set _typedString to the UrlBar.
Comment 4 Andrea Diamantini 2012-06-24 10:15:21 UTC
Hi Franz, and many thanks for your "assisted" bug reporting. Unfortunately there are a couple of problems with your patches.
The first one (Key_Esc set typed string to the Urlbar) changes rekonq behavior, that has been explicitely requested this way. I think that firefox is a step behind in this case.
Anyway, to fix the bug reported here, I think the second one is enough. Thoughts?
Comment 5 Franz Trischberger 2012-06-24 10:41:42 UTC
(In reply to comment #4)
> Anyway, to fix the bug reported here, I think the second one is enough.
> Thoughts?
Of course it is OK with just the second patch.
Comment 6 Andrea Diamantini 2012-06-25 22:46:09 UTC
Git commit d8e66449a62a2758d07b7b90f40a2470e440a3e8 by Andrea Diamantini.
Committed on 26/06/2012 at 00:44.
Pushed by adjam into branch 'master'.

Ensure users can recover typed text in the urlbar

PS: contains also an easy check improved to avoid duplicating
suggestions creation ;)

Thanks to Franz Fellner for REPORTING and FIXING himself the problem :D
REVIEWED-BY: adjam

M  +28   -20   src/urlbar/completionwidget.cpp

http://commits.kde.org/rekonq/d8e66449a62a2758d07b7b90f40a2470e440a3e8
Comment 7 Jekyll Wu 2012-12-13 23:33:04 UTC
*** Bug 311654 has been marked as a duplicate of this bug. ***