Bug 302298 - Kate crashed during block delete
Summary: Kate crashed during block delete
Status: RESOLVED WORKSFORME
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2012-06-21 13:41 UTC by alex.d.herbert
Modified: 2018-10-27 03:31 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description alex.d.herbert 2012-06-21 13:41:46 UTC
Application: kate (3.4.5)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-40-generic x86_64
Distribution: Ubuntu 10.04.4 LTS

-- Information about the crash:
I was using Kate in two windows. I highlighted a large block of text and pressed delete. The application crashed. 

Prior to this I had been scrolling up through my text file and deleting blocks of text I did not need.


 -- Backtrace:
Application: Kate (kate), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f7a4d1f5760 (LWP 3113))]

Thread 3 (Thread 0x7f7a3ce96700 (LWP 3116)):
#0  0x00007f7a4cb64543 in *__GI___poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f7a49d594a9 in ?? () from /lib/libglib-2.0.so.0
#2  0x00007f7a49d598fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#3  0x00007f7a4ab0b566 in QEventDispatcherGlib::processEvents (this=0x1df9390, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:414
#4  0x00007f7a4aae0992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#5  0x00007f7a4aae0d6c in QEventLoop::exec (this=0x7f7a3ce95db0, flags=) at kernel/qeventloop.cpp:201
#6  0x00007f7a4a9ead59 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:487
#7  0x00007f7a4aac1178 in QInotifyFileSystemWatcherEngine::run (this=0x1ceb560) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f7a4a9ed775 in QThreadPrivate::start (arg=0x1ceb560) at thread/qthread_unix.cpp:248
#9  0x00007f7a4a2149ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#10 0x00007f7a4cb70cdd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f7a34cc2700 (LWP 5227)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f7a40fd22a6 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f7a412b0220) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2304
#2  0x00007f7a40fd22e9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f7a412be2ec) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1438
#3  0x00007f7a4a2149ca in start_thread (arg=<value optimized out>) at pthread_create.c:300
#4  0x00007f7a4cb70cdd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f7a4d1f5760 (LWP 3113)):
[KCrash Handler]
#5  KateLineLayout::viewLineCount (this=0x0) at ../../kate/render/katelinelayout.cpp:173
#6  0x00007f7a41612eda in KateLayoutCache::viewLine (this=0x2a69830, realCursor=...) at ../../kate/render/katelayoutcache.cpp:395
#7  0x00007f7a416134d1 in KateLayoutCache::textLayout (this=0x2a69830, realCursor=...) at ../../kate/render/katelayoutcache.cpp:337
#8  0x00007f7a4167905f in KateViewInternal::updateCursor (this=0x2a46ab0, newCursor=<value optimized out>, force=<value optimized out>, center=<value optimized out>, 
    calledExternally=<value optimized out>) at ../../kate/view/kateviewinternal.cpp:1939
#9  0x00007f7a416791a9 in KateViewInternal::editEnd (this=0x2a46ab0, editTagLineStart=<value optimized out>, editTagLineEnd=<value optimized out>, tagFrom=<value optimized out>)
    at ../../kate/view/kateviewinternal.cpp:3400
#10 0x00007f7a415d1d71 in KateDocument::editEnd (this=0x2ac12d0) at ../../kate/document/katedocument.cpp:981
#11 0x00007f7a4166457a in KateView::removeSelectedText (this=0x3eb2dc0) at ../../kate/view/kateview.cpp:1774
#12 0x00007f7a415d047e in KateDocument::del (this=0x2ac12d0, view=0x3eb2dc0, c=...) at ../../kate/document/katedocument.cpp:2918
#13 0x00007f7a4165f98c in KateView::keyDelete (this=0x3eb2dc0) at ../../kate/view/kateview.cpp:2307
#14 0x00007f7a41664c8d in KateView::qt_metacall (this=0x3eb2dc0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffcfb585b0) at ./kateview.moc:375
#15 0x00007f7a4aaf4e3f in QMetaObject::activate (sender=0x38e16d0, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3293
#16 0x00007f7a4bfab032 in QAction::triggered (this=0x0, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#17 0x00007f7a4bfad0ab in QAction::activate (this=0x38e16d0, event=<value optimized out>) at kernel/qaction.cpp:1255
#18 0x00007f7a4bfae9b7 in QAction::event (this=0x0, e=<value optimized out>) at kernel/qaction.cpp:1181
#19 0x00007f7a4b1cd00d in KAction::event (this=0x0, event=0x7fffcfb58c20) at ../../kdeui/actions/kaction.cpp:129
#20 0x00007f7a4bfb122c in QApplicationPrivate::notify_helper (this=0x179c2d0, receiver=0x38e16d0, e=0x7fffcfb58c20) at kernel/qapplication.cpp:4300
#21 0x00007f7a4bfb76fb in QApplication::notify (this=0x7fffcfb5a260, receiver=0x38e16d0, e=0x7fffcfb58c20) at kernel/qapplication.cpp:4183
#22 0x00007f7a4b2a2a16 in KApplication::notify (this=0x7fffcfb5a260, receiver=0x38e16d0, event=0x7fffcfb58c20) at ../../kdeui/kernel/kapplication.cpp:302
#23 0x00007f7a4aae206c in QCoreApplication::notifyInternal (this=0x7fffcfb5a260, receiver=0x38e16d0, event=0x7fffcfb58c20) at kernel/qcoreapplication.cpp:704
#24 0x00007f7a4bfece86 in QCoreApplication::sendEvent (this=<value optimized out>, e=0x7fffcfb59220) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#25 QShortcutMap::dispatchEvent (this=<value optimized out>, e=0x7fffcfb59220) at kernel/qshortcutmap.cpp:879
#26 0x00007f7a4bfeec97 in QShortcutMap::tryShortcutEvent (this=0x179c3f8, o=<value optimized out>, e=0x7fffcfb59220) at kernel/qshortcutmap.cpp:364
#27 0x00007f7a4bfb9268 in QApplication::notify (this=0x7fffcfb5a260, receiver=0x3eb5250, e=0x7fffcfb59220) at kernel/qapplication.cpp:3746
#28 0x00007f7a4b2a2a16 in KApplication::notify (this=0x7fffcfb5a260, receiver=0x3eb5250, event=0x7fffcfb59220) at ../../kdeui/kernel/kapplication.cpp:302
#29 0x00007f7a4aae206c in QCoreApplication::notifyInternal (this=0x7fffcfb5a260, receiver=0x3eb5250, event=0x7fffcfb59220) at kernel/qcoreapplication.cpp:704
#30 0x00007f7a4c05c16a in QKeyMapper::sendKeyEvent (keyWidget=0x3eb5250, grab=<value optimized out>, type=QEvent::KeyPress, code=16777223, modifiers=<value optimized out>, text=..., 
    autorepeat=false, count=1, nativeScanCode=119, nativeVirtualKey=65535, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1861
#31 0x00007f7a4c05e6f0 in QKeyMapperPrivate::translateKeyEvent (this=0x17da550, keyWidget=0x3eb5250, event=<value optimized out>, grab=64) at kernel/qkeymapper_x11.cpp:1831
#32 0x00007f7a4c035904 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffcfb59df0) at kernel/qapplication_x11.cpp:3394
#33 0x00007f7a4c061882 in x11EventSourceDispatch (s=0x17a0050, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#34 0x00007f7a49d558c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#35 0x00007f7a49d59748 in ?? () from /lib/libglib-2.0.so.0
#36 0x00007f7a49d598fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#37 0x00007f7a4ab0b513 in QEventDispatcherGlib::processEvents (this=0x1776770, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#38 0x00007f7a4c06146e in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f7a4aae0992 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#40 0x00007f7a4aae0d6c in QEventLoop::exec (this=0x7fffcfb5a120, flags=) at kernel/qeventloop.cpp:201
#41 0x00007f7a4aae4aab in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#42 0x00007f7a4ce12eed in kdemain () from /usr/lib/libkdeinit4_kate.so
#43 0x00007f7a4caa8c4d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fffcfb5b7e8) at libc-start.c:226
#44 0x00000000004006b9 in _start ()

Reported using DrKonqi
Comment 1 Christoph Cullmann 2012-07-04 13:54:28 UTC
Can't reproduce, we would need some test case to fix this.
Perhaps the code is already fixed, but without test, we can't know.
Comment 2 Andrew Crouthamel 2018-09-23 02:39:25 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Andrew Crouthamel 2018-10-27 03:31:50 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!