Bug 302282 - panel overlaps full screen window if panel on edge between two screens
Summary: panel overlaps full screen window if panel on edge between two screens
Status: RESOLVED DUPLICATE of bug 94470
Alias: None
Product: plasma4
Classification: Plasma
Component: panel (show other bugs)
Version: 4.7.4
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-21 06:15 UTC by Pascal R.
Modified: 2016-01-03 15:47 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
screenshot of the panel overlapping a maximized window (228.79 KB, image/jpeg)
2013-02-21 20:25 UTC, Elena Cortis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pascal R. 2012-06-21 06:15:15 UTC
If two screens are configured, one on the left and one on the right, and you put the KDE plasma panel on one of the (vertical) edges that is between the the two screens, it will overlap full screen windows, because they are maximized to the full screen size without taking the panel in respect.

After moving the panel to the left of the left screen or the right of the right screen, everything is working fine.

Reproducible: Always

Steps to Reproduce:
1. Start KDE with single screen.
2. Move the default panel from the bottom edge to the right edge (and set it to "always visible" if it wasn't already).
3. Connect another screen to your computer.
4. Configure the second screen to expand your desktop on the right (with system settings or xrandr).
5. Maximize a window on the screen where the panel is.

You can swap step 2 and 3 and restart your computer or plasma or your session before or after but this will not help.
Actual Results:  
The window will maximize to the full screen size (of only one screen) and the right edge of the window will disappear behind the panel.

Expected Results:  
The window will maximize to the full screen size (of only one screen) minus the width of the panel in x dimension. You could also describe this behaviour as: The window will maximize to the free space on the screen.

Tested on a Lenovo ThinkPad L420 with intel graphics chipset.
Comment 1 Elena Cortis 2013-02-21 20:22:07 UTC
I can confirm this behavior. This happens both with KDE 4.9.4 on Ubuntu 12.10 and KDE 4.8.5 on Mageia 2. 
If the panel is on the right edge of the left screen, this makes the close and maximize buttons inaccessible, which is quite annoying.
Comment 2 Elena Cortis 2013-02-21 20:25:26 UTC
Created attachment 77495 [details]
screenshot of the panel overlapping a maximized window
Comment 3 Elena Cortis 2013-04-06 19:29:48 UTC
Are https://bugs.kde.org/show_bug.cgi?id=310156 and this bug duplicates?
Comment 4 Martin Kimmerle 2014-04-07 10:36:36 UTC
Seems this is a Wontfix and might be fixed with Wayland. See bug 94470 comment 57:
https://bugs.kde.org/show_bug.cgi?id=94470#c57
Comment 5 Oliver Kurz 2015-11-18 12:07:41 UTC
Can confirm still happening, other distro: openSUSE Leap 42.1 plasma version 5.4.2
Comment 6 deabru 2015-12-16 16:16:05 UTC
Confirmed on openSUSE Leap 42.1, plasma 5.4.3

Is Plasma 5 a different product from Plasma 4? should we open another bug report?
Comment 7 Martin Flöser 2016-01-01 17:55:49 UTC

*** This bug has been marked as a duplicate of bug 94470 ***
Comment 8 Oliver Kurz 2016-01-02 09:44:06 UTC
I don't understand why this bug is closed as duplicate, also the parent bug 94470 is closed as WONTFIX. How is plasma expected to handle multiple screens with panels on each screen? I don't think this is such an unusual setup. From the user point of view this is clearly a bug and I am sure the developer(s) that allowed panels to be created on each screen did not have it in mind to maximize windows behind panels.
Regardless of any "NETWM spec" in IMHO maximizing behind panels does not make any sense. Maximizing in front of panels would be better, not covering the panel would be best, i.e. probably expected by most users.

Please reopen the bug (as I seem to not be able to do it) as it is not the same issue.
Comment 9 David Edmundson 2016-01-02 10:18:56 UTC
>Please reopen the bug (as I seem to not be able to do it) as it is not the same issue.

Yes it is.
Comment 10 Oliver Kurz 2016-01-03 15:47:04 UTC
(In reply to David Edmundson from comment #9)
> >Please reopen the bug (as I seem to not be able to do it) as it is not the same issue.
> 
> Yes it is.

Unfortunately your statement is lacking an explanation. I will try to state my message from comment 8 as a question:
How is the intended behavior of plasma when configuring panels on multiple screens?