Bug 302164 - the efficiency of drawing in kwin 4.9 beta2 is lower than 4.8
Summary: the efficiency of drawing in kwin 4.9 beta2 is lower than 4.8
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: 4.8.90
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-19 03:58 UTC by Ukyoi
Modified: 2012-07-12 07:40 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Window title will become white when trigger a window wht "Present windows" (312.88 KB, image/png)
2012-06-23 12:58 UTC, Ukyoi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ukyoi 2012-06-19 03:58:09 UTC
I'm not indicating the speed of the animation. Actually the speed of "Normal" is become much faster than before (seems someone has reported that). But I'm talking about the efficiency of drawing.

1. When moving the window, there will be a lag while the whole window becoming semi-transparent.
2. When watching a video with smplayer, the video not performed affluently whatever the vsync is on or off (vsync on will cause the fps exceed 60 when playing video in 4.9 beta but it seems not the main reason of the problem), especially when walking through windows with "Cover switch" (a kwin effect) at the same time.
3. When selected a window with "Present windows" (a kwin effect), the window title will become white until the effect end.

In summary, I guess there are some redundant works is being done when kwin is working.

I'm not a professional bug reporter and it's really hard to explain. Please forgive me if there is something wrong in the bug report.

Reproducible: Always

Steps to Reproduce:
First problem:
1,Moving the window.

Second problem:
1.Open a video in smplayer
2.Trigger "Cover switch" and watch the video through the effect.

Third problem:
1.Trigger "Present windows"
2.Select a window and watch the window title before the effect ended.
Actual Results:  
Refer to the "Deteils" part.

Expected Results:  
Behave like them in KDE 4.8.
Comment 1 Thomas Lübking 2012-06-19 07:51:37 UTC
please attach/post the  output of
qdbus org.kde.kwin /KWin supportInformation

In case you've an intel GMA chip (esp 915/945) turn of OpenGL2 shaders in "kcmshell4 kwincompositing",
Comment 2 Ukyoi 2012-06-19 10:08:09 UTC
(In reply to comment #1)
> please attach/post the  output of
> qdbus org.kde.kwin /KWin supportInformation
> 
> In case you've an intel GMA chip (esp 915/945) turn of OpenGL2 shaders in
> "kcmshell4 kwincompositing",


Thanks for your reply.
I pasted the output at here:
http://paste.kde.org/503258/

I have an i965 chipset and the openGL 2.0 seems not be used whatever I check or uncheck "Use OpenGL2 Shaders".
Comment 3 Thomas Lübking 2012-06-19 11:16:49 UTC
nothing "obvious"

> openGL 2.0 seems not be used whatever I check or uncheck "Use OpenGL2 Shaders"
that's a fixed bug (trouble with npot usage) and a regression compared to 4.8

Please try to deactivate the blur effect, it could be either affected by the mentioned bug (uses a different implementation w/o glsl) or (and esp. if you just upgraded mesa as well) by "too optimistically promoted" shader capabilities.

In case this speeds up things, please try the shader effect with lowered strength and check whether at some point there's a significant performance boost.

Also please keep an eye on "the window title will become white" and esp. if that isn't affected by blurring, please illustrate it with a screenshot.
Comment 4 Ukyoi 2012-06-23 12:58:13 UTC
Created attachment 72066 [details]
Window title will become white when trigger a window wht "Present windows"

Window title will become white when trigger a window wht "Present windows".
If the effect is finished, the title will return to normal.
Comment 5 Ukyoi 2012-06-23 13:12:22 UTC
(In reply to comment #3)
> nothing "obvious"
> 
> > openGL 2.0 seems not be used whatever I check or uncheck "Use OpenGL2 Shaders"
> that's a fixed bug (trouble with npot usage) and a regression compared to 4.8
> 
> Please try to deactivate the blur effect, it could be either affected by the
> mentioned bug (uses a different implementation w/o glsl) or (and esp. if you
> just upgraded mesa as well) by "too optimistically promoted" shader
> capabilities.
> 
> In case this speeds up things, please try the shader effect with lowered
> strength and check whether at some point there's a significant performance
> boost.
> 
> Also please keep an eye on "the window title will become white" and esp. if
> that isn't affected by blurring, please illustrate it with a screenshot.

(In reply to comment #3)
> nothing "obvious"
> 
> > openGL 2.0 seems not be used whatever I check or uncheck "Use OpenGL2 Shaders"
> that's a fixed bug (trouble with npot usage) and a regression compared to 4.8
> 
> Please try to deactivate the blur effect, it could be either affected by the
> mentioned bug (uses a different implementation w/o glsl) or (and esp. if you
> just upgraded mesa as well) by "too optimistically promoted" shader
> capabilities.
> 
> In case this speeds up things, please try the shader effect with lowered
> strength and check whether at some point there's a significant performance
> boost.
> 
> Also please keep an eye on "the window title will become white" and esp. if
> that isn't affected by blurring, please illustrate it with a screenshot.

Thanks for your reply.

All of the problems seems not related to the blur effect because turning off it is useless.

The problem of watching a video seems just a problem cause by the boost of fps when playing it. I turned on Vsync and it's normal now. But also has small lagging when watch it through "Cover switch" or "Present windows" effects (I use the video "How Linux is Built" in linuxfoundation.org to test). While this small issue is not harmful for daily use.

I add an attachment to discribe the "white window" problem.

I indeed upgraded mesa recently but it behaves properly in KDE 4.8. Could you describe the meaning of w/o in a few words? I really can't understand what is "uses a different implementation w/o glsl".
Comment 6 Thomas Lübking 2012-06-23 17:11:37 UTC
Overexposed, also there's a gap what means clamping doesn't work -> very much likely an NPOT texture (iirc we had overexposed textures alongside fglrx or the radeon driver and it was pot. NPOT related as well)

Is there any chance you can try a patch or just current git master?
Comment 7 Ukyoi 2012-06-24 08:36:17 UTC
(In reply to comment #6)

Thanks for your replay.

> NPOT related as well
Oh. I just using OpenGL 1.0 (because of that known bug) and it seems doesn't support NPOT. I'll try it when rc1 announced.

> Is there any chance you can try a patch or just current git master?
Arch linux has an unofficial "kde-snapshots" repo. But because I'm busy preparing for a final exam recently, I need to keep my laptop stable enough and have no abundant time to try it until May 29th. Sorry about that.
Comment 8 Ukyoi 2012-07-12 07:40:50 UTC
Sorry for delaying my report. 

The overexposing doesn't exist with OpenGL 2 but it still happen with OpenGL 1. Turning off VSync can solve the problem of playing video. When using "Cover Switch" or "Present Windows", the video in the program seems have a wrong field order but it's a small glitch that not harmful for daily use. Thanks for your work.