Bug 302124 - Google calendar resource fails to parse token page
Summary: Google calendar resource fails to parse token page
Status: RESOLVED DUPLICATE of bug 301240
Alias: None
Product: libkgapi
Classification: Unclassified
Component: General (show other bugs)
Version: 0.4.0
Platform: unspecified Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Daniel Vrátil
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-18 13:19 UTC by Otso Helenius
Modified: 2012-06-18 13:42 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Otso Helenius 2012-06-18 13:19:13 UTC
I opened akonadi server configuration page and added the google calendar module. after pressing authenticate and entering my google credentials on the login page and granting the akonadi resource access to my google account, the module simply says "parsing token page failed". (I am using two stage authentication just for the info)

The token parsing error happens also for all the other google resources in akonadi. the versions i'm using are:

akonadi-google-calendar-0.2-12.20120301git41cd7c5.fc17.x86_64
akonadi-google-0.2-12.20120301git41cd7c5.fc17.x86_64
akonadi-google-contacts-0.2-12.20120301git41cd7c5.fc17.x86_64
akonadi-1.7.2-1.fc17.x86_64
akonadi-google-tasks-0.2-12.20120301git41cd7c5.fc17.x86_64
akonadi-google-debuginfo-0.2-12.20120301git41cd7c5.fc17.x86_64
kdepimlibs-akonadi-4.8.3-1.fc17.x86_64


Reproducible: Always

Steps to Reproduce:
1. Try to authenticate a new google module
2. Get error after allowing access to google account
Actual Results:  
Parse error

Expected Results:  
Reliable access to the calendar, contacts and tasks
Comment 1 Daniel Vrátil 2012-06-18 13:42:25 UTC
Thanks for reporting the issue. This problem has been fixed in LibKGAPI 0.4.1. 

Please wait for your distribution to update the resources.

*** This bug has been marked as a duplicate of bug 301240 ***