Bug 302094 - KWin crashes with flash
Summary: KWin crashes with flash
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-18 02:34 UTC by Leon Maurer
Modified: 2013-01-17 15:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leon Maurer 2012-06-18 02:34:52 UTC
Application: kwin (4.8.3 (4.8.3))
KDE Platform Version: 4.8.3 (4.8.3)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-25-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I was watching a flash video in Google Chrome. When the flash plug-in crashed, so did KWin. This has happened a few times. I realize this issue may be in the video driver or somewhere else out of KDE's hands, but I'm reporting it in case it's not.

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f953ebe4780 (LWP 1805))]

Thread 4 (Thread 0x7f951bdcb700 (LWP 1981)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f9522de5e73 in ?? () from /usr/lib/x86_64-linux-gnu/dri/r600_dri.so
#2  0x00007f9532cf3e9a in start_thread (arg=0x7f951bdcb700) at pthread_create.c:308
#3  0x00007f953e3fd4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f951a850700 (LWP 1986)):
#0  0x00007f953e3f6823 in select () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f9539bf7366 in qt_safe_select (nfds=21, fdread=0x7f950c000ac8, fdwrite=0x7f950c000d60, fdexcept=0x7f950c000ff8, orig_timeout=<optimized out>) at kernel/qcore_unix.cpp:83
#2  0x00007f9539bfc7b2 in QEventDispatcherUNIXPrivate::doSelect (this=0x7f950c000910, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:223
#3  0x00007f9539bfcca3 in QEventDispatcherUNIX::processEvents (this=0x7f950c0008f0, flags=...) at kernel/qeventdispatcher_unix.cpp:926
#4  0x00007f9539bc9c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9539bc9ed7 in QEventLoop::exec (this=0x7f951a84fdd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9539ac8fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f9539ba99ff in QInotifyFileSystemWatcherEngine::run (this=0x1b80d40) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f9539acbfcb in QThreadPrivate::start (arg=0x1b80d40) at thread/qthread_unix.cpp:298
#9  0x00007f9532cf3e9a in start_thread (arg=0x7f951a850700) at pthread_create.c:308
#10 0x00007f953e3fd4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f951a04f700 (LWP 1987)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f953aeb6222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f953aeb6259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f9532cf3e9a in start_thread (arg=0x7f951a04f700) at pthread_create.c:308
#4  0x00007f953e3fd4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f953ebe4780 (LWP 1805)):
[KCrash Handler]
#6  0x00007f953e7772cc in QList (l=..., this=0x7fff0969e080) at /usr/include/qt4/QtCore/qlist.h:122
#7  WindowQuadList (this=0x7fff0969e080) at ../../kwin/libkwineffects/kwineffects.h:1343
#8  WindowPaintData (this=0x7fff0969e030) at ../../kwin/libkwineffects/kwineffects.h:1383
#9  KWin::Scene::finalDrawWindow (this=0x1924590, w=0x1cd1540, mask=9, region=..., data=...) at ../../kwin/scene.cpp:438
#10 0x00007f953e799d35 in KWin::EffectsHandlerImpl::drawWindow (this=0x1b69cd0, w=0x1cd1550, mask=9, region=..., data=...) at ../../kwin/effects.cpp:286
#11 0x00007f951b1c90b7 in KWin::BlurEffect::drawWindow (this=<optimized out>, w=0x1cd1550, mask=9, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:389
#12 0x00007f953e799cc9 in KWin::EffectsHandlerImpl::drawWindow (this=0x1b69cd0, w=0x1cd1550, mask=9, region=..., data=...) at ../../kwin/effects.cpp:283
#13 0x00007f953c56539b in KWin::Effect::drawWindow (this=<optimized out>, w=0x1cd1550, mask=9, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:182
#14 0x00007f953e799cc9 in KWin::EffectsHandlerImpl::drawWindow (this=0x1b69cd0, w=0x1cd1550, mask=9, region=..., data=...) at ../../kwin/effects.cpp:283
#15 0x00007f953e776885 in KWin::Scene::finalPaintWindow (this=<optimized out>, w=0x1cd1540, mask=9, region=..., data=...) at ../../kwin/scene.cpp:429
#16 0x00007f953e799fc5 in KWin::EffectsHandlerImpl::paintWindow (this=0x1b69cd0, w=0x1cd1550, mask=9, region=..., data=...) at ../../kwin/effects.cpp:249
#17 0x00007f953c56549b in KWin::Effect::paintWindow (this=<optimized out>, w=0x1cd1550, mask=9, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:157
#18 0x00007f953e799f59 in KWin::EffectsHandlerImpl::paintWindow (this=0x1b69cd0, w=0x1cd1550, mask=9, region=..., data=...) at ../../kwin/effects.cpp:246
#19 0x00007f951b1b2c0b in KWin::TranslucencyEffect::paintWindow (this=<optimized out>, w=0x1cd1550, mask=9, region=..., data=...) at ../../../kwin/effects/translucency/translucency.cpp:169
#20 0x00007f953e799f59 in KWin::EffectsHandlerImpl::paintWindow (this=0x1b69cd0, w=0x1cd1550, mask=9, region=..., data=...) at ../../kwin/effects.cpp:246
#21 0x00007f953e777508 in KWin::Scene::paintWindow (this=<optimized out>, w=0x1c68250, mask=9, region=..., quads=...) at ../../kwin/scene.cpp:385
#22 0x00007f953e7780ad in KWin::Scene::paintSimpleScreen (this=0x1924590, orig_mask=8, region=<error reading variable: Cannot access memory at address 0xffffffffffffffff>) at ../../kwin/scene.cpp:330
#23 0x00007f953e7767b4 in KWin::Scene::finalPaintScreen (this=0x1924590, mask=8, region=..., data=...) at ../../kwin/scene.cpp:198
#24 0x00007f953e79a197 in KWin::EffectsHandlerImpl::paintScreen (this=0x1b69cd0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:222
#25 0x00007f953c565508 in KWin::Effect::paintScreen (this=<optimized out>, mask=8, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#26 0x00007f953e79a13b in KWin::EffectsHandlerImpl::paintScreen (this=0x1b69cd0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:219
#27 0x00007f953c565508 in KWin::Effect::paintScreen (this=<optimized out>, mask=8, region=..., data=...) at ../../../kwin/libkwineffects/kwineffects.cpp:142
#28 0x00007f953e79a13b in KWin::EffectsHandlerImpl::paintScreen (this=0x1b69cd0, mask=8, region=..., data=...) at ../../kwin/effects.cpp:219
#29 0x00007f953e7797c5 in KWin::Scene::paintScreen (this=0x1924590, mask=0x7fff0969ef08, region=0x7fff0969efd0) at ../../kwin/scene.cpp:156
#30 0x00007f953e78f68d in KWin::SceneOpenGL::paint (this=0x1924590, damage=..., toplevels=...) at ../../kwin/scene_opengl_glx.cpp:459
#31 0x00007f953e7732fc in KWin::Workspace::performCompositing (this=0x175b690) at ../../kwin/composite.cpp:412
#32 0x00007f9539be4179 in QObject::event (this=0x175b690, e=<optimized out>) at kernel/qobject.cpp:1157
#33 0x00007f9538f4d894 in notify_helper (e=0x7fff0969f6d0, receiver=0x175b690, this=0x15ed5c0) at kernel/qapplication.cpp:4559
#34 QApplicationPrivate::notify_helper (this=0x15ed5c0, receiver=0x175b690, e=0x7fff0969f6d0) at kernel/qapplication.cpp:4531
#35 0x00007f9538f52713 in QApplication::notify (this=0x7fff0969faf0, receiver=0x175b690, e=0x7fff0969f6d0) at kernel/qapplication.cpp:4420
#36 0x00007f953ded8bb6 in KApplication::notify (this=0x7fff0969faf0, receiver=0x175b690, event=0x7fff0969f6d0) at ../../kdeui/kernel/kapplication.cpp:311
#37 0x00007f9539bcae9c in QCoreApplication::notifyInternal (this=0x7fff0969faf0, receiver=0x175b690, event=0x7fff0969f6d0) at kernel/qcoreapplication.cpp:876
#38 0x00007f9539bfc1f2 in sendEvent (event=0x7fff0969f6d0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#39 QTimerInfoList::activateTimers (this=0x15ee1e8) at kernel/qeventdispatcher_unix.cpp:611
#40 0x00007f9539bfccb4 in QEventDispatcherUNIX::processEvents (this=0x159fad0, flags=...) at kernel/qeventdispatcher_unix.cpp:930
#41 0x00007f9538ff6bf8 in QEventDispatcherX11::processEvents (this=0x159fad0, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#42 0x00007f9539bc9c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#43 0x00007f9539bc9ed7 in QEventLoop::exec (this=0x7fff0969fa30, flags=...) at kernel/qeventloop.cpp:204
#44 0x00007f9539bcef67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#45 0x00007f953e728a06 in kdemain (argc=<optimized out>, argv=<optimized out>) at ../../kwin/main.cpp:541
#46 0x00007f953e32c76d in __libc_start_main (main=0x400630 <main(int, char**)>, argc=3, ubp_av=0x7fff096a0218, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff096a0208) at libc-start.c:226
#47 0x0000000000400661 in _start ()

Possible duplicates by query: bug 280324.

Reported using DrKonqi
Comment 1 Thomas Lübking 2012-06-18 09:04:28 UTC
it *might* fall into categories of
https://git.reviewboard.kde.org/r/104703/

it's *not* a dupe of bug #280324
Comment 2 Martin Flöser 2013-01-17 15:56:53 UTC
It's very difficult to say something about this crash. As pointed out in comment #1: it might be fixed, but we don't know.

The problem here is that we cannot reproduce the situation which caused the crash, which makes it impossible to say for sure it's fixed.

I just assume that we fixed it. If you are still able to reproduce it, please reopen and provide steps to reproduce the issue.