Bug 301836 - Plop sound when changing the volume can't be turned off
Summary: Plop sound when changing the volume can't be turned off
Status: RESOLVED FIXED
Alias: None
Product: kmix
Classification: Unclassified
Component: KMix Panel Docking (show other bugs)
Version: 4.5
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-06-13 18:49 UTC by Janek Bevendorff
Modified: 2020-02-06 19:51 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janek Bevendorff 2012-06-13 18:49:40 UTC
When changing the system volume either via the Kmix popup in the system tray or by hitting the volume keys on the keyboard (in case you have a notebook or a keyboard with multimedia keys) there is always a "plop" sound that can't be turned off.

As far as I know this is normally controlled by the "Beeb" property for the KDE Workspace notification settings, but turning this option off doesn't do anything.
The plop sound can only be turned off by muting system sounds alltogether.

Reproducible: Always



Expected Results:  
There should be an option in the notification settings to turn off the plop sound.
Comment 1 Christian Esken 2012-06-26 20:20:41 UTC
I am a bit confused. The plop sound should not be in any release, only in the development version. Are you running a development version?
In any case, for KDE 4.9 this will be configurable.
Comment 2 Janek Bevendorff 2012-06-26 20:22:46 UTC
I had this in 4.8.80 and still have it in 4.8.90 (i.e. both beta 
releases).
Comment 3 Christian Esken 2012-06-26 21:50:40 UTC
Git commit 9adc98fd03c2d9a5fdf68953e3591dcaa857177f by Christian Esken.
Committed on 26/06/2012 at 22:22.
Pushed by esken into branch 'master'.

Allow disableing of "plop" sound on volume changes.

M  +17   -0    apps/kmix.cpp
M  +2    -0    apps/kmix.h
M  +1    -1    backends/mixer_pulse.cpp
M  +5    -0    core/mixer.cpp
M  +6    -0    core/mixer.h
M  +8    -0    gui/kmixprefdlg.cpp
M  +1    -0    gui/kmixprefdlg.h

http://commits.kde.org/kmix/9adc98fd03c2d9a5fdf68953e3591dcaa857177f
Comment 4 Christian Esken 2012-06-26 22:18:36 UTC
Git commit 2eeb898695494747f6c220add82b2ea9b41cea86 by Christian Esken, on behalf of Script Kiddy.
Committed on 21/06/2012 at 10:37.
Pushed by esken into branch 'remotes/origin/KDE/4.9'.

Backport to branch: Fix "plop sound" not configurable.

M  +17   -0    apps/kmix.cpp
M  +2    -0    apps/kmix.h
M  +1    -1    backends/mixer_pulse.cpp
M  +5    -0    core/mixer.cpp
M  +6    -0    core/mixer.h
M  +1    -1    core/version.h
M  +8    -0    gui/kmixprefdlg.cpp
M  +1    -0    gui/kmixprefdlg.h

http://commits.kde.org/kmix/2eeb898695494747f6c220add82b2ea9b41cea86
Comment 5 Christoph Feck 2012-07-18 16:07:12 UTC
Christian, the backport went to an incorrect branch. It should be just "origin/KDE/4.9", not "origin/remotes/origin/KDE/4.9". If you need help cleaning up, please ask admins.
Comment 6 Christoph Feck 2012-07-18 16:10:20 UTC
Also, there is a "origin/local/4.9" branch, which also looks wrong.
Comment 7 Janek Bevendorff 2012-07-18 16:21:59 UTC
I reopen this until it is committed to the correct branch.
Comment 8 Janek Bevendorff 2012-07-21 20:58:22 UTC
No plop sound in rc2, looks like the patch finally found the right way.
But I also can't find an option for turning it on or off (as Christian's comment suggests). That's confusing me a little.
Comment 9 Christoph Feck 2012-07-22 00:02:07 UTC
> looks like the patch finally found the right way

It has not.
Comment 10 Christian Esken 2012-08-04 15:36:15 UTC
I thought everything is commited, as there only translation changes:
 git diff remotes/origin/KDE/4.9 remotes/origin/HEAD

Am I right with this assumption?

But probably this is again one of the millions of git mysteries (don't know if "remotes/origin/KDE/4.9" is the same as "origin/KDE/4.9" but the diff looks identical) . Sorry if the changes are not in the right branch. I have spent hours and hours trying to figure how to work with git branches, but sooner or later git starts complaining with totally bizarre messages. Probably I will simply stop working in branches, it gets too time-consuming. BTW: I have done another clone and do not see the "origin/local/4.9" and "origin/remotes/origin/KDE/4.9" branches via "git branch -a" there - probably somebody already has cleaned up.
Comment 11 Christian Esken 2012-10-03 23:01:48 UTC
Christoph, I am sure the option is there. If it is actually not in 4.9, it is definitely in trunk and thus will be in 4.10. Thus I'll close this bug report.
Comment 12 Joel Aufrecht 2014-04-20 03:35:06 UTC
This seems to have regressed in Kubuntu 14.04.  

kmix --version
Qt: 4.8.6
KDE Development Platform: 4.13.0
KMix: 4.5

The plop sound occurs even though System Settings > Manage Notifications > Player Settings is set to No Audio Output.  Audio works normally - music plays as it should and there are no notification noises such as login - but Kmix makes the plop sound when the volume is changed.  I don't see how to re-open this bug.  Should I file a new one?
Comment 13 Joel Aufrecht 2014-04-24 00:11:06 UTC
Correction: it is possible to disable the plopping sound of changing volume by changing the "Event Sounds" slider to 0.  This can be in the extended mixer.
Comment 14 Janek Bevendorff 2014-04-24 09:41:37 UTC
This sound can also be disabled by unchecking "Volume Feedback" in the 
KMix settings (click on the KMix icon, then on the wrench symbol.You 
find the option under "General").
I agree, though, that this should be a normal system sound like any 
other than can be disabled over systemsettings.
Comment 15 rgpublic 2014-07-02 10:25:32 UTC
No Janek, it can't, unfortunately. Changing the event sounds volume to 0 is the only way to get rid of the plop sound. But that gets rid of all other (more useful) sounds as well. Unchecking "Volume Feedback" has no effect at all. I also don't see how to reopen this bug so I'm also considering filing a new one....
Comment 16 Janek Bevendorff 2014-07-02 16:36:45 UTC
Are you sure, it doesn't work? I can't confirm this behavior. On my system I was able to successfully turn off the volume feedback as described above.
Can you please post your exact system stats (KDE version, KMix version etc.)? If this issue is reproducible on the current KDE version I can reopen this report.
Comment 17 Joel Aufrecht 2014-07-02 17:17:05 UTC
I re-tested the behavior.  

Steps to Reproduce:
1) have this system: kmix --version
Qt: 4.8.6
KDE Development Platform: 4.13.1
KMix: 4.5

2) in KMix > Settings > General, uncheck Volume Feedback and Apply
3) In the extended Mixer, make sure Event Sounds is at maximum
4) In System Settings > Application and System Notifications > Manage Notifications > Player Settings, set to No audio output.
5) Move the cursor over the volume control icon in the systray and scroll up and down with the middle mouse roller button

Actual Results
bubbling noise

Expected Results
no noise.
Comment 18 rgpublic 2014-07-03 20:02:17 UTC
I've got exactly the same version (this is  simply current up-to-date Kubuntu by the way). I'm definitely sure it doesn't work. It sounds amazing but I can differentiate between a plop sound and no plop sound ;-)

kmix --version
Qt: 4.8.6
KDE: 4.13.1
KMix: 4.5
Comment 19 Janek Bevendorff 2014-07-04 23:00:03 UTC
I still can't reproduce this. Anyway, I'm reopening this issue, so the devs and other users may look into it and report back.
Comment 20 Christian Esken 2014-08-17 17:05:25 UTC
I can reproduce it. I found that a restart of KMix is necessary in the current version. Bug was likely introduced when creating the new configuration. I will commit a fix soon.
Workaround: Quit KMix and restart. It should work then (it does for me in the KDE4.13 version!)
Comment 21 Christian Esken 2014-08-17 17:10:39 UTC
Git commit e8bd7101b450695b083474d7d042ee22f420254f by Christian Esken.
Committed on 17/08/2014 at 17:11.
Pushed by esken into branch 'master'.

Volume feedback does not require a KMix restart anymore (Mixer directly
reads from GlobalConfigData)

M  +0    -14   apps/kmix.cpp
M  +0    -3    apps/kmix.h
M  +0    -5    core/mixer.cpp
M  +6    -2    core/mixer.h

http://commits.kde.org/kmix/e8bd7101b450695b083474d7d042ee22f420254f
Comment 22 Storm Engineer 2015-01-22 13:57:07 UTC
And I just started experiencing this bug today. A few days ago when I was messing with sound settings it wasn't there for sure.

I didn10t update anything since, the only thing I did was installing some PulseAudio packages.
Comment 23 Storm Engineer 2015-01-22 13:58:43 UTC
Also let me add: restarting Kmix doesn't fix it.
Comment 24 launchpad 2020-02-06 19:30:36 UTC
In Kubuntu 19.10, this is not fixed:
https://i.imgur.com/6zRo8dN.png

I have both checkboxes for visual feedback unchecked, and I still cannot get rid of this huge volume dialog that blocks the video I'm watching while I'm adjusting the volume.

If it would pop up on another monitor, that doesn't have focus, maybe I could stand it, but it always jumps in front of the picture of the youtube video I'm watching. Bad idea.

This visual indicator needs to be localize to the small area of the system tray.

However, the bug is the that the two checkboxes, in my screenshot above, do not prevent that dialog from taking over my screen like a boss.
Comment 25 Christoph Feck 2020-02-06 19:49:01 UTC
The screenshot shows the plasma-pulseaudio configuration, not kmix.
Comment 26 Christoph Feck 2020-02-06 19:51:02 UTC
For plasma-pa, I only found bug 401904. If you believe it is not a duplicate, please report a separate ticket for plasma-pa.