Bug 301825 - Crash of IMAP resource on resume from suspend
Summary: Crash of IMAP resource on resume from suspend
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Unclassified
Component: IMAP resource (show other bugs)
Version: 4.8
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
: 295189 302496 303087 305613 305858 306041 311810 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-13 16:53 UTC by Martin Flöser
Modified: 2013-02-28 12:31 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10.1


Attachments
New crash information added by DrKonqi (6.46 KB, text/plain)
2012-06-30 16:03 UTC, Elias Probst
Details
New crash information added by DrKonqi (6.45 KB, text/plain)
2012-07-16 18:38 UTC, Elias Probst
Details
New crash information added by DrKonqi (6.76 KB, text/plain)
2012-12-08 20:25 UTC, Elias Probst
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Flöser 2012-06-13 16:53:10 UTC
Application: akonadi_imap_resource (4.8)
KDE Platform Version: 4.8.4 (4.8.4) (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-2-amd64 x86_64
Distribution: Debian GNU/Linux testing (wheezy)

-- Information about the crash:
- What I was doing when the application crashed:
Resumed from suspend, probably Internet connection was gone in between
- Unusual behavior I noticed:
The system was in suspend

The crash can be reproduced some of the time.

-- Backtrace:
Application: IMAP Account 1 of type  (akonadi_imap_resource), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2cf9d37760 (LWP 4017))]

Thread 10 (Thread 0x7f2ce5487700 (LWP 6224)):
#0  0x00007f2cf4d0dd93 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f2cf3cce4d4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2cf3cce5f4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2cf914c736 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007f2cf911bf92 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007f2cf911c1e7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f2cf901b307 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f2cf7b222c9 in KIMAP::SessionThread::run (this=0x1ed3a80) at /home/martin/kdesrc/kde/kdepimlibs/kimap/sessionthread.cpp:181
#8  0x00007f2cf901e32b in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f2cf8d86b50 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#10 0x00007f2cf4d189dd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f2cdda01700 (LWP 10402)):
#0  0x00007f2cf4d0dd93 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f2cf3cce4d4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2cf3cce5f4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2cf914c736 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007f2cf911bf92 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007f2cf911c1e7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f2cf901b307 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f2cf7b222c9 in KIMAP::SessionThread::run (this=0x22bcf20) at /home/martin/kdesrc/kde/kdepimlibs/kimap/sessionthread.cpp:181
#8  0x00007f2cf901e32b in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f2cf8d86b50 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#10 0x00007f2cf4d189dd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f2ce4c86700 (LWP 15948)):
#0  0x00007f2cf914bcd4 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#1  0x00007f2cf3ccdd0f in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2cf3cce3fb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2cf3cce5f4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f2cf914c736 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007f2cf911bf92 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f2cf911c1e7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f2cf901b307 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007f2cf7b222c9 in KIMAP::SessionThread::run (this=0x22a6d90) at /home/martin/kdesrc/kde/kdepimlibs/kimap/sessionthread.cpp:181
#9  0x00007f2cf901e32b in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007f2cf8d86b50 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#11 0x00007f2cf4d189dd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#12 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f2cdea03700 (LWP 21895)):
#0  0x00007f2cf4d0dd93 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f2cf3cce4d4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2cf3cce5f4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2cf914c736 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007f2cf911bf92 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007f2cf911c1e7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f2cf901b307 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f2cf7b222c9 in KIMAP::SessionThread::run (this=0x2383b00) at /home/martin/kdesrc/kde/kdepimlibs/kimap/sessionthread.cpp:181
#8  0x00007f2cf901e32b in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f2cf8d86b50 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#10 0x00007f2cf4d189dd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f2cd7dda700 (LWP 24731)):
#0  0x00007f2cf4d0dd93 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f2cf3cce4d4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2cf3cce5f4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2cf914c736 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007f2cf911bf92 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007f2cf911c1e7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f2cf901b307 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f2cf7b222c9 in KIMAP::SessionThread::run (this=0x22f1150) at /home/martin/kdesrc/kde/kdepimlibs/kimap/sessionthread.cpp:181
#8  0x00007f2cf901e32b in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f2cf8d86b50 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#10 0x00007f2cf4d189dd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f2cde202700 (LWP 25516)):
#0  0x00007f2cf4d0dd93 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f2cf3cce4d4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2cf3cce5f4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2cf914c736 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007f2cf911bf92 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007f2cf911c1e7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f2cf901b307 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f2cf7b222c9 in KIMAP::SessionThread::run (this=0x218eef0) at /home/martin/kdesrc/kde/kdepimlibs/kimap/sessionthread.cpp:181
#8  0x00007f2cf901e32b in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f2cf8d86b50 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#10 0x00007f2cf4d189dd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f2cdd200700 (LWP 25530)):
#0  0x00007f2cf4d0dd93 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f2cf3cce4d4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2cf3cce5f4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2cf914c736 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007f2cf911bf92 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007f2cf911c1e7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f2cf901b307 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f2cf7b222c9 in KIMAP::SessionThread::run (this=0x7f2cd00c9290) at /home/martin/kdesrc/kde/kdepimlibs/kimap/sessionthread.cpp:181
#8  0x00007f2cf901e32b in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f2cf8d86b50 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#10 0x00007f2cf4d189dd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f2cd6dd8700 (LWP 26377)):
#0  0x00007f2cf8d8b64b in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007f2cf901e79f in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#2  0x00007f2cf901191f in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#3  0x00007f2cf901e32b in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007f2cf8d86b50 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#5  0x00007f2cf4d189dd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f2cd65d7700 (LWP 26384)):
#0  0x00007f2cf4d0dd93 in poll () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007f2cf3cce4d4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2cf3cce5f4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2cf914c736 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007f2cf911bf92 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007f2cf911c1e7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f2cf901b307 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f2cf7b222c9 in KIMAP::SessionThread::run (this=0x22b17a0) at /home/martin/kdesrc/kde/kdepimlibs/kimap/sessionthread.cpp:181
#8  0x00007f2cf901e32b in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f2cf8d86b50 in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#10 0x00007f2cf4d189dd in clone () from /lib/x86_64-linux-gnu/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f2cf9d37760 (LWP 4017)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f2cf7b20137 in qDeleteAll<QList<KIMAP::Job*>::const_iterator> (end=..., begin=...) at /usr/include/qt4/QtCore/qalgorithms.h:322
#8  qDeleteAll<QQueue<KIMAP::Job*> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#9  KIMAP::SessionPrivate::clearJobQueue (this=0x204f2a0) at /home/martin/kdesrc/kde/kdepimlibs/kimap/session.cpp:401
#10 0x00007f2cf9136756 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#11 0x00007f2cf8284204 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#12 0x00007f2cf8289083 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#13 0x00007f2cf611d5d6 in KApplication::notify (this=0x7fffd1680110, receiver=0x22cf010, event=0x7f2cd002ead0) at /home/martin/kdesrc/kde/kdelibs/kdeui/kernel/kapplication.cpp:311
#14 0x00007f2cf911d1ac in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#15 0x00007f2cf9120f7a in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#16 0x00007f2cf914c2a3 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#17 0x00007f2cf3cce205 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007f2cf3cce538 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007f2cf3cce5f4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007f2cf914c6cf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#21 0x00007f2cf8328aee in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#22 0x00007f2cf911bf92 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#23 0x00007f2cf911c1e7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#24 0x00007f2cf9121277 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#25 0x00007f2cf985c126 in Akonadi::ResourceBase::init (r=0x20267e0) at /home/martin/kdesrc/kde/kdepimlibs/akonadi/resourcebase.cpp:412
#26 0x000000000041c396 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /home/martin/kde/include/akonadi/resourcebase.h:188
#27 0x00007f2cf4c5eead in __libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6
#28 0x0000000000416a75 in _start ()

Possible duplicates by query: bug 295189.

Reported using DrKonqi
Comment 1 David Faure 2012-06-29 15:03:40 UTC
*** Bug 302496 has been marked as a duplicate of this bug. ***
Comment 2 Elias Probst 2012-06-30 16:03:38 UTC
Created attachment 72242 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.8) on KDE Platform 4.8.3 (4.8.3) using Qt 4.8.2

- What I was doing when the application crashed:
Resumed my laptop from standby, when I was greated by DrKonqi…

-- Backtrace (Reduced):
#7  0x00007f3fae438977 in qDeleteAll<QList<KIMAP::Job*>::const_iterator> (end=<optimized out>, begin=<optimized out>) at /usr/include/qt4/QtCore/qalgorithms.h:322
#8  qDeleteAll<QQueue<KIMAP::Job*> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#9  KIMAP::SessionPrivate::clearJobQueue (this=0x8c6650) at /var/tmp/portage/kde-base/kdepimlibs-4.8.3/work/kdepimlibs-4.8.3/kimap/session.cpp:401
#10 0x00007f3faf801896 in QObject::event (this=0xa38950, e=<optimized out>) at kernel/qobject.cpp:1195
#11 0x00007f3faeb88374 in QApplicationPrivate::notify_helper (this=0x6aa350, receiver=0xa38950, e=0x7f3f9800cd60) at kernel/qapplication.cpp:4551
Comment 3 Jekyll Wu 2012-07-06 19:09:09 UTC
*** Bug 303087 has been marked as a duplicate of this bug. ***
Comment 4 Jekyll Wu 2012-07-06 19:09:13 UTC
*** Bug 295189 has been marked as a duplicate of this bug. ***
Comment 5 Elias Probst 2012-07-16 18:38:46 UTC
Created attachment 72563 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.8) on KDE Platform 4.8.3 (4.8.3) using Qt 4.8.2

- What I was doing when the application crashed:

It happened again. Crash after resuming from suspend.
KDE 4.8.3
Qt 4.8.2
IMAP server of crashed resource is Citadel Groupware.

-- Backtrace (Reduced):
#7  0x00007f715575f977 in qDeleteAll<QList<KIMAP::Job*>::const_iterator> (end=<optimized out>, begin=<optimized out>) at /usr/include/qt4/QtCore/qalgorithms.h:322
#8  qDeleteAll<QQueue<KIMAP::Job*> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#9  KIMAP::SessionPrivate::clearJobQueue (this=0x8c94c0) at /var/tmp/portage/kde-base/kdepimlibs-4.8.3/work/kdepimlibs-4.8.3/kimap/session.cpp:401
#10 0x00007f7156b28896 in QObject::event (this=0xae3550, e=<optimized out>) at kernel/qobject.cpp:1195
#11 0x00007f7155eaf374 in QApplicationPrivate::notify_helper (this=0x6aa350, receiver=0xae3550, e=0x7f7130000970) at kernel/qapplication.cpp:4551
Comment 6 Janek Bevendorff 2012-08-22 19:34:54 UTC
*** Bug 305613 has been marked as a duplicate of this bug. ***
Comment 7 Myriam Schweingruber 2012-08-27 22:56:10 UTC
*** Bug 305858 has been marked as a duplicate of this bug. ***
Comment 8 Myriam Schweingruber 2012-09-02 07:05:06 UTC
*** Bug 306041 has been marked as a duplicate of this bug. ***
Comment 9 Elias Probst 2012-12-08 20:25:21 UTC
Created attachment 75730 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.9) on KDE Platform 4.9.90 using Qt 4.8.4

- What I was doing when the application crashed:
It happened again using KDE 4.10 beta2 (4.9.90), Qt 4.8.4, 1.8.80.
IMAP resource is still Citadel Groupware.

-- Backtrace (Reduced):
#7  0x00007f3523337187 in qDeleteAll<QList<KIMAP::Job*>::const_iterator> (end=..., begin=...) at /usr/include/qt4/QtCore/qalgorithms.h:322
#8  qDeleteAll<QQueue<KIMAP::Job*> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#9  KIMAP::SessionPrivate::clearJobQueue (this=0x749880) at /var/tmp/portage/kde-base/kdepimlibs-4.9.90/work/kdepimlibs-4.9.90/kimap/session.cpp:407
#10 0x00007f3524713046 in QObject::event (this=0xc4bdc0, e=<optimized out>) at kernel/qobject.cpp:1194
#11 0x00007f3523a9de54 in notify_helper (e=0x7f34f8024920, receiver=0xc4bdc0, this=0x6b1690) at kernel/qapplication.cpp:4562
Comment 10 Jekyll Wu 2013-02-26 03:34:39 UTC
*** Bug 311810 has been marked as a duplicate of this bug. ***
Comment 11 David Faure 2013-02-28 12:31:15 UTC
Git commit a0ac9b5bfd68aab378842f91915f4ba4b084cfb3 by David Faure.
Committed on 27/02/2013 at 19:17.
Pushed by dfaure into branch 'KDE/4.10'.

Fix crash in qDeleteAll(), due to the item dtor modifying the container.
FIXED-IN: 4.10.1

M  +2    -1    kimap/session.cpp

http://commits.kde.org/kdepimlibs/a0ac9b5bfd68aab378842f91915f4ba4b084cfb3