Bug 301791 - Plasma Desktop Crashes when activating second monitor
Summary: Plasma Desktop Crashes when activating second monitor
Status: RESOLVED DUPLICATE of bug 302046
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: 4.8.3
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-13 07:24 UTC by Sven Eden
Modified: 2012-06-28 09:22 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sven Eden 2012-06-13 07:24:23 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.3 (4.8.3) (Compiled from sources)
Qt Version: 4.8.2
Operating System: Linux 3.3.7-gentoo x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
- What I was doing when the application crashed:
Resumed laptop from suspend to ram, attached second monitor, activated second monitor in system settings.

Since I rebuilt my system using gcc-4.7.0 this crash occurs every time. The Plasma Desktop then restarts and I can use the external monitor along the panel fine, but Dr.Konqi keeps popping up first.

- Custom settings of the application:

Rebuilt my system using gcc-4.7.0

(A side note: DrKonqi is currently unable to search the bug reports. I have searched via web interface but could not identify a possible duplicate.)

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma-Desktop-Umgebung (kdeinit4), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4ead273780 (LWP 4395))]

Thread 4 (Thread 0x7f4e82f86700 (LWP 4482)):
#0  pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f4e9e196d07 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f4e9e4a4640) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f4e9e196d39 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f4eabb59fea in start_thread (arg=0x7f4e82f86700) at pthread_create.c:305
#4  0x00007f4eaa90ad4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7f4e81b08700 (LWP 4483)):
#0  0x00007f4eaa901e5f in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f4ea78457a4 in g_main_context_poll (n_fds=1, fds=0x7f4e7c0029b0, timeout=-1, context=0x7f4e7c0009a0, priority=<optimized out>) at gmain.c:3440
#2  g_main_context_iterate (context=context@entry=0x7f4e7c0009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3141
#3  0x00007f4ea78458c4 in g_main_context_iteration (context=0x7f4e7c0009a0, may_block=1) at gmain.c:3207
#4  0x00007f4eabf11ff6 in QEventDispatcherGlib::processEvents (this=0x7f4e7c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f4eabee2c0f in QEventLoop::processEvents (this=this@entry=0x7f4e81b07e60, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f4eabee2e98 in QEventLoop::exec (this=0x7f4e81b07e60, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f4eabde65c0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f4eabec379f in QInotifyFileSystemWatcherEngine::run (this=0x1e4f650) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f4eabde950b in QThreadPrivate::start (arg=0x1e4f650) at thread/qthread_unix.cpp:307
#10 0x00007f4eabb59fea in start_thread (arg=0x7f4e81b08700) at pthread_create.c:305
#11 0x00007f4eaa90ad4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7f4e7bfff700 (LWP 16243)):
#0  pthread_cond_timedwait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:215
#1  0x00007f4eabde9967 in wait (time=30000, this=0x23f7ed0) at thread/qwaitcondition_unix.cpp:84
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x23f8598, time=30000) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f4eabddd29f in QThreadPoolThread::run (this=0x23f75e0) at concurrent/qthreadpool.cpp:141
#4  0x00007f4eabde950b in QThreadPrivate::start (arg=0x23f75e0) at thread/qthread_unix.cpp:307
#5  0x00007f4eabb59fea in start_thread (arg=0x7f4e7bfff700) at pthread_create.c:305
#6  0x00007f4eaa90ad4d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f4ead273780 (LWP 4395)):
[KCrash Handler]
#6  0x00007f4eaa859cf5 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f4eaa85b178 in __GI_abort () at abort.c:91
#8  0x00007f4eaac2d56d in __gnu_cxx::__verbose_terminate_handler () at /home/portage/sys-devel/gcc-4.7.0/work/gcc-4.7.0/libstdc++-v3/libsupc++/vterminate.cc:95
#9  0x00007f4eaac2b676 in __cxxabiv1::__terminate (handler=<optimized out>) at /home/portage/sys-devel/gcc-4.7.0/work/gcc-4.7.0/libstdc++-v3/libsupc++/eh_terminate.cc:40
#10 0x00007f4eaac2b6a3 in std::terminate () at /home/portage/sys-devel/gcc-4.7.0/work/gcc-4.7.0/libstdc++-v3/libsupc++/eh_terminate.cc:50
#11 0x00007f4eaac2b916 in __cxxabiv1::__cxa_rethrow () at /home/portage/sys-devel/gcc-4.7.0/work/gcc-4.7.0/libstdc++-v3/libsupc++/eh_throw.cc:116
#12 0x00007f4eabee3104 in QEventLoop::exec (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:218
#13 0x00007f4eabee7b38 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#14 0x00007f4e998bbed5 in kdemain (argc=1, argv=0x1504710) at /home/portage/kde-base/plasma-workspace-4.8.3/work/plasma-workspace-4.8.3/plasma/desktop/shell/main.cpp:120
#15 0x0000000000407fe2 in launch (argc=argc@entry=1, _name=_name@entry=0x1502b38 "/usr/bin/plasma-desktop", args=args@entry=0x1502b50 "", cwd=cwd@entry=0x0, envc=envc@entry=0, envs=<optimized out>, envs@entry=0x1502b58 "", reset_env=false, tty=tty@entry=0x0, avoid_loops=false, startup_id_str=startup_id_str@entry=0x40a8ae "0") at /home/portage/kde-base/kdelibs-4.8.3/work/kdelibs-4.8.3/kinit/kinit.cpp:734
#16 0x0000000000408e5b in handle_launcher_request (sock=7, who=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at /home/portage/kde-base/kdelibs-4.8.3/work/kdelibs-4.8.3/kinit/kinit.cpp:1226
#17 0x000000000040949b in handle_requests (waitForPid=waitForPid@entry=0) at /home/portage/kde-base/kdelibs-4.8.3/work/kdelibs-4.8.3/kinit/kinit.cpp:1419
#18 0x000000000040519f in main (argc=2, argv=0x7fff00000001, envp=0x7fffda5141f0) at /home/portage/kde-base/kdelibs-4.8.3/work/kdelibs-4.8.3/kinit/kinit.cpp:1907

Reported using DrKonqi
Comment 1 Marco Martin 2012-06-28 09:22:55 UTC

*** This bug has been marked as a duplicate of bug 302046 ***