Bug 301624 - dragged icons misplaced
Summary: dragged icons misplaced
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: view-engine: general (show other bugs)
Version: 2.0.95
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-11 08:00 UTC by Martin Koller
Modified: 2013-07-19 09:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Koller 2012-06-11 08:00:17 UTC
When I start a drag operation the icons shown during the drag are misplaced by about 20pixels downwards.

While this might be called a feature, it _feels_ wrong as I'm used to see things I drag very close to or directly beneath the cursor hotspot.
Compare this to the folder view widget's behaviour.
At the very least it is inconsistent with other applications and irritating.


Reproducible: Always
Comment 1 Peter Penz 2012-06-11 12:48:42 UTC
This originally has been done on purpose, because when doing it like in the folder-view, it is not possible to drag an item to e.g. the places-panel as the target is hidden by the overlay.

The best solution from my point of view would be that we could do it like in the folder-view but that the overlay is halve-transparent. Sadyl currently this is not possible with the Qt-drag-and-drop-mechanism...

Probably I might decrease the the gap so that it is just a few pixels below the hotspot for 4.9 and might come up with a custom solution later (-> halve-transparent overlay).
Comment 2 Martin Koller 2012-06-11 12:59:02 UTC
It would be consistent with the other D&D (e.g. dragging  a URL from konqueror, a window from the taskbar to a different virtual desktop, a mail attachment from kmail, etc.) when you place the icon to the right/bottom of the cursor hotspot. This would also leave the cursor itself alone not overlapping with the icons.
Comment 3 Peter Penz 2012-06-12 11:21:42 UTC
Git commit eaf2285afa2f9731fae6e8e1a69b050c85f5ce23 by Peter Penz.
Committed on 12/06/2012 at 13:19.
Pushed by ppenz into branch 'master'.

Drag-pixmap fixes

- Don't use the selection-tinted icon when dragging a single item
- Decrease the vertical gap for the hotspot
- Prevent drawing tree-lines when dragging items for the Places Panel

M  +1    -3    dolphin/src/kitemviews/kitemlistcontroller.cpp
M  +5    -0    dolphin/src/kitemviews/kitemlistwidget.cpp
M  +1    -1    dolphin/src/kitemviews/kstandarditemlistwidget.cpp

http://commits.kde.org/kde-baseapps/eaf2285afa2f9731fae6e8e1a69b050c85f5ce23
Comment 4 Jeroen van Meeuwen (Kolab Systems) 2012-08-24 16:19:50 UTC
Resetting assignee to default as per bug #305719
Comment 5 Martin Koller 2013-07-19 09:12:32 UTC
Checking 4.11 RC1 it is still inconsistent to the folder view widget but it is better than when I reported the problem.
Closing.