Bug 301528 - In-painting enhance effect crashes digikam image editor.
Summary: In-painting enhance effect crashes digikam image editor.
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Editor-Clone (show other bugs)
Version: 2.6.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-09 19:21 UTC by Philip Johnsson
Modified: 2020-08-12 08:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.8.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Johnsson 2012-06-09 19:21:20 UTC
This bug might be related to my other reported bug with the restoration effect as crashes happens about in the same way and both use CIMG backend or something else in common.

Backtrace:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffa6ba8700 (LWP 3793)]
malloc_consolidate (av=0x7fff9c000020) at malloc.c:4240
4240    malloc.c: No such file or directory.
(gdb) bt
#0  malloc_consolidate (av=0x7fff9c000020) at malloc.c:4240
#1  0x00007ffff15c7ec6 in malloc_consolidate (av=0x7fff9c000020)
    at malloc.c:4215
#2  _int_malloc (av=0x7fff9c000020, bytes=2208) at malloc.c:3532
#3  0x00007ffff15caa45 in __GI___libc_malloc (bytes=2208) at malloc.c:2924
#4  0x00007ffff1ecaded in operator new(unsigned long) ()
   from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#5  0x00007ffff5738007 in greycstoration_run (nb_threads=2, tile_border=4, 
    tile=256, fast_approx=true, interpolation=0, gauss_prec=2, da=30, 
    dl=0.800000012, gfact=1, sigma=2, alpha=0.800000012, anisotropy=1, 
    sharpness=0.300000012, amplitude=20, mask=..., this=0x4565618)
    at /tmp/buildd/digikam-2.6.0/core/libs/3rdparty/cimg/greycstoration.h:178
#6  Digikam::GreycstorationFilter::inpainting (this=0x3d6bd50)
    at /tmp/buildd/digikam-2.6.0/core/libs/dimg/filters/greycstoration/greycstorationfilter.cpp:398
#7  0x00007ffff573a3b0 in Digikam::GreycstorationFilter::filterImage (
    this=0x3d6bd50)
    at /tmp/buildd/digikam-2.6.0/core/libs/dimg/filters/greycstoration/greycstorationfilter.cpp:252
#8  0x00007ffff565b8bc in Digikam::DImgThreadedFilter::startFilterDirectly (
    this=0x3d6bd50)
    at /tmp/buildd/digikam-2.6.0/core/libs/dimg/filters/dimgthreadedfilter.cpp:189
#9  0x00007ffff58239ce in Digikam::DynamicThread::DynamicThreadPriv::run (
    this=0x453ae70)
    at /tmp/buildd/digikam-2.6.0/core/libs/threads/dynamicthread.cpp:186
#10 0x00007ffff24014f2 in QThreadPoolThread::run (this=0x25ff9d0)
    at concurrent/qthreadpool.cpp:107
#11 0x00007ffff240dfcb in QThreadPrivate::start (arg=0x25ff9d0)
    at thread/qthread_unix.cpp:298
#12 0x00007fffece30e9a in start_thread (arg=0x7fffa6ba8700)
    at pthread_create.c:308
#13 0x00007ffff163a4bd in clone ()
---Type <return> to continue, or q <return> to quit---
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()
(gdb) 


Reproducible: Always

Steps to Reproduce:
1.open an image in image editor
2.select a region of the image with the selection tool.
3.open Enhance > In-painting effect in Digikam Image Editor.
4. Make sure that the effect starts to get calculated.
5. Digikam crashes.
Actual Results:  
In-painting enhance effect applys without crash.
Comment 1 caulier.gilles 2012-06-13 07:05:34 UTC
It probably the same problem than #232926

Gilles Caulier

*** This bug has been marked as a duplicate of bug 232926 ***
Comment 2 caulier.gilles 2017-09-05 05:09:44 UTC
With 5.8.0, in-painting image editor tool was been replaced by a Clone tool.

More details here : 

https://community.kde.org/GSoC/2017/StatusReports/shazaismailkaoud

Gilles Caulier