Bug 301383 - Dragging window to top edge of the screen to maximize it shows opaque box
Summary: Dragging window to top edge of the screen to maximize it shows opaque box
Status: RESOLVED DUPLICATE of bug 301068
Alias: None
Product: kwin
Classification: Unclassified
Component: compositing (show other bugs)
Version: 4.8.80
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-07 17:16 UTC by Janek Bevendorff
Modified: 2012-06-07 17:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janek Bevendorff 2012-06-07 17:16:51 UTC
When dragging a window with enabled OpenGL compositing to the top edge of the screen to maximize it or to the sides to spread it over half or a quarter of the screen a fully opaque box is shown which is either completely white or completely black.

Reproducible: Always

Steps to Reproduce:
Drag the window to the top, right or left edge of the screen to trigger maximization.
Actual Results:  
A black or white box is shown indicating which part of the screen the window would fill hiding everything that's below.

Expected Results:  
The box that appears should be white (it's sometimes black) and semi-transparent instead of opaque as it was in KDE 4.8.3.

Only happens when OpenGL compositing is enabled, works fine with Xrender.
Using Nouveau driver from Kernel 3.3.0.
Comment 1 Thomas Lübking 2012-06-07 17:35:27 UTC
depends on the graphicssystem

*** This bug has been marked as a duplicate of bug 301068 ***