Bug 301331 - Use .desktop files to describe "tube" services
Summary: Use .desktop files to describe "tube" services
Status: RESOLVED FIXED
Alias: None
Product: telepathy
Classification: Unclassified
Component: general (show other bugs)
Version: git-latest
Platform: unspecified Linux
: NOR task
Target Milestone: 0.6-next
Assignee: Telepathy Bugs
URL:
Keywords:
: 297434 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-07 07:56 UTC by Daniele E. Domenichelli
Modified: 2013-02-06 19:34 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 0.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniele E. Domenichelli 2012-06-07 07:56:30 UTC
At the moment "tube" services names cannot be translated and we don't have a way to know if we support one certain service.
Each service should install a self describing .desktop file somewhere.

This should be done upstream, but George K. asserted that if we implement it downstream, they will be happy to accept it also upstream.
Comment 1 George Kiagiadakis 2012-07-17 08:34:33 UTC
*** Bug 297434 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Vrátil 2013-02-06 19:12:35 UTC
Git commit e44c775b4679e68c603a47d460e28ed84843cf6e by Dan Vrátil.
Committed on 06/02/2013 at 16:55.
Pushed by dvratil into branch 'master'.

.desktop-based tubes channel approver

Every application using tubes should now install a ,desktop
file to `kde4-config --prefix`/share/kde4/services/ktp.

Approver will pick the .desktop file on incoming tube, show
message and icon as specified in the file and 'Accept' and
'Reject' buttons.

REVIEW: 108780

M  +2    -0    CMakeLists.txt
A  +19   -0    ktp-approver.service
M  +1    -1    src/CMakeLists.txt
M  +2    -1    src/approverdaemon.cpp
M  +4    -4    src/channelapprover.cpp
M  +4    -0    src/ktpapprovermodule.cpp
D  +0    -123  src/streamtubechannelapprover.cpp
A  +158  -0    src/tubechannelapprover.cpp     [License: LGPL (v2.1+)]
R  +22   -15   src/tubechannelapprover.h [from: src/streamtubechannelapprover.h - 057% similarity]

http://commits.kde.org/telepathy-approver/e44c775b4679e68c603a47d460e28ed84843cf6e