Bug 301214 - Akregator crashes when i close it
Summary: Akregator crashes when i close it
Status: RESOLVED DUPLICATE of bug 282236
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian unstable Linux
: NOR crash with 40 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 301286 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-06-05 12:12 UTC by kdebugs
Modified: 2015-05-10 15:42 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.50 KB, text/plain)
2012-06-09 03:05 UTC, Manolis Maroudas
Details
New crash information added by DrKonqi (6.90 KB, text/plain)
2012-06-09 11:37 UTC, aeris
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kdebugs 2012-06-05 12:12:38 UTC
Application: akregator (1.6.6)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-2-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

-- Information about the crash:
- What I was doing when the application crashed:

Every time I stop Akregator (File->Exit), I got a crash with this backstrace.

The crash can be reproduced every time.

-- Backtrace:
Application: Akregator (akregator), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007fdca150521e in qDeleteAll<QList<Akregator::TreeNode*>::const_iterator> (end=..., begin=...) at /usr/include/qt4/QtCore/qalgorithms.h:322
#8  qDeleteAll<QList<Akregator::TreeNode*> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#9  Akregator::Folder::FolderPrivate::~FolderPrivate (this=0x23fbe10, __in_chrg=<optimized out>) at ../../../akregator/src/folder.cpp:68
#10 0x00007fdca15052c0 in Akregator::Folder::~Folder (this=0x2306540, __in_chrg=<optimized out>) at ../../../akregator/src/folder.cpp:95
#11 0x00007fdca1505309 in Akregator::Folder::~Folder (this=0x2306540, __in_chrg=<optimized out>) at ../../../akregator/src/folder.cpp:97
#12 0x00007fdca1509bb8 in Akregator::FeedList::setRootNode (this=0x22a94b0, folder=0x0) at ../../../akregator/src/feedlist.cpp:435
#13 0x00007fdca150a707 in Akregator::FeedList::~FeedList (this=0x22a94b0, __in_chrg=<optimized out>) at ../../../akregator/src/feedlist.cpp:315
#14 0x00007fdca150a7e9 in Akregator::FeedList::~FeedList (this=0x22a94b0, __in_chrg=<optimized out>) at ../../../akregator/src/feedlist.cpp:319
#15 0x00007fdca155a69a in release (this=0x1fce2a0) at /usr/include/boost/smart_ptr/detail/sp_counted_base_gcc_x86.hpp:145
#16 ~shared_count (this=<synthetic pointer>, __in_chrg=<optimized out>) at /usr/include/boost/smart_ptr/detail/shared_count.hpp:305
#17 ~shared_ptr (this=<synthetic pointer>, __in_chrg=<optimized out>) at /usr/include/boost/smart_ptr/shared_ptr.hpp:164
#18 Akregator::MainWidget::setFeedList (this=this@entry=0x20b98d0, list=...) at ../../../akregator/src/mainwidget.cpp:431
#19 0x00007fdca155a785 in Akregator::MainWidget::slotOnShutdown (this=0x20b98d0) at ../../../akregator/src/mainwidget.cpp:315
#20 0x00007fdca155250a in Akregator::Part::slotOnShutdown (this=this@entry=0x201d290) at ../../../akregator/src/akregator_part.cpp:296
#21 0x00007fdca1553f20 in Akregator::Part::~Part (this=this@entry=0x201d290, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../../akregator/src/akregator_part.cpp:341
#22 0x00007fdca1554079 in Akregator::Part::~Part (this=0x201d290, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at ../../../akregator/src/akregator_part.cpp:344
#23 0x000000000040a387 in Akregator::MainWindow::queryExit (this=0x1e1b610) at ../../../akregator/src/mainwindow.cpp:196
#24 0x00007fdcbaa1767c in _k_shuttingDown (this=<optimized out>) at ../../kdeui/widgets/kmainwindow.cpp:1126
#25 qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./kmainwindow.moc:79
#26 KMainWindow::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./kmainwindow.moc:66
#27 0x00007fdcb9207a9f in QMetaObject::activate (sender=0x7fffa967caf0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#28 0x00007fdcb91f632d in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1153
#29 0x0000000000408c13 in main (argc=<optimized out>, argv=<optimized out>) at ../../../akregator/src/main.cpp:103

Possible duplicates by query: bug 288154, bug 285938, bug 285753, bug 278742.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-06-06 15:26:42 UTC
*** Bug 301286 has been marked as a duplicate of this bug. ***
Comment 2 Manolis Maroudas 2012-06-09 03:05:28 UTC
Created attachment 71677 [details]
New crash information added by DrKonqi

akregator (1.6.6) on KDE Platform 4.7.4 (4.7.4) using Qt 4.8.1

- What I was doing when the application crashed:

akregator crashes every time on exit/logout

-- Backtrace (Reduced):
#8  0xb0bfe9a6 in qDeleteAll<QList<Akregator::TreeNode*>::const_iterator> (end=..., begin=...) at /usr/include/qt4/QtCore/qalgorithms.h:322
#9  qDeleteAll<QList<Akregator::TreeNode*> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#10 Akregator::Folder::FolderPrivate::~FolderPrivate (this=0xa3e8ed0, __in_chrg=<optimized out>) at ../../../akregator/src/folder.cpp:68
#11 0xb0bfea58 in Akregator::Folder::~Folder (this=0xa3d5540, __in_chrg=<optimized out>) at ../../../akregator/src/folder.cpp:95
#12 0xb0bfeac2 in Akregator::Folder::~Folder (this=0xa3d5540, __in_chrg=<optimized out>) at ../../../akregator/src/folder.cpp:97
Comment 3 aeris 2012-06-09 11:37:13 UTC
Created attachment 71680 [details]
New crash information added by DrKonqi

kontact (4.4.11) on KDE Platform 4.7.4 (4.7.4) using Qt 4.8.1

- What I was doing when the application crashed:
On closing, Kontact crashes probably because of Akregator

No problem with Debian version 4:4.4.11.1+l10n-1, bug is present from 4:4.4.11.1+l10n-2

-- Backtrace (Reduced):
#7  0x00007f982039321e in qDeleteAll<QList<Akregator::TreeNode*>::const_iterator> (end=..., begin=...) at /usr/include/qt4/QtCore/qalgorithms.h:322
#8  qDeleteAll<QList<Akregator::TreeNode*> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#9  Akregator::Folder::FolderPrivate::~FolderPrivate (this=0x49ffdc0, __in_chrg=<optimized out>) at ../../../akregator/src/folder.cpp:68
#10 0x00007f98203932c0 in Akregator::Folder::~Folder (this=0x49fdf30, __in_chrg=<optimized out>) at ../../../akregator/src/folder.cpp:95
#11 0x00007f9820393309 in Akregator::Folder::~Folder (this=0x49fdf30, __in_chrg=<optimized out>) at ../../../akregator/src/folder.cpp:97
Comment 4 basz 2015-02-01 21:17:58 UTC
got the same problem for a very long time now (debian/testing). my system (currently) is:

Application: akregator (4.14.1)
KDE Platform Version: 4.14.2
Qt Version: 4.8.6
Operating System: Linux 3.16.0-4-amd64 x86_64
Distribution: Debian GNU/Linux 8.0 (jessie)

out of interesting stuff, when starting akregator on a console it shows:

QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QSystemTrayIcon::setVisible: No Icon set


and then, when closing it it crashes:

Object::disconnect: Unexpected null parameter
Object::disconnect: Unexpected null parameter
akregator(25169)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
akregator(25169)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:
KCrash: Application 'akregator' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
KCrash: Connect sock_file=/home/someuser/.kde/socket-somehost/kdeinit4__0
Comment 5 cricketc 2015-02-09 19:24:16 UTC
I don't know if this is the same issue or not, but Akregator (4.14.3) regularly crashes for me when I logout of the KDE session.
Comment 6 Pali Rohár 2015-03-01 11:36:50 UTC
Confirmed, same problem with same backtrace. Also it crash on KDE logout.
Comment 7 Pali Rohár 2015-03-01 13:52:36 UTC
This bug is fixed by commit:
http://commits.kde.org/kdepim/c200bf630aea5be26d757351a58219b9088d0d5a

It was backported to KDE 4.7.2

*** This bug has been marked as a duplicate of bug 282236 ***