Bug 301111 - routing info sometimes not shown
Summary: routing info sometimes not shown
Status: RESOLVED WORKSFORME
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-03 16:25 UTC by Michi
Modified: 2013-02-10 16:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
a testcase (787.05 KB, application/vnd.google-earth.kml+xml)
2012-06-03 16:27 UTC, Michi
Details
screenshot (54.05 KB, image/png)
2012-06-04 08:39 UTC, Michi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michi 2012-06-03 16:25:04 UTC
I will attach a list of waypoints that I tried to find routing information for. Although OpenRouteService is able to find one route (bicycle - mountainbike) marble does not show the routing table nor does it paint the route.
After a restart of marble the information is shown until I hit the "Get directions" button again.

At some stage, when I still got more than one routing alternative (just 2 or 3 waypoints), I could at least activate the routing table by switching between the options from the dropdown button "Choose alternative route".

Reproducible: Sometimes
Comment 1 Michi 2012-06-03 16:27:13 UTC
Created attachment 71542 [details]
a testcase
Comment 2 Dennis Nienhüser 2012-06-04 08:02:27 UTC
Which routing backends were enabled? I guess Yours was among them. It doesn't handle via points yet, and in the current version ignores them and calculates the route between the very first and the very last point instead. Hence you get a route that does not travel the via points, but is shorter in total. In that case Marble prefers that route to the one from OpenRouteService and presents it as the first route in the list of alternative routes. Yours does not provide directions, therefore the table is empty.

I'll commit a fix for Yours not to calculate a route when there are via points shorty.

The remaining part of the bug would then be the missing painting of the route. I couldn't reproduce that yet, can you attach a screenshot?
Comment 3 Dennis Nienhüser 2012-06-04 08:03:49 UTC
Git commit 062fee6290fc321d857664c08e9ef8d94a1f6a08 by Dennis Nienhüser.
Committed on 04/06/2012 at 10:02.
Pushed by nienhueser into branch 'master'.

Don't ignore via points, but refuse to calculate a route instead.

M  +1    -1    src/plugins/runner/yours/YoursRunner.cpp

http://commits.kde.org/marble/062fee6290fc321d857664c08e9ef8d94a1f6a08
Comment 4 Michi 2012-06-04 08:37:53 UTC
Hallo Dennis,

I don't think that you're describing what I have encountered.

To start with, it doesn't make a difference whether I have Yours activated or not.

The point is, when I hit the "Get directions" button marble tells me "1 routes found". And also the button at the bottom for choosing alternative routes shows that one choice. However, the directions are not shown anywhere, not in the list nor in the map.

My guess is that it could have to do with the button change event of that bottom button. Because when I get more than 1 routing option, I can change the selection and the routing information is getting updated.
Comment 5 Michi 2012-06-04 08:39:25 UTC
Created attachment 71562 [details]
screenshot
Comment 6 Dennis Nienhüser 2012-06-04 09:02:04 UTC
I tried various ways to create and alter routes (mostly bike routes from OpenRouteService, also in the area you're using and altering the sample .kml you attached) but it always worked fine.
How often does that happen to you? Can you describe in more detail how you compose the route (how do you select via points: button "from map", bookmark, context menu, search; how do you add new? add via button, drag and drop)

The alternative route selection combo box does indeed only update when you switch to another route. That's on purpose, there's no need to recalculate the current result. Of course changing that behavior would be a workaround for the bug you describe, but I'd rather fix the original cause.
Comment 7 Dennis Nienhüser 2012-06-06 14:22:53 UTC
Please reopen with details how to reproduce.
Comment 8 Michi 2013-02-09 18:09:56 UTC
meanwhile it also works for me