Bug 300901 - kwin drags when starting up
Summary: kwin drags when starting up
Status: RESOLVED WORKSFORME
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-31 00:58 UTC by Saurabh Asthana
Modified: 2012-09-08 21:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:
mgraesslin: Intel+


Attachments
qdbus org.kde.kwin /Kwin supportInformation (3.11 KB, text/plain)
2012-09-08 02:32 UTC, Saurabh Asthana
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Saurabh Asthana 2012-05-31 00:58:48 UTC
Whenever I login to KDE, kwin is extremely slow - opening the kickoff menu, spawning windows, switching between windows, all take up to tens of seconds.

However, I can fix this by opening Settings/Desktop Effects and selecting 'Advanced'. There I change the rendering engine from OpenGL to XRender - KDE pops up a confirmation dialog and I refuse, reverting back to openGL. Now everything works fine. No lag at all.

Reproducible: Always




I am using Oxygen decorations with openGL and desktop effects enabled. I have an onboard intel graphics chip from five years ago.
Comment 1 Martin Flöser 2012-05-31 06:37:48 UTC
try to disable OpenGL 2 shaders with such an old GPU
Comment 2 Thomas Lübking 2012-05-31 08:20:01 UTC
all lags seem related to active window changes
->also try another decoration (not aurorae themes, but eg. try "laptop")

if that helps: in "oxygen-settings" you can deactivate animations - does that help?
Comment 3 Thomas Lübking 2012-08-26 10:56:43 UTC
Is this still an issue (with 4.9)

In this case please provide the output of
qdbus org.kde.kwin /KWin supportInformtaion
while things are slow AND after improvements through the workaround
Comment 4 Saurabh Asthana 2012-09-08 02:32:12 UTC
Created attachment 73737 [details]
qdbus org.kde.kwin /Kwin supportInformation
Comment 5 Saurabh Asthana 2012-09-08 02:33:55 UTC
Not sure if it's still the same bug, but now my workaround no longer seems to cut the mustard, and OpenGL rendering is always slow. I've isolated it down to the blur effect (disabled in the above supportInformation log); disabling this seems to ease the problem.
Comment 6 Martin Flöser 2012-09-08 07:14:27 UTC
By default the Blur shader is disabled for your hardware, so that seems just fine. I would also recommend to disable the usage of OpenGL 2 shaders. Given that with default settings the problem does not exist, I dare to set to worksforme.

I just created a new bug 306436 to automatically use the OpenGL 1 backend for your hardware.
Comment 7 Saurabh Asthana 2012-09-08 20:59:43 UTC
I don't have a huge problem with that, but I'll point out that the Blur shader worked just fine in the past with this hardware, so it seems like the problem is not insurmountable. Just maybe not worth it.
Comment 8 Thomas Lübking 2012-09-08 21:20:20 UTC
ARB program bluring will be faster than GLSL blurring in that GPU.
Do not use GLSL or use kwin_gles

Also the intel driver from time to time simply lies about several capabilities.
Reduce the blur strength by hand - at some point it might suddenly be fast again.
Nevertheless, NOT using "OpenGL 2 shaders" is the sane option for that chip (blurring will still work as manymost other effects)