Bug 300753 - [WINDOWS] Panes are all messed up and cannot be re-attached to Amarok-Window
Summary: [WINDOWS] Panes are all messed up and cannot be re-attached to Amarok-Window
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Unclassified
Component: Context View (show other bugs)
Version: 2.6.0
Platform: Microsoft Windows Microsoft Windows
: NOR major with 20 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 304750 312625 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-28 12:17 UTC by fabian_euhus
Modified: 2013-05-13 09:52 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.8


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fabian_euhus 2012-05-28 12:17:17 UTC
When I tried to move the elements around (playlist, context, collection) they dis-attached from the amarok window and now are overlapping each other and cannot be reset to be in the correct window.

Reproducible: Always

Steps to Reproduce:
1. grab pane
2. move pane - and then it detaches from the window and cannot be reattached
3.
Actual Results:  
Amarok looks strange and I cannot configure the look

Expected Results:  
it should be possible to move around the items and then to fix them again. There should be a way to reset everything to default.
Comment 1 Myriam Schweingruber 2012-08-08 20:42:21 UTC
*** Bug 304750 has been marked as a duplicate of this bug. ***
Comment 2 MinSik CHO 2012-12-02 11:51:15 UTC
not reproducible with amarok 2.6
Comment 3 MinSik CHO 2012-12-02 12:14:10 UTC
Sorry, I tested with different environement with the provided environment of this bug.
Comment 4 Kyle 2012-12-03 02:32:07 UTC
Not a problem in version 2.6
Comment 5 Myriam Schweingruber 2012-12-03 09:20:25 UTC
(In reply to comment #4)
> Not a problem in version 2.6

Kyle, IIRC you are currently testing with the git version in Linux, so please, this is a bug about Windows, not about Linux.
Also please read the instructions in the task about how to comment on bugs you check, namely specifying the exact git version (run 'git describe' in the source folder).

To all other subscribers: it would be really helpful if somebody could test with the Windows version of Amarok 2.6
Comment 6 MinSik CHO 2012-12-03 12:03:35 UTC
Ok. I've tested this in Windows 8 (with amarok 2.6)

If you move the pane and drop the pane when a highlight is shown, the pane doesn't go messy.
However, if you do that before the area is highlighted / or at the other region, the pane goes messy and becomes not recoverable.
Comment 7 Myriam Schweingruber 2012-12-03 12:55:14 UTC
(In reply to comment #6)
> Ok. I've tested this in Windows 8 (with amarok 2.6)
> 
> If you move the pane and drop the pane when a highlight is shown, the pane
> doesn't go messy.
> However, if you do that before the area is highlighted / or at the other
> region, the pane goes messy and becomes not recoverable.

Thank you very much for testing!
Comment 8 Myriam Schweingruber 2013-01-04 22:43:30 UTC
*** Bug 312625 has been marked as a duplicate of this bug. ***
Comment 9 B. Kühnel 2013-01-29 17:23:38 UTC
Restoring %APPDATA%\.kde\share\config\amarokrc from a backup fixed this for me. Specifically the following section seems to be responsible:

"clean" layout:

[MainWindow]
State=AAAA/wAAAAD9AAAAAQAAAAAAAAeAAAADr/wBAAAAA/sAAAAkAE0AZQBkAGkAYQAgAFMAbwB1AHIAYwBlAHMAIABkAG8AYwBrAQAAAAAAAAJdAAAAjgEAAAX7AAAAGABDAG8AbgB0AGUAeAB0ACAAZABvAGMAawEAAAJgAAAB6gAAAFABAAAF+wAAABoAUABsAGEAeQBsAGkAcwB0ACAAZABvAGMAawEAAARNAAADMwAAATUBAAAFAAAAAAAAA68AAAAEAAAABAAAAAgAAAAI/AAAAAEAAAACAAAAAgAAABYATQBhAGkAbgBUAG8AbwBsAGIAYQByAAAAAAD/////AAAAAAAAAAAAAAAYAFMAbABpAG0AIABUAG8AbwBsAGIAYQByAQAAAAD/////AAAAAAAAAAA=


"messed up" layout:

[MainWindow]
State=AAAA/wAAAAD9AAAAAQAAAAAAAAeAAAADr/wBAAAAA/sAAAAkAE0AZQBkAGkAYQAgAFMAbwB1AHIAYwBlAHMAIABkAG8AYwBrAQAAAAAAAAMuAAAAjgEAAAX7AAAAGABDAG8AbgB0AGUAeAB0ACAAZABvAGMAawMAAAJgAAAAPgAAAeoAAAOv+wAAABoAUABsAGEAeQBsAGkAcwB0ACAAZABvAGMAawEAAAMxAAAETwAAATUBAAAFAAAAAAAAA68AAAAEAAAABAAAAAgAAAAI/AAAAAEAAAACAAAAAgAAABYATQBhAGkAbgBUAG8AbwBsAGIAYQByAAAAAAD/////AAAAAAAAAAAAAAAYAFMAbABpAG0AIABUAG8AbwBsAGIAYQByAQAAAAD/////AAAAAAAAAAA=


Using the german version 2.5.0 on Windows 7 (installed via KDE 4.8.0 for Windows), sometimes while starting Amarok the "messed up" context pane has window decorations with the title "&Kontext". However once Amarok becomes responsive (i.e. no longer "(not responding)"), these window decorations disappear and the pane can no longer be moved.
On my machine, this is the case for the other two panes as well. They always stay at a fixed position relative to the screen and always in foreground w.r.t. the rest of the main Amarok window, but minimize along with it.
Comment 10 Mark Kretschmann 2013-05-13 09:52:08 UTC
Git commit 0eabe453e164ab59a5b06848da86895fdaaf8286 by Mark Kretschmann.
Committed on 13/05/2013 at 10:35.
Pushed by markey into branch 'master'.

Added a function for resetting the GUI layout back to default state.
FIXED-IN: 2.8

M  +2    -0    ChangeLog
M  +61   -2    src/MainWindow.cpp
M  +3    -4    src/MainWindow.h

http://commits.kde.org/amarok/0eabe453e164ab59a5b06848da86895fdaaf8286